Bug 111423 - [CI][DRMTIP] igt@kms_cursor_legacy@* - SKIP - No second valid output found
Summary: [CI][DRMTIP] igt@kms_cursor_legacy@* - SKIP - No second valid output found
Status: RESOLVED DUPLICATE of bug 110580
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: low minor
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-19 08:13 UTC by Lakshmi
Modified: 2019-09-05 10:26 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: display/DP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-08-19 08:13:53 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic.html
Test requirement not met in function __real_main1364, file ../tests/kms_cursor_legacy.c:1383:
Test requirement: !(n >= display.n_pipes)
Starting subtest: cursorB-vs-flipB-atomic
Test requirement not met in function find_connected_pipe, file ../tests/kms_cursor_legacy.c:241:
Test requirement: found
No second valid output found
Subtest cursorB-vs-flipB-atomic: SKIP (0.000s)

Is this a duplicate of Bug 110940? fi-icl-u4 has two displays connected.
Comment 1 CI Bug Log 2019-08-19 08:15:29 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u4: igt@kms_cursor_legacy@* - SKIP - No second valid output found
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-legacy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-cursor-vs-flip-legacy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipa-toggle.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursora-vs-flipb-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipa-atomic-transitions.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-nonblocking-modeset-vs-cursor-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipa-atomic-transitions-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-flip-vs-cursor-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipa-legacy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipa-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-long-nonblocking-modeset-vs-cursor-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-cursor-vs-flip-atomic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipb-toggle.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-flip-vs-cursor-legacy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-atomic.html
Comment 2 James Ausmus 2019-08-19 23:08:12 UTC
It looks like whatever is hooked up to the DP-4 connect on FI-ICL-U4 is getting DPCD timeout errors intermittently:

<7> [258.142736] [drm:intel_dp_detect [i915]] [CONNECTOR:224:DP-4]
<7> [258.177949] [drm:drm_dp_dpcd_access] Too many retries, giving up. First error: -5
<7> [258.177953] [drm:drm_helper_probe_single_connector_modes] [CONNECTOR:224:DP-4] disconnected

while sometimes it connects just fine.

This could indicate a bad monitor or cable - What monitor is hooked up? Have we tried a different cable between the system and the monitor, or a different monitor?
Comment 3 James Ausmus 2019-08-19 23:10:04 UTC
*** Bug 111421 has been marked as a duplicate of this bug. ***
Comment 4 Jani Saarinen 2019-08-20 04:44:16 UTC
James, u4 has only eDP2 and type-c ports connected to Chamelium if I am not mistaken. Imre?
Comment 5 Imre Deak 2019-08-20 10:53:41 UTC
(In reply to Jani Saarinen from comment #4)
> James, u4 has only eDP2 and type-c ports connected to Chamelium if I am not
> mistaken. Imre?

Yes, eDP and 2 external outputs connected to Chamelium. Visible (partly) from:
https://intel-gfx-ci.01.org/hardware.html#fi-icl-u4
Comment 6 Arek Hiler 2019-09-05 10:26:48 UTC

*** This bug has been marked as a duplicate of bug 110580 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.