Bug 111571 - [regression] - /usr/bin/ld: /usr/lib/llvm-9/lib/libclangCodeGen.a: error adding symbols: archive has no index; run ranlib to add one
Summary: [regression] - /usr/bin/ld: /usr/lib/llvm-9/lib/libclangCodeGen.a: error addi...
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: All Linux (All)
: not set not set
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
: 111580 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-06 08:12 UTC by Fabio Pedretti
Modified: 2019-09-09 16:36 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Pedretti 2019-09-06 08:12:26 UTC
I get this error when building in Ubuntu eoan/19.10:
/usr/bin/ld: /usr/lib/llvm-9/lib/libclangCodeGen.a: error adding symbols: archive has no index; run ranlib to add one
collect2: error: ld returned 1 exit status

This build regression happened between f8887909c6683986990474b61afd6d4335a69e41 (which was OK) and 1591d1fee5016a21477edec0d2eb6b2d24221952 (failed). I cannot bisect. I added in CC the four developers having commits in this range.

Full build error:
https://launchpadlibrarian.net/440284447/buildlog_ubuntu-eoan-amd64.mesa_19.3~git1909041930.1591d1~oibaf~e_BUILDING.txt.gz
Comment 1 Michel Dänzer 2019-09-06 09:56:16 UTC
That looks like a problem in the libclang-9-dev package, not in Mesa.
Comment 2 Timo Aaltonen 2019-09-06 11:48:27 UTC
and is filed as a distro bug in

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939472
Comment 3 Fabio Pedretti 2019-09-06 11:50:22 UTC
Let's close this one then.
Comment 4 Guru Randhawa 2019-09-06 23:31:51 UTC Comment hidden (spam)
Comment 5 Michel Dänzer 2019-09-09 16:36:34 UTC
*** Bug 111580 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.