Bug 111580 - Building libvulkan_radeon.so against llvm 10 fails with "libLLVMAMDGPUDisassembler.a: error adding symbols: archive has no index"
Summary: Building libvulkan_radeon.so against llvm 10 fails with "libLLVMAMDGPUDisasse...
Status: RESOLVED DUPLICATE of bug 111571
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-06 20:38 UTC by Shmerl
Modified: 2019-09-09 16:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Detailed error log (6.32 KB, text/plain)
2019-09-06 20:38 UTC, Shmerl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shmerl 2019-09-06 20:38:25 UTC
Created attachment 145287 [details]
Detailed error log

I'm trying to build Mesa against libllvm10, using static linking option for llvm:

    -Dshared-llvm=false

That's done on Debian testing, gcc 9.2.1 with llvm build from http://apt.llvm.org/unstable/pool/main/l/llvm-toolchain-snapshot/

I get such error when it's building libvulkan_radeon.so


/usr/bin/ld: /usr/lib/llvm-10/lib/libLLVMAMDGPUDisassembler.a: error adding symbols: archive has no index; run ranlib to add one


See more detailed error attached. Is it a problem with this llvm build or something else?
Comment 1 Shmerl 2019-09-06 21:00:15 UTC
Just tried to build Mesa 19.2.0-rc2 against libllvm 9 (dynamic linking). A similar problem occurs:

FAILED: src/gallium/targets/opencl/libMesaOpenCL.so.1.0.0
...
/usr/bin/ld: /usr/lib/llvm-9/lib/libclangCodeGen.a: error adding symbols: archive has no index; run ranlib to add one
collect2: error: ld returned 1 exit status
Comment 2 Michel Dänzer 2019-09-09 16:36:34 UTC

*** This bug has been marked as a duplicate of bug 111571 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.