Bug 111593 - [CI][BAT] igt@gem_exec_gttfill@basic / igt@gem_exec_parallel@(vcs0|smoke) - incomplete
Summary: [CI][BAT] igt@gem_exec_gttfill@basic / igt@gem_exec_parallel@(vcs0|smoke) - ...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest blocker
Assignee: Mika Kuoppala
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 111647 111653 111662 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-09 07:25 UTC by Martin Peres
Modified: 2019-09-17 07:22 UTC (History)
2 users (show)

See Also:
i915 platform: TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-09 07:25:52 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6845/fi-tgl-u/igt@gem_exec_gttfill@basic.html

<6> [62.934694] Console: switching to colour dummy device 80x25
<6> [62.934738] [IGT] gem_exec_gttfill: executing
<5> [62.944463] Setting dangerous option reset - tainting kernel
<6> [62.946930] [IGT] gem_exec_gttfill: starting subtest basic
<6> [62.948304] gem_exec_gttfil (1077): drop_caches: 4
Comment 1 CI Bug Log 2019-09-09 07:26:17 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@gem_exec_gttfill@basic / igt@gem_exec_parallel@(vcs0|smoke)  - incomplete
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4941/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6845/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6846/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6847/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5173/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4945/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14286/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4947/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14309/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4951/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14310/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14311/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6849/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14312/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14313/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3426/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4953/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4955/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14315/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4956/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6850/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_exec_parallel@vcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_exec_balancer@smoke.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14319/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6851/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4958/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4959/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4960/fi-tgl-u/igt@gem_exec_gttfill@basic.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6852/fi-tgl-u/igt@gem_exec_gttfill@basic.html
Comment 2 CI Bug Log 2019-09-09 07:27:22 UTC
A CI Bug Log filter associated to this bug has been updated:

{- TGL: igt@gem_exec_gttfill@basic / igt@gem_exec_parallel@(vcs0|smoke)  - incomplete -}
{+ TGL: igt@gem_exec_gttfill@basic / igt@gem_exec_parallel@(vcs0|smoke) / igt@gem_close_race@basic-process - incomplete +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6844/fi-tgl-u/igt@gem_close_race@basic-process.html
Comment 3 Chris Wilson 2019-09-09 07:39:54 UTC
Any squawk over netconsole or serial?
Comment 4 Chris Wilson 2019-09-10 12:51:31 UTC
Next clue: https://patchwork.freedesktop.org/patch/329953/?series=66483&rev=1
=> rc6/forcewake is adrift.
Comment 5 Chris Wilson 2019-09-10 16:14:39 UTC
Disabled rc6 -> https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14343/?
No improvement, forcewake ftw.
Comment 6 Chris Wilson 2019-09-10 19:37:57 UTC
(In reply to Chris Wilson from comment #5)
> Disabled rc6 -> https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14343/?
> No improvement, forcewake ftw.

Tried again with an explicit rc6 disable; success.
Comment 7 Chris Wilson 2019-09-10 20:36:56 UTC
Band aid fix,

commit ab37c4d712c8b35c0c1e3237e04fe49f717055a4
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Sep 10 17:16:57 2019 +0100

    drm/i915/tgl: Disable rc6 for debugging
    
    Empirical evidence from CI tells us that our rc6 setup for Tigerlake is
    off. Disable rc6 on tgl temporary so that we gain CI coverage as we
    prepare a fix. It also appears that the BIOS on our tgl leaves rc6
    enabled, so we have to explicitly disable it on init.
    
    References: https://bugs.freedesktop.org/show_bug.cgi?id=111593
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: Mika Kuoppala <mika.kuoppala@linux.intel.com>
    Acked-by: Matthew Auld <matthew.auld@intel.com>
    Link: https://patchwork.freedesktop.org/patch/msgid/20190910161657.23037-1-chris@chris-wilson.co.uk


Should leave pm_rpm failing as a suitable reminder to fix rc6.
Comment 8 Chris Wilson 2019-09-11 07:52:59 UTC
*** Bug 111647 has been marked as a duplicate of this bug. ***
Comment 9 Chris Wilson 2019-09-11 08:31:27 UTC
*** Bug 111653 has been marked as a duplicate of this bug. ***
Comment 10 Chris Wilson 2019-09-11 10:50:27 UTC
*** Bug 111597 has been marked as a duplicate of this bug. ***
Comment 12 CI Bug Log 2019-09-11 11:56:45 UTC
A CI Bug Log filter associated to this bug has been updated:

{- TGL: random tests - incomplete - Resetting chip for hang -}
{+ TGL: random tests - incomplete / timeout - Resetting chip for hang +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@perf_pmu@semaphore-wait-bcs0.html
Comment 13 Chris Wilson 2019-09-11 12:38:26 UTC
*** Bug 111662 has been marked as a duplicate of this bug. ***
Comment 15 CI Bug Log 2019-09-17 07:20:11 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.
Comment 16 Martin Peres 2019-09-17 07:21:22 UTC
(In reply to Chris Wilson from comment #7)
> Band aid fix,
> 
> commit ab37c4d712c8b35c0c1e3237e04fe49f717055a4
> Author: Chris Wilson <chris@chris-wilson.co.uk>
> Date:   Tue Sep 10 17:16:57 2019 +0100
> 
>     drm/i915/tgl: Disable rc6 for debugging
>     
>     Empirical evidence from CI tells us that our rc6 setup for Tigerlake is
>     off. Disable rc6 on tgl temporary so that we gain CI coverage as we
>     prepare a fix. It also appears that the BIOS on our tgl leaves rc6
>     enabled, so we have to explicitly disable it on init.
>     
>     References: https://bugs.freedesktop.org/show_bug.cgi?id=111593
>     Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
>     Cc: Mika Kuoppala <mika.kuoppala@linux.intel.com>
>     Acked-by: Matthew Auld <matthew.auld@intel.com>
>     Link:
> https://patchwork.freedesktop.org/patch/msgid/20190910161657.23037-1-
> chris@chris-wilson.co.uk
> 
> 
> Should leave pm_rpm failing as a suitable reminder to fix rc6.

I guess this patch and the forcewake ones fixed the issue. I will still keep it open for a bit longer because rc6 was re-enabled and I want to prove that it indeed was well fixed.

Thanks!
Comment 17 CI Bug Log 2019-09-17 07:22:00 UTC
The CI Bug Log issue associated to this bug has been restored.

All the previous filters are now active.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.