Bug 111643 - [CI][RESUME] igt@kms_big_fb@linear-(8|16|32)bpp-rotate-(180|0) - fail - Failed assertion: (dst_pitch) < (1 << 15)
Summary: [CI][RESUME] igt@kms_big_fb@linear-(8|16|32)bpp-rotate-(180|0) - fail - Faile...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 111738 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-11 06:55 UTC by Martin Peres
Modified: 2019-10-16 12:34 UTC (History)
2 users (show)

See Also:
i915 platform: TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-11 06:55:54 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_big_fb@linear-32bpp-rotate-180.html

Starting subtest: linear-32bpp-rotate-180
(kms_big_fb:1149) intel_batchbuffer-CRITICAL: Test assertion failure function intel_blt_copy, file ../lib/intel_batchbuffer.c:430:
(kms_big_fb:1149) intel_batchbuffer-CRITICAL: Failed assertion: (dst_pitch) < (1 << 15)
(kms_big_fb:1149) intel_batchbuffer-CRITICAL: error: 65536 >= 32768
Comment 2 Ville Syrjala 2019-09-16 12:11:34 UTC
Missing rendercopy in igt -> try to use blitter instead -> fail due to blitter stride too big.
Comment 3 Mika Kahola 2019-09-18 13:00:23 UTC
With the patch https://patchwork.freedesktop.org/patch/331203/?series=66769&rev=2 merged to IGT the tests igt@kms_big_fb@linear-(8|16|32)bpp-rotate-(180|0) succeeds. 

kms_big_fb --run-subtest linear-8bpp-rotate-0
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-8bpp-rotate-0
Max usable framebuffer size for format C8  (0x20203843) / modifier 0x0: 16384x16384
Subtest linear-8bpp-rotate-0: SUCCESS (1,150s)

kms_big_fb --run-subtest linear-16bpp-rotate-0
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-16bpp-rotate-0
Max usable framebuffer size for format RG16(0x36314752) / modifier 0x0: 16384x16384
Subtest linear-16bpp-rotate-0: SUCCESS (1,291s)

kms_big_fb --run-subtest linear-32bpp-rotate-0
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-32bpp-rotate-0
Max usable framebuffer size for format XR24(0x34325258) / modifier 0x0: 16384x16384
Subtest linear-32bpp-rotate-0: SUCCESS (1,602s)
kms_big_fb --run-subtest linear-8bpp-rotate-180
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-8bpp-rotate-180
Max usable framebuffer size for format C8  (0x20203843) / modifier 0x0: 16384x16384
Subtest linear-8bpp-rotate-180: SUCCESS (1,154s)

kms_big_fb --run-subtest linear-16bpp-rotate-180
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-16bpp-rotate-180
Max usable framebuffer size for format RG16(0x36314752) / modifier 0x0: 16384x16384
Subtest linear-16bpp-rotate-180: SUCCESS (1,273s)

kms_big_fb --run-subtest linear-32bpp-rotate-180
IGT-Version: 1.24-g0e9510b8 (x86_64) (Linux: 5.3.0-CI-CI_DRM_6913+ x86_64)
Max driver framebuffer size 16384x16384
RAM: 15765 MiB, GPU address space: 268435456 MiB, GGTT mappable size: 256 MiB
Starting subtest: linear-32bpp-rotate-180
Max usable framebuffer size for format XR24(0x34325258) / modifier 0x0: 16384x16384
Subtest linear-32bpp-rotate-180: SUCCESS (1,598s)

Could we close this one?
Comment 4 Jani Saarinen 2019-09-18 13:16:28 UTC
author	Kalamarz, Lukasz <lukasz.kalamarz@intel.com
committer	Chris Wilson <chris@chris-wilson.co.uk
commit	c78b9959fa4050725b16d55a5e56315884a2753d
tree	3bb8adfad2ca92a01ba86af1744f106095087819


lib/rendercopy/tgl: Add support for gem_render_* tests on TGL
Previous generations didn't use SWSB dependency tracking.
For that reason shader was adopted to handle that on TGL.

FIXME: Some tests still have to be fixed, currently working:
      gem_render_copy @linear @x-tiled @y-tiled @yf-tiled
      gem_render_copy_redux
      gem_render_linear_blits @basic
      gem_render_tiled_blits @basic
Signed-off-by: Lukasz Kalamarz <lukasz.kalamarz@intel.com>
Signed-off-by: Zbigniew Kempczyński <zbigniew.kempczynski@intel.com>
Cc: Katarzyna Dec <katarzyna.dec@intel.com>
Reviewed-by: Katarzyna Dec <katarzyna.dec@intel.com>
Acked-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 6 Jani Saarinen 2019-09-20 03:40:38 UTC
*** Bug 111738 has been marked as a duplicate of this bug. ***
Comment 7 Jani Saarinen 2019-09-20 07:05:58 UTC
Fix was in on IGT_5189. Need to wait to see and close if fixed.
Comment 8 Martin Peres 2019-10-16 12:34:26 UTC
(In reply to Jani Saarinen from comment #7)
> Fix was in on IGT_5189. Need to wait to see and close if fixed.

Looks good, thanks!
Comment 9 CI Bug Log 2019-10-16 12:34:33 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.