Bug 111738 - [CI][DRMTIP] igt@kms_big_fb@[xy]-tiled-64bpp-rotate-(180|0) - fail - Failed assertion: (dst_pitch) < (1 << 15)
Summary: [CI][DRMTIP] igt@kms_big_fb@[xy]-tiled-64bpp-rotate-(180|0) - fail - Failed ...
Status: RESOLVED DUPLICATE of bug 111643
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-18 15:25 UTC by Lakshmi
Modified: 2019-10-16 13:32 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-09-18 15:25:27 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_big_fb@x-tiled-64bpp-rotate-0.html
Starting subtest: x-tiled-64bpp-rotate-0
(kms_big_fb:1071) intel_batchbuffer-CRITICAL: Test assertion failure function intel_blt_copy, file ../lib/intel_batchbuffer.c:430:
(kms_big_fb:1071) intel_batchbuffer-CRITICAL: Failed assertion: (dst_pitch) < (1 << 15)
(kms_big_fb:1071) intel_batchbuffer-CRITICAL: error: 32768 >= 32768
Subtest x-tiled-64bpp-rotate-0 failed.

Bug 111643 is fixed for igt@kms_big_fb@linear-(8|16|32)bpp-rotate-(180|0) failures.
Comment 2 Jani Saarinen 2019-09-18 15:33:00 UTC
IGT used on this IGT_5183 but was fix needed on IGT on this run yet?
Comment 3 Jani Saarinen 2019-09-20 03:40:38 UTC
So dup of 111643

*** This bug has been marked as a duplicate of bug 111643 ***
Comment 4 Lakshmi 2019-09-20 05:52:07 UTC
(In reply to Jani Saarinen from comment #3)
> So dup of 111643
> 
> *** This bug has been marked as a duplicate of bug 111643 ***

Author	Kalamarz, Lukasz <lukasz.kalamarz@intel.com
committer	Chris Wilson <chris@chris-wilson.co.uk
commit	c78b9959fa4050725b16d55a5e56315884a2753d
tree	3bb8adfad2ca92a01ba86af1744f106095087819


lib/rendercopy/tgl: Add support for gem_render_* tests on TGL
Previous generations didn't use SWSB dependency tracking.
For that reason shader was adopted to handle that on TGL.

FIXME: Some tests still have to be fixed, currently working:
      gem_render_copy @linear @x-tiled @y-tiled @yf-tiled
      gem_render_copy_redux
      gem_render_linear_blits @basic
      gem_render_tiled_blits @basic
Signed-off-by: Lukasz Kalamarz <lukasz.kalamarz@intel.com>
Signed-off-by: Zbigniew Kempczyński <zbigniew.kempczynski@intel.com>
Cc: Katarzyna Dec <katarzyna.dec@intel.com>
Reviewed-by: Katarzyna Dec <katarzyna.dec@intel.com>
Acked-by: Chris Wilson <chris@chris-wilson.co.uk>

Jani, Above is the commit that fixed bug 111643. It's mentioned that igt@kms_big_fb@[xy]-* still needs a fix. So, I have created a new bug.
Comment 5 CI Bug Log 2019-09-27 14:30:21 UTC
A CI Bug Log filter associated to this bug has been updated:

{- TGL: igt@kms_big_fb@[xy]-tiled-64bpp-rotate-(180|0) - fail -  Failed assertion: (dst_pitch) &lt; (1 &lt;&lt; 15) -}
{+ TGL: igt@kms_big_fb@[xy]-tiled-64bpp-rotate-(180|0) - fail -  Failed assertion: (dst_pitch) &lt; (1 &lt;&lt; 15) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6963/re-tgl1-display/igt@kms_big_fb@y-tiled-64bpp-rotate-0.html
Comment 6 CI Bug Log 2019-10-16 13:32:11 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.