Bug 111683 - SPIR-V shader causes display freeze
Summary: SPIR-V shader causes display freeze
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: unspecified
Hardware: Other All
: not set not set
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-13 10:50 UTC by Alastair Donaldson
Modified: 2019-09-18 20:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Amber test that exposes the problem (533.95 KB, text/plain)
2019-09-13 10:50 UTC, Alastair Donaldson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alastair Donaldson 2019-09-13 10:50:43 UTC
Created attachment 145346 [details]
Amber test that exposes the problem

Doing:

amber -d killer.amber

causes my machine to lock up (the display freezes, then goes into a pretty cool and crazy scramble of colours).

Build: Mesa 19.2.0-devel (git-2eace10c62) (Debug)
Device: Radeon RX Vega

I expect this is related to https://bugs.freedesktop.org/show_bug.cgi?id=111147 - that was a highly reduced shader.  I have included the unreduced shader in the hope that the issue is less likely to be sensitive to small changes in shader compilation.

I have tried enabling amdgpu.gpu_recovery=1 but this doesn't seem to help.
Comment 1 GitLab Migration User 2019-09-18 20:11:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/872.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.