Bug 111817 - workqueue: PF_MEMALLOC task 134(kswapd0) is flushing !WQ_MEM_RECLAIM events:gen6_pm_rps_work
Summary: workqueue: PF_MEMALLOC task 134(kswapd0) is flushing !WQ_MEM_RECLAIM events:g...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 111943 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-25 19:24 UTC by Laurent Bonnaud
Modified: 2019-10-09 18:26 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Full kernel log (74.09 KB, text/plain)
2019-09-25 19:27 UTC, Laurent Bonnaud
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bonnaud 2019-09-25 19:24:37 UTC
Bug description:

The kernel output a WARNING related to the i915 driver

System environment:
-- chipset: Intel(R) Core(TM) i5-7260U
-- xserver: 2:1.20.4-1ubuntu3
-- mesa: 19.0.8-0ubuntu0~19.04.1
-- libdrm: 2.4.97-1ubuntu1
-- kernel: Linux xxx 5.3.1-050301-generic #201909210632 SMP Sat Sep 21 06:34:27 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
-- Linux distribution: Ubuntu 19.04 with mainline kernel
-- Machine or mobo model: NUC7i5BNB
-- Display connector: HDMI

Reproducing steps:

I use the Plasma desktop on this system but cannot tell precisely what I was doing when the WARNING occurred.

Additional info:

[112602.597933] ------------[ cut here ]------------
[112602.597968] workqueue: PF_MEMALLOC task 134(kswapd0) is flushing !WQ_MEM_RECLAIM events:gen6_pm_rps_work [i915]
[112602.597975] WARNING: CPU: 0 PID: 134 at kernel/workqueue.c:2598 check_flush_dependency+0xa7/0x140
[112602.597975] Modules linked in: ipt_REJECT nf_reject_ipv4 xt_multiport iptable_filter bpfilter binfmt_misc nls_iso8859_1 dm_crypt snd_soc_skl snd_hda_codec_hdmi snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc intel_rapl_msr snd_soc_sst_dsp snd_soc_acpi_intel_match snd_hda_codec_realtek snd_soc_acpi snd_hda_codec_generic ledtrig_audio snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel mei_hdcp snd_hda_codec snd_hda_core snd_hwdep intel_rapl_common snd_pcm x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel snd_seq_midi snd_seq_midi_event kvm irqbypass snd_rawmidi crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_seq snd_seq_device snd_timer aesni_intel aes_x86_64 wmi_bmof crypto_simd cryptd glue_helper intel_cstate intel_rapl_perf intel_wmi_thunderbolt snd joydev soundcore input_leds btusb rtsx_pci_ms btrtl btbcm memstick btintel ir_rc6_decoder bluetooth mei_me ecdh_generic intel_xhci_usb_role_switch mei intel_pch_thermal roles ecc rc_rc6_mce
[112602.597993]  ite_cir rc_core acpi_pad mac_hid sch_fq_codel ip_tables x_tables autofs4 btrfs zstd_compress raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq libcrc32c raid1 raid0 multipath linear hid_logitech_hidpp uas usb_storage hid_logitech_dj hid_generic usbhid hid i915 rtsx_pci_sdmmc i2c_algo_bit drm_kms_helper nvme e1000e syscopyarea sysfillrect i2c_i801 nvme_core sysimgblt rtsx_pci fb_sys_fops drm ahci libahci wmi video
[112602.598006] CPU: 0 PID: 134 Comm: kswapd0 Not tainted 5.3.1-050301-generic #201909210632
[112602.598007] Hardware name:  /NUC7i5BNB, BIOS BNKBL357.86A.0080.2019.0725.1139 07/25/2019
[112602.598008] RIP: 0010:check_flush_dependency+0xa7/0x140
[112602.598010] Code: 8d 8a 70 0a 00 00 4d 89 e0 48 8d 8b b0 00 00 00 4c 89 ca 48 c7 c7 50 3c b3 b0 48 89 45 e0 c6 05 73 35 75 01 01 e8 f4 13 fe ff <0f> 0b 48 8b 45 e0 eb 0f 4c 89 ef e8 59 8d 00 00 41 f6 45 25 08 75
[112602.598010] RSP: 0018:ffffa8d2c018b7f0 EFLAGS: 00010086
[112602.598011] RAX: 0000000000000000 RBX: ffff8a286cc0ae00 RCX: 0000000000000000
[112602.598012] RDX: 0000000000000063 RSI: ffffffffb1380fc3 RDI: 0000000000000046
[112602.598012] RBP: ffffa8d2c018b810 R08: ffffffffb1380f60 R09: 0000000000000063
[112602.598012] R10: ffffffffb1381340 R11: 00000000b1380fab R12: ffffffffc040c710
[112602.598013] R13: ffff8a286c1a0000 R14: 0000000000000001 R15: ffff8a286eb30700
[112602.598014] FS:  0000000000000000(0000) GS:ffff8a286ea00000(0000) knlGS:0000000000000000
[112602.598014] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[112602.598015] CR2: 00007ff4ece09000 CR3: 0000000016c0a003 CR4: 00000000003606f0
[112602.598015] Call Trace:
[112602.598018]  __flush_work+0x97/0x1d0
[112602.598020]  ? enqueue_hrtimer+0x3d/0x90
[112602.598021]  __cancel_work_timer+0x10e/0x190
[112602.598023]  ? _cond_resched+0x19/0x30
[112602.598024]  ? synchronize_irq+0x3e/0xb0
[112602.598025]  cancel_work_sync+0x10/0x20
[112602.598040]  gen6_disable_rps_interrupts+0x95/0xc0 [i915]
[112602.598052]  gen6_rps_idle+0x1f/0xf0 [i915]
[112602.598066]  intel_gt_park+0x5b/0x60 [i915]
[112602.598078]  __intel_wakeref_put_last+0x1c/0x50 [i915]
[112602.598091]  intel_gt_pm_put+0x44/0x50 [i915]
[112602.598104]  __engine_park+0xc3/0xd0 [i915]
[112602.598115]  __intel_wakeref_put_last+0x1c/0x50 [i915]
[112602.598127]  intel_engine_pm_put+0x44/0x50 [i915]
[112602.598139]  intel_context_exit_engine+0x12/0x20 [i915]
[112602.598155]  i915_request_retire+0x1b2/0x370 [i915]
[112602.598170]  ring_retire_requests+0x53/0x60 [i915]
[112602.598247]  i915_retire_requests+0x49/0x90 [i915]
[112602.598261]  i915_gem_shrink+0xcb/0x4d0 [i915]
[112602.598275]  i915_gem_shrinker_scan+0x64/0x120 [i915]
[112602.598276]  do_shrink_slab+0x150/0x2a0
[112602.598277]  ? shrink_node_memcg+0x2e5/0x370
[112602.598278]  shrink_slab+0xac/0x290
[112602.598279]  shrink_node+0xf4/0x490
[112602.598281]  balance_pgdat+0x319/0x590
[112602.598282]  kswapd+0x1ff/0x3c0
[112602.598283]  ? wait_woken+0x80/0x80
[112602.598285]  kthread+0x104/0x140
[112602.598286]  ? balance_pgdat+0x590/0x590
[112602.598287]  ? kthread_park+0x80/0x80
[112602.598288]  ret_from_fork+0x35/0x40
[112602.598289] ---[ end trace 539d72d1174933f6 ]---
Comment 1 Laurent Bonnaud 2019-09-25 19:27:10 UTC
Created attachment 145515 [details]
Full kernel log
Comment 2 Chris Wilson 2019-09-25 19:52:04 UTC
Not a major worry (false positive), fixed by

commit c7302f204490f3eb4ef839bec228315bcd3ba43f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Aug 8 21:27:58 2019 +0100

    drm/i915: Defer final intel_wakeref_put to process context
Comment 3 Laurent Bonnaud 2019-09-25 19:59:46 UTC
Thanks for the quick answer!

Will this fix appear in a 5.3.x kernel or in the 5.4 kernel?
Comment 4 mailinglists35 2019-09-28 01:26:24 UTC
is this the same bug?
Fedora core 31 up to date on asus laptop




00:02.0 VGA compatible controller [0300]: Intel Corporation Celeron N3350/Pentium N4200/Atom E3900 Series Integrated Graphics Controller [8086:5a84] (rev 0b)
	Subsystem: ASUSTeK Computer Inc. Device [1043:15b0]
	Kernel driver in use: i915
	Kernel modules: i915


Handle 0x0001, DMI type 1, 27 bytes
System Information
	Manufacturer: ASUSTeK COMPUTER INC.
	Product Name: E403NA


[10995.843825] ------------[ cut here ]------------
[10995.843915] workqueue: PF_MEMALLOC task 154(kswapd0) is flushing !WQ_MEM_RECLAIM events:gen6_pm_rps_work [i915]
[10995.843928] WARNING: CPU: 0 PID: 154 at kernel/workqueue.c:2598 check_flush_dependency+0xa0/0x130
[10995.843929] Modules linked in: ipheth nfsv3 nfs_acl rpcsec_gss_krb5 auth_rpcgss nfsv4 dns_resolver nfs lockd grace fscache rfcomm binfmt_misc ccm xt_CHECKSUM xt_MASQUERADE xt_comment bridge stp llc ip6t_REJECT nf_reject_ipv6 ip6t_rpfilter ipt_REJECT nf_reject_ipv4 xt_conntrack ebtable_nat ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat iptable_mangle iptable_raw iptable_security nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c ip_set nfnetlink ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables ppdev parport_pc parport fuse vmw_vsock_vmci_transport vsock vmw_vmci cmac bnep sunrpc vfat fat squashfs zstd_decompress loop bluetooth ecdh_generic ecc uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mc sof_pci_dev snd_sof_intel_hda_common snd_sof_intel_hda snd_sof_intel_byt snd_sof_intel_ipc snd_sof intel_telemetry_pltdrv snd_sof_xtensa_dsp intel_punit_ipc intel_telemetry_core snd_soc_skl joydev
[10995.843974]  x86_pkg_temp_thermal snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc intel_powerclamp snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_codec_hdmi coretemp snd_soc_acpi_intel_match hid_multitouch snd_soc_acpi kvm_intel snd_soc_core mei_hdcp snd_hda_codec_realtek iwlmvm intel_rapl_msr snd_hda_codec_generic mac80211 ledtrig_audio snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel kvm libarc4 snd_hda_codec snd_hda_core snd_hwdep irqbypass intel_cstate iwlwifi snd_seq snd_seq_device intel_rapl_perf cfg80211 snd_pcm asus_nb_wmi asus_wmi wdat_wdt wmi_bmof sparse_keymap snd_timer mei_me idma64 snd rfkill mei intel_xhci_usb_role_switch intel_lpss_pci i2c_i801 roles soundcore processor_thermal_device intel_lpss intel_rapl_common lpc_ich int3403_thermal int3400_thermal intel_soc_dts_iosf asus_wireless acpi_thermal_rel int340x_thermal_zone ashmem_linux(OE) f2fs dm_crypt i915 i2c_algo_bit crct10dif_pclmul drm_kms_helper crc32_pclmul crc32c_intel drm ghash_clmulni_intel serio_raw wmi i2c_hid
[10995.844018]  video pinctrl_broxton pinctrl_intel mmc_block sdhci_pci cqhci sdhci mmc_core lz4 lz4_compress [last unloaded: btrtl]
[10995.844027] CPU: 0 PID: 154 Comm: kswapd0 Tainted: G           OE     5.3.1-300.fc31.x86_64 #1
[10995.844028] Hardware name: ASUSTeK COMPUTER INC. E403NA/E403NA, BIOS E403NA.307 06/26/2018
[10995.844032] RIP: 0010:check_flush_dependency+0xa0/0x130
[10995.844034] Code: 8d 8a 18 07 00 00 49 89 e8 48 8d 8b b0 00 00 00 4c 89 ca 48 c7 c7 c8 09 13 b1 48 89 04 24 c6 05 d3 2c 44 01 01 e8 9e 2b fe ff <0f> 0b 48 8b 04 24 eb 10 4c 89 e7 e8 80 81 00 00 41 f6 44 24 25 08
[10995.844035] RSP: 0018:ffffb3a38019f8d0 EFLAGS: 00010086
[10995.844037] RAX: 0000000000000000 RBX: ffff9be7bb00ae00 RCX: 0000000000000000
[10995.844038] RDX: 0000000000000063 RSI: ffffffffb1be7883 RDI: 0000000000000046
[10995.844039] RBP: ffffffffc03cf760 R08: 00000a002b5edd48 R09: 0000000000000063
[10995.844040] R10: ffffffffb1be7c00 R11: 00000000b1be786b R12: ffff9be7ba641ec0
[10995.844041] R13: ffff9be7bbaae700 R14: 0000000000000001 R15: 0000000000000013
[10995.844043] FS:  0000000000000000(0000) GS:ffff9be7bba00000(0000) knlGS:0000000000000000
[10995.844044] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[10995.844045] CR2: 00000d8a20bab038 CR3: 000000002b40a000 CR4: 00000000003406f0
[10995.844046] Call Trace:
[10995.844054]  __flush_work+0x92/0x1c0
[10995.844058]  ? enqueue_hrtimer+0x36/0x90
[10995.844060]  ? hrtimer_start_range_ns+0x192/0x2d0
[10995.844062]  __cancel_work_timer+0x107/0x190
[10995.844065]  ? _cond_resched+0x15/0x30
[10995.844068]  ? synchronize_irq+0x3a/0xa0
[10995.844108]  ? fwtable_write32+0x1a0/0x210 [i915]
[10995.844143]  gen6_disable_rps_interrupts+0x7f/0xa0 [i915]
[10995.844182]  gen6_rps_idle+0x1a/0xe0 [i915]
[10995.844223]  intel_gt_park+0x54/0x60 [i915]
[10995.844262]  __intel_wakeref_put_last+0x17/0x50 [i915]
[10995.844302]  __engine_park+0xbc/0xd0 [i915]
[10995.844341]  __intel_wakeref_put_last+0x17/0x50 [i915]
[10995.844385]  i915_request_retire+0x1aa/0x370 [i915]
[10995.844429]  ring_retire_requests+0x4e/0x60 [i915]
[10995.844473]  i915_retire_requests+0x43/0x80 [i915]
[10995.844516]  i915_gem_shrink+0x355/0x510 [i915]
[10995.844560]  i915_gem_shrinker_scan+0x63/0x110 [i915]
[10995.844564]  do_shrink_slab+0x154/0x2c0
[10995.844567]  shrink_slab+0xac/0x2b0
[10995.844570]  shrink_node+0xf5/0x490
[10995.844573]  balance_pgdat+0x2db/0x530
[10995.844576]  kswapd+0x1fb/0x3c0
[10995.844580]  ? finish_wait+0x80/0x80
[10995.844583]  kthread+0xfb/0x130
[10995.844584]  ? balance_pgdat+0x530/0x530
[10995.844587]  ? kthread_park+0x80/0x80
[10995.844590]  ret_from_fork+0x35/0x40
[10995.844593] ---[ end trace 8a68e6d5f34b14ad ]---
Comment 5 Ravi Chandra Padmala 2019-10-09 18:26:59 UTC
*** Bug 111943 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.