Bug 111943 - i915: warnings on dmesg with i915 in calltrace
Summary: i915: warnings on dmesg with i915 in calltrace
Status: RESOLVED DUPLICATE of bug 111817
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-09 18:06 UTC by Ravi Chandra Padmala
Modified: 2019-10-09 18:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (250.51 KB, text/plain)
2019-10-09 18:06 UTC, Ravi Chandra Padmala
no flags Details
lsmod output (8.00 KB, text/plain)
2019-10-09 18:06 UTC, Ravi Chandra Padmala
no flags Details
lspci output (2.83 KB, text/plain)
2019-10-09 18:06 UTC, Ravi Chandra Padmala
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ravi Chandra Padmala 2019-10-09 18:06:05 UTC
Created attachment 145689 [details]
dmesg output

I'm running Fedora 31 Beta on a Dell 5540 which has both intel and nvidia graphics. The relevant dmesg logs look like this:

[417623.602097] workqueue: PF_MEMALLOC task 199(kswapd0) is flushing !WQ_MEM_RECLAIM events:gen6_pm_rps_work [i915]
[417623.602102] WARNING: CPU: 9 PID: 199 at kernel/workqueue.c:2598 check_flush_dependency+0xa0/0x130
[417623.602102] Modules linked in: uas usb_storage rc_cec nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_REJECT nf_reject_ipv6 ip6t_rpfilter ipt_REJECT nf_reject_ipv4 xt_conntrack ebtable_nat ebtable_broute ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat iptable_mangle iptable_raw iptable_security nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables rfcomm snd_usb_audio snd_usbmidi_lib snd_rawmidi ccm libcrc32c ip_set nfnetlink cmac bnep sunrpc vfat fat wacom hid_multitouch dell_rbtn iTCO_wdt iTCO_vendor_support sof_pci_dev snd_sof_intel_hda_common snd_sof_intel_hda snd_sof_intel_byt snd_sof_intel_ipc snd_sof snd_sof_xtensa_dsp snd_soc_skl x86_pkg_temp_thermal intel_powerclamp snd_soc_hdac_hda coretemp snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc kvm_intel snd_soc_sst_dsp snd_soc_acpi_intel_match snd_hda_codec_hdmi snd_soc_acpi dell_laptop kvm snd_soc_core mei_hdcp
[417623.602117]  snd_hda_codec_realtek mei_wdt dell_smm_hwmon snd_hda_codec_generic intel_rapl_msr irqbypass ledtrig_audio snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel crct10dif_pclmul crc32_pclmul snd_hda_codec iwlmvm ghash_clmulni_intel snd_hda_core intel_cstate intel_uncore snd_hwdep intel_rapl_perf mac80211 joydev dell_wmi snd_seq dell_smbios dcdbas snd_seq_device wmi_bmof intel_wmi_thunderbolt dell_wmi_descriptor snd_pcm libarc4 uvcvideo btusb btrtl snd_timer btbcm i2c_i801 btintel videobuf2_vmalloc videobuf2_memops iwlwifi snd videobuf2_v4l2 bluetooth videobuf2_common rtsx_pci_ms cfg80211 soundcore videodev memstick thunderbolt mei_me ecdh_generic rfkill idma64 mc mei ecc processor_thermal_device ucsi_acpi typec_ucsi intel_rapl_common intel_lpss_pci intel_lpss intel_pch_thermal intel_soc_dts_iosf typec int3403_thermal int340x_thermal_zone dell_smo8800 intel_hid int3400_thermal sparse_keymap acpi_thermal_rel acpi_pad ipmi_msghandler i915 nouveau ttm i2c_algo_bit drm_kms_helper
[417623.602133]  rtsx_pci_sdmmc mmc_core drm mxm_wmi nvme crc32c_intel nvme_core rtsx_pci serio_raw i2c_hid pinctrl_cannonlake video wmi pinctrl_intel fuse [last unloaded: ip_tables]
[417623.602137] CPU: 9 PID: 199 Comm: kswapd0 Tainted: P        W  OEL    5.3.0-1.fc31.x86_64 #1
[417623.602137] Hardware name: Dell Inc. Precision 5540/07C17G, BIOS 1.1.1 05/31/2019
[417623.602139] RIP: 0010:check_flush_dependency+0xa0/0x130
[417623.602140] Code: 8d 8a 18 07 00 00 49 89 e8 48 8d 8b b0 00 00 00 4c 89 ca 48 c7 c7 c8 09 13 ac 48 89 04 24 c6 05 d3 2c 44 01 01 e8 9e 2b fe ff <0f> 0b 48 8b 04 24 eb 10 4c 89 e7 e8 80 81 00 00 41 f6 44 24 25 08
[417623.602140] RSP: 0018:ffffae3c803c38d0 EFLAGS: 00010086
[417623.602141] RAX: 0000000000000000 RBX: ffff88fe18c0ce00 RCX: 0000000000000000
[417623.602141] RDX: 0000000000000063 RSI: ffffffffacbe7883 RDI: 0000000000000046
[417623.602142] RBP: ffffffffc0821760 R08: 00017bd39273ed59 R09: 0000000000000063
[417623.602142] R10: ffffffffacbe7c00 R11: 00000000acbe786b R12: ffff88fe17fe5f40
[417623.602142] R13: ffff88fe1c42e700 R14: 0000000000000001 R15: 0000000000000013
[417623.602143] FS:  0000000000000000(0000) GS:ffff88fe1c440000(0000) knlGS:0000000000000000
[417623.602143] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[417623.602144] CR2: 00007efe547ec000 CR3: 000000027c40a001 CR4: 00000000003606e0
[417623.602144] Call Trace:
[417623.602147]  __flush_work+0x92/0x1c0
[417623.602149]  ? enqueue_hrtimer+0x36/0x90
[417623.602150]  ? sched_clock+0x5/0x10
[417623.602151]  __cancel_work_timer+0x107/0x190
[417623.602153]  ? _cond_resched+0x15/0x30
[417623.602154]  ? synchronize_irq+0x3a/0xa0
[417623.602167]  ? fwtable_write32+0x1a0/0x210 [i915]
[417623.602177]  gen6_disable_rps_interrupts+0x7f/0xa0 [i915]
[417623.602188]  gen6_rps_idle+0x1a/0xe0 [i915]
[417623.602200]  intel_gt_park+0x54/0x60 [i915]
[417623.602211]  __intel_wakeref_put_last+0x17/0x50 [i915]
[417623.602223]  __engine_park+0xbc/0xd0 [i915]
[417623.602234]  __intel_wakeref_put_last+0x17/0x50 [i915]
[417623.602248]  i915_request_retire+0x1aa/0x370 [i915]
[417623.602262]  ring_retire_requests+0x4e/0x60 [i915]
[417623.602276]  i915_retire_requests+0x43/0x80 [i915]
[417623.602289]  i915_gem_shrink+0x355/0x510 [i915]
[417623.602302]  i915_gem_shrinker_scan+0x63/0x110 [i915]
[417623.602304]  do_shrink_slab+0x154/0x2c0
[417623.602306]  shrink_slab+0xac/0x2b0
[417623.602307]  shrink_node+0xf5/0x490
[417623.602308]  balance_pgdat+0x2db/0x530
[417623.602309]  kswapd+0x1fb/0x3c0
[417623.602311]  ? finish_wait+0x80/0x80
[417623.602312]  kthread+0xfb/0x130
[417623.602313]  ? balance_pgdat+0x530/0x530
[417623.602314]  ? kthread_park+0x80/0x80
[417623.602315]  ret_from_fork+0x35/0x40
[417623.602317] ---[ end trace e039dd2359e64532 ]---
Comment 1 Ravi Chandra Padmala 2019-10-09 18:06:23 UTC
Created attachment 145690 [details]
lsmod output
Comment 2 Ravi Chandra Padmala 2019-10-09 18:06:49 UTC
Created attachment 145691 [details]
lspci output
Comment 3 Chris Wilson 2019-10-09 18:18:18 UTC
Was fixed by commit c7302f204490f3eb4ef839bec228315bcd3ba43f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Aug 8 21:27:58 2019 +0100

    drm/i915: Defer final intel_wakeref_put to process context
Comment 4 Ravi Chandra Padmala 2019-10-09 18:26:59 UTC
Thanks!

*** This bug has been marked as a duplicate of bug 111817 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.