Bug 111985 - [i915] Black monitor screen on boot (NO VGA SIGNAL)
Summary: [i915] Black monitor screen on boot (NO VGA SIGNAL)
Status: RESOLVED DUPLICATE of bug 111966
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: not set blocker
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 112005 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-12 19:37 UTC by Rui Nuno Capela
Modified: 2019-10-15 10:08 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments
dmesg boot log extract - Linux version 5.3.6-test1 (5.84 KB, text/plain)
2019-10-12 20:33 UTC, Rui Nuno Capela
no flags Details
dmesg boot log extract - Linux version 5.3.4-1-default (openSUSE Tumbleweed) (5.37 KB, text/plain)
2019-10-13 08:37 UTC, Rui Nuno Capela
no flags Details
dmesg boot log full - Linux version 5.3.4-1-default (openSUSE Tumbleweed) (737.81 KB, text/plain)
2019-10-14 09:31 UTC, Rui Nuno Capela
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rui Nuno Capela 2019-10-12 19:37:34 UTC
- normal boot: display screen goes dead black as sson the i915 module is loaded (monitor reports NO VGA SINAL);
- with "i915.modeset=0" on bootloader: boots and displays alright but leads to no X desktop session;
- with "nomodeset": boots screen and starts X alright, although extremely slow and unusable.

Occurs on all Linux 5.3 kernels to date (including 5.3.6)
--
openSUSE Tumbleweed: Intel Core i5-7400 Kabylake.
Comment 1 Rui Nuno Capela 2019-10-12 20:33:36 UTC
Created attachment 145719 [details]
dmesg boot log extract - Linux version 5.3.6-test1
Comment 2 Rui Nuno Capela 2019-10-13 08:37:57 UTC
Created attachment 145725 [details]
dmesg boot log extract - Linux version 5.3.4-1-default (openSUSE Tumbleweed)
Comment 3 Rui Nuno Capela 2019-10-13 08:53:27 UTC
Note that the bugger seems to be specific to this 7th. gen integrated processors (KabyLake, i5-7400).

For instance, on an older 4th gen. laptop (Haswell, i7-4500U) with the very same system and kernel configurations (openSUSE Tumbleweed; 5.3.4-1-default, 5.3.6-test1) this bugger does't occur whatsoever.
Comment 4 Lakshmi 2019-10-14 08:30:22 UTC
(In reply to Rui Nuno Capela from comment #1)
> Created attachment 145719 [details]
> dmesg boot log extract - Linux version 5.3.6-test1

(In reply to Rui Nuno Capela from comment #2)
> Created attachment 145725 [details]
> dmesg boot log extract - Linux version 5.3.4-1-default (openSUSE Tumbleweed)

Can you please attach the full log from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?
Comment 5 Rui Nuno Capela 2019-10-14 09:31:41 UTC
Created attachment 145733 [details]
dmesg boot log full - Linux version 5.3.4-1-default (openSUSE Tumbleweed)

> Can you please attach the full log from boot with kernel parameters
> drm.debug=0x1e log_buf_len=4M?

absolutely, here it goes!
thanks
Comment 6 Jani Saarinen 2019-10-14 15:09:42 UTC
Maybe related? 
[    5.856346] [drm:intel_modeset_readout_hw_state [i915]] pipe C data rate 0 num active planes 0
[    5.856366] WARNING: CPU: 1 PID: 313 at drivers/gpu/drm/drm_vblank.c:638 drm_calc_vbltimestamp_from_scanoutpos+0x2c7/0x300 [drm]
[    5.856369] Modules linked in: i915(E+) i2c_algo_bit(E) sr_mod(E) drm_kms_helper(E) syscopyarea(E) sysfillrect(E) sysimgblt(E) fb_sys_fops(E) xhci_pci(E) xhci_hcd(E) serio_raw(E) cdrom(E) usbcore(E) drm(E) video(E)
[    5.856377] CPU: 1 PID: 313 Comm: systemd-udevd Tainted: G            E     5.3.6-test1 #1
[    5.856379] Hardware name: System manufacturer System Product Name/PRIME B250M-C, BIOS 1001 12/11/2017
[    5.856388] RIP: 0010:drm_calc_vbltimestamp_from_scanoutpos+0x2c7/0x300 [drm]
[    5.856391] Code: 43 20 8b 80 78 01 00 00 23 43 50 a8 10 75 1b 48 8b 83 28 03 00 00 48 85 c0 0f 84 6c fd ff ff 48 83 78 28 00 0f 84 61 fd ff ff <0f> 0b e9 5d fd ff ff 48 c7 c7 00 67 3d c0 e8 66 ec ff ff e9 4c fd
[    5.856394] RSP: 0018:ffffb4e2c033b8c8 EFLAGS: 00010002
[    5.856395] RAX: 000000000000003f RBX: ffff9c0b4ff50000 RCX: 0000000000000000
[    5.856397] RDX: 0000000000000000 RSI: ffffffffc03d6738 RDI: 0000000000000001
[    5.856398] RBP: ffffb4e2c033b920 R08: 0000000000000000 R09: ffffffffc03b2560
[    5.856400] R10: 0000000000000000 R11: ffffffffc055b5e0 R12: 0000000000000000
[    5.856401] R13: 0000000000000000 R14: ffffb4e2c033b934 R15: ffff9c0c60282880
[    5.856403] FS:  00007f49b0e4d1c0(0000) GS:ffff9c0c66680000(0000) knlGS:0000000000000000
[    5.856405] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    5.856406] CR2: 00007f1da971d018 CR3: 000000031089e002 CR4: 00000000003606e0
[    5.856407] Call Trace:
[    5.856417]  ? drm_dbg+0x62/0x70 [drm]
[    5.856425]  drm_get_last_vbltimestamp+0x38/0x50 [drm]
[    5.856433]  drm_reset_vblank_timestamp+0x46/0xa0 [drm]
[    5.856440]  drm_crtc_vblank_on+0x72/0xc0 [drm]
[    5.856465]  intel_modeset_setup_hw_state+0x163/0xba0 [i915]
[    5.856474]  ? drm_modeset_lock_all_ctx+0xc9/0xd0 [drm]
[    5.856499]  intel_modeset_init+0x508/0xfa0 [i915]
[    5.856525]  ? fwtable_write32+0x44/0x180 [i915]
[    5.856553]  ? intel_gmbus_setup+0x22c/0x2e0 [i915]
[    5.856577]  i915_driver_load+0x481/0x560 [i915]
[    5.856580]  ? __kernfs_new_node+0x167/0x1c0
[    5.856603]  i915_pci_probe+0x3f/0x110 [i915]
[    5.856607]  ? __pm_runtime_resume+0x44/0x50
[    5.856609]  local_pci_probe+0x3d/0x70
[    5.856611]  ? pci_match_device+0xd2/0x100
[    5.856613]  pci_device_probe+0xd9/0x190
[    5.856615]  really_probe+0xf3/0x380
[    5.856617]  driver_probe_device+0x58/0xd0
[    5.856619]  device_driver_attach+0x4e/0x60
[    5.856620]  __driver_attach+0x91/0x140
[    5.856622]  ? device_driver_attach+0x60/0x60
[    5.856624]  bus_for_each_dev+0x61/0x90
[    5.856626]  bus_add_driver+0x174/0x1e0
[    5.856628]  driver_register+0x67/0xb0
[    5.856630]  ? 0xffffffffc0761000
[    5.856632]  do_one_initcall+0x47/0x17f
[    5.856634]  ? __vunmap+0x20f/0x240
[    5.856636]  ? kmem_cache_alloc+0xea/0x180
[    5.856638]  do_init_module+0x51/0x200
[    5.856640]  load_module+0x15cd/0x1770
[    5.856643]  ? __do_sys_finit_module+0xaa/0xe0
[    5.856645]  __do_sys_finit_module+0xaa/0xe0
[    5.856647]  do_syscall_64+0x50/0x120
[    5.856650]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[    5.856656] RIP: 0033:0x7f49b17a7059
[    5.856660] Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d f7 5d 0c 00 f7 d8 64 89 01 48
[    5.856663] RSP: 002b:00007ffc7fa790c8 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
[    5.856665] RAX: ffffffffffffffda RBX: 00005609402bd3c0 RCX: 00007f49b17a7059
[    5.856666] RDX: 0000000000000000 RSI: 00007f49b190b89d RDI: 0000000000000013
[    5.856668] RBP: 0000000000020000 R08: 0000000000000000 R09: 000056094029e1a0
[    5.856669] R10: 0000000000000013 R11: 0000000000000246 R12: 00007f49b190b89d
[    5.856671] R13: 0000000000000000 R14: 000056094029bff0 R15: 00005609402bd3c0
[    5.856673] ---[ end trace 9b11657452f92555 ]---
Comment 7 Ville Syrjala 2019-10-14 15:17:54 UTC
[    5.841869] [drm:parse_ddi_port [i915]] port E trying to use the same AUX CH (0x40) as port A, disabling port E DP support

Probably a duplicate of bug 111966.

*** This bug has been marked as a duplicate of bug 111966 ***
Comment 8 Rui Nuno Capela 2019-10-15 07:59:20 UTC
Confirmed fixed in bug 111966:

[PATCH] drm/i915: Favor last VBT child device with conflicting AUX ch/DDC pin
attachment 145712 [details] [review]

Merged and tested on (uname -srv):
Linux 5.3.6-test1 #1 SMP PREEMPT Tue Oct 15 08:29:55 WEST 201
(openSUSE Tumbleweed - Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz)

Thanks
Comment 9 demanuel 2019-10-15 10:08:51 UTC
*** Bug 112005 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.