Bug 12085 - Using "grp:(ctrl|alt)_shift_toggle" stops propagating (ctrl|alt)_shift+something events
Summary: Using "grp:(ctrl|alt)_shift_toggle" stops propagating (ctrl|alt)_shift+someth...
Status: RESOLVED DUPLICATE of bug 865
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: 7.2 (2007.02)
Hardware: All All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-21 06:46 UTC by Martin Kase
Modified: 2007-08-21 07:13 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kase 2007-08-21 06:46:14 UTC
If I am using settings bellow I am not able to use Ctrl+Shift+something shortcuts in any of my favourite programs. The same is for Ctrl+Alt+something combinations.

...
Option  "XkbLayout" "us,cz_qwerty"
Option  "XkbOptions" "grp:ctrl_shift_toggle"
...

Nice behaviour will be if driver waits for release of (Ctrl|Alt)+Shift and if there won't be any key pressed in short past it will generate event ctrl_shift_toggle.

Thaks a lot for solving it.
Comment 1 Daniel Stone 2007-08-21 07:13:56 UTC

*** This bug has been marked as a duplicate of bug 865 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.