Bug 12270 - Assertion `n == 0' failed in drawImageMaskPrescaled
Summary: Assertion `n == 0' failed in drawImageMaskPrescaled
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-03 08:11 UTC by Keenan Pepper
Modified: 2007-09-03 08:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
PDF file that makes Evince crash (134.34 KB, application/pdf)
2007-09-03 08:12 UTC, Keenan Pepper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keenan Pepper 2007-09-03 08:11:13 UTC
When I view the attached PDF file with Evince, it displays correctly for about one second, but then it crashes with the following output:

n = 1 (39 40 -1)
evince: CairoOutputDev.cc:943: void CairoOutputDev::drawImageMaskPrescaled(GfxState*, Object*, Stream*, int, int, GBool, GBool): Assertion `n == 0' failed.
Aborted (core dumped)

I think this is the same as http://bugzilla.gnome.org/show_bug.cgi?id=377785 but someone said they don't want it there because it's a Cairo bug.
Comment 1 Keenan Pepper 2007-09-03 08:12:55 UTC
Created attachment 11399 [details]
PDF file that makes Evince crash
Comment 2 Chris Wilson 2007-09-03 08:34:54 UTC

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.