Bug 12506 - input-vmmouse-12.4.2 moves the cursor correctly, but X sees incorrectly scaled movements
Summary: input-vmmouse-12.4.2 moves the cursor correctly, but X sees incorrectly scale...
Status: RESOLVED DUPLICATE of bug 13552
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/other (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-21 01:29 UTC by Mike Auty
Modified: 2008-01-15 16:50 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Auty 2007-09-21 01:29:20 UTC
Hi,

I recently upgraded a vmware machine to xorg-x11-7.3.  Previously I had been letting Xorg start without an xorg.conf which detected everything pretty much fine.  However, I decided during the upgrade to start using the vmmouse driver.  After getting a suitable config from Xorg -configure, I started using it.

The cursor showed up and move around the screen OK, but the fluxbox menu was always appearing in the bottom right corner, and moving the cursor over the entries seemed to have no effect.  I then changed to twm, and discovered courtesy of mouse focus, that the mouse movements appear to only be registered in the topmost 3 or 4 pixels, and in the leftmost 3 or 4 pixels of the screen.

Having seen a similarly unusual top-left issue with linuxwacom under xorg-server-1.4, it suggested to me that this is probably some scaling issue.

I haven't yet had a chance to test this issue out on xorg-server-1.3, since trying to leave the X environment without using a mouse tends to require Ctrl+Alt+Backspace, which seems to cause vmware to crash and take the host X with it...  5:\

Anyway, I'd be happy to test out any patches or fixes you'd like, and if there's any more information I can provide please just let me know...  5:)
Comment 1 Brice Goglin 2007-09-21 02:42:39 UTC
Same problem has been reported by Joerg Platte at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=442853
Comment 2 Dan Finn 2007-09-24 18:44:46 UTC
I'm seeing this same issue on Debian lenny/sid when running in VMWare Player.  This issue recently appeared and I believe it was because they updated the xserver-xorg-input-vmmouse.  All packages are up to date.

I'm running:
xorg 7.3+2
xserver-xorg-core 1.4-2
xserver-xorg-input-vmmouse 12.4.2-3

Comment 3 Peter Hutterer 2008-01-15 16:50:00 UTC
See the interim solution attached to #13552 

*** This bug has been marked as a duplicate of bug 13552 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.