Bug 13552 - vmmouse doesn't work with git Xserver 1127
vmmouse doesn't work with git Xserver 1127
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/VMWare
git
Other All
: medium normal
Assigned To: Nolan Leake
Xorg Project Team
: NEEDINFO
: 12506 (view as bug list)
Depends on: 10324
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 15:12 UTC by Jeremy Katz
Modified: 2009-12-29 07:32 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Katz 2007-12-06 15:12:03 UTC
With a git X server from 20071127, the vmmouse module loads fine but the pointer doesn't seem to respond at all.  This is with qemu's vmmouse emulation, but nothing has changed there and going back to an earlier X server (1.3) with the same qemu has things work fine.
Comment 1 Peter Hutterer 2007-12-06 20:09:36 UTC
(In reply to comment #0)
> With a git X server from 20071127, the vmmouse module loads fine but the
> pointer doesn't seem to respond at all.  This is with qemu's vmmouse emulation,
> but nothing has changed there and going back to an earlier X server (1.3) with
> the same qemu has things work fine.

do you have a debug server installed? I had a look at VMMouseDoPostEvent and it seems to call the API  correctly. can you step through and determine whether the problem is in the driver or the server?

Comment 2 Jeremy Katz 2008-01-02 12:27:33 UTC
Aha, I see what it is.  With the  new xinput ABI, conversion_proc is never being called.  See xserver commit 60ea7b51fe2b8a19a08b63db48504971a7a50ee6 and then there's also a thread from Debian with a hacky patch at http://groups.google.com/group/linux.debian.maint.x/browse_thread/thread/9c2ecc22fba0f03a
Comment 3 Peter Hutterer 2008-01-02 15:29:03 UTC
Until #10324 is fixed, this patch is a good solution.
Comment 4 Jeremy Katz 2008-01-02 16:53:05 UTC
Yeah, I've gone ahead and added it to the Fedora package for now, but getting the patch from 10324 or similar would definitely make things nicer (and allow for other nice things). 
Comment 5 Timo Aaltonen 2008-01-07 01:20:04 UTC
is this a dupe of bug 12506?
https://bugs.freedesktop.org/show_bug.cgi?id=12506
Comment 6 Timo Aaltonen 2008-01-07 01:23:59 UTC
Peter, see bug #10324, there's a patch now.
Comment 7 Peter Hutterer 2008-01-15 16:50:00 UTC
*** Bug 12506 has been marked as a duplicate of this bug. ***
Comment 8 Peter Hutterer 2008-02-28 19:23:50 UTC
(In reply to comment #0)
> With a git X server from 20071127, the vmmouse module loads fine but the
> pointer doesn't seem to respond at all.  This is with qemu's vmmouse emulation,
> but nothing has changed there and going back to an earlier X server (1.3) with
> the same qemu has things work fine.
> 

magnus has merged his patches into master. Could you please verify whether the problem persists?
Comment 9 Michel Dänzer 2009-12-29 07:32:46 UTC
Seems to work fine with current xserver Git in VMware Workstation.