Bug 12661 - PDFs with layers
Summary: PDFs with layers
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL: http://www.bfs.admin.ch/bfs/portal/de...
Whiteboard:
Keywords:
Depends on:
Blocks: 4925
  Show dependency treegraph
 
Reported: 2007-10-03 06:43 UTC by Roger Luethi
Modified: 2009-11-18 08:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
PDF with layers as described in report, just in case the URL dies (104.98 KB, application/pdf)
2007-10-03 06:45 UTC, Roger Luethi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Luethi 2007-10-03 06:43:08 UTC
This document is a statistic issued by the Swiss government. According to its metadata, it was produced in September 2007 with Adobe InDesign CS2 (4.0.2).

The document uses several layers. The Acrobat Reader does not show some of the layers by default, but all free readers I tried did, resulting in a garbled display (the difference is very obvious).

I tried:
* Adobe Reader 7.0.8
* evince 0.8.3 (with poppler 0.5.4)
* evince 2.20.0 (with poppler 0.6) (Ubuntu Tribe 5 + updates)
* xpdf 3.01
* kpdf 0.5.7
Comment 1 Roger Luethi 2007-10-03 06:45:00 UTC
Created attachment 11878 [details]
PDF with layers as described in report, just in case the URL dies
Comment 2 Brad Hards 2007-11-06 00:23:37 UTC
OK, the subject PDF is using Optional Content Groups.

This is the relevant part (I think) of the document:
17 0 obj<</ViewerPreferences<</Direction/L2R>>/.../OCProperties<</D<</RBGroups[]/ON[23 0 R 24 0 R 25 0 R]/OFF[18 0 R 19 0 R 20 0 R 21 0 R 22 0 R 26 0 R]/Order 29 0 R>>/OCGs[18 0 R 19 0 R 20 0 R 21 0 R 22 0 R 23 0 R 24 0 R 25 0 R 26 0 R]>>/Type/Catalog>>
endobj
18 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Hilfslinien und Raster)/Type/OCG>>
endobj
19 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(LOGO EDI BFS I)/Type/OCG>>
endobj
20 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(LOGO EDI BFS F)/Type/OCG>>
endobj
21 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Kopf F)/Type/OCG>>
endobj
22 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Layout F)/Type/OCG>>
endobj
23 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(LOGO EDI BFS D)/Type/OCG>>
endobj
24 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Kopf D)/Type/OCG>>
endobj
25 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Layout D)/Type/OCG>>
endobj
26 0 obj<</Intent 27 0 R/Usage 28 0 R/Name(Information)/Type/OCG>>
endobj
27 0 obj[/View/Design]
endobj
28 0 obj<</CreatorInfo<</Subtype/Artwork/Creator(Adobe InDesign CS2 \(4.0.2\))>>>>
endobj

We need to think about how to represent that in poppler...
Comment 3 Brad Hards 2007-12-02 22:56:25 UTC
Bug 4925 has a related problem (for OptionalContent that is only ON for Print and Export).

It isn't really a duplicate, but we need the basic OC support before we can fix 4925
Comment 4 Carlos Garcia Campos 2009-11-18 08:24:12 UTC
This seems to be fixed since poppler 0.11. Feel free to reopen it if the problem is present for you with current poppler. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.