Bug 1274 - Add si_LK locale to X
Summary: Add si_LK locale to X
Status: CLOSED DUPLICATE of bug 1544
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: unspecified
Hardware: All All
: high normal
Assignee: Xorg Project Team
QA Contact:
URL: http://www.linux.lk/~anuradha/si_LK.p...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-01 21:59 UTC by Anuradha Ratnaweera
Modified: 2011-10-15 16:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Adds si_LK.UTF-8 locale (1.79 KB, patch)
2004-09-01 22:01 UTC, Anuradha Ratnaweera
no flags Details | Splinter Review
Clean patch for the latest CVS. (1.84 KB, patch)
2004-09-08 21:57 UTC, Anuradha Ratnaweera
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Anuradha Ratnaweera 2004-09-01 21:59:15 UTC
Currently, si_LK.UTF-8 is not in X locale.dir or compose.dir files.  This is a
trivial patch which adds this locale, so that the patches we submit to upper
layers (GTK/KDE etc) will work without having to patch anything.

Presently, we run the following script to edit compose.dir, locale.dir and
locale.alias files.

http://cvs.linux.lk/cgi-bin/cvsweb/sinhala/locale/install.sh

Please apply.

Thanks.
Comment 1 Anuradha Ratnaweera 2004-09-01 22:01:56 UTC
Created attachment 813 [details] [review]
Adds si_LK.UTF-8 locale


This is a trivial patch.  Please apply to all branches if possible.
Comment 2 Anuradha Ratnaweera 2004-09-07 05:08:18 UTC
Please consider adding this patch (which is small, doesn't touch anything
critical, and doesn't break anything) before the release.

Thanks.
Comment 3 Anuradha Ratnaweera 2004-09-08 21:57:41 UTC
Created attachment 839 [details] [review]
Clean patch for the latest CVS.


The patch submitted earlier was for XFree86.  A lot has changed since the fork.
 This should apply cleanly to x.org tree.
Comment 4 Anuradha Ratnaweera 2004-10-05 22:22:54 UTC

*** This bug has been marked as a duplicate of 1544 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.