Bug 13100 - Gtkradiant crashes with radeon driver
Gtkradiant crashes with radeon driver
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: General
unspecified
x86 (IA32) Linux (All)
: medium major
Assigned To: Default DRI bug account
:
: 13809 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 10:40 UTC by Jose Rodriguez
Modified: 2007-12-28 11:07 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jose Rodriguez 2007-11-05 10:40:55 UTC
Hardware: 

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Software:
Debian testing
libgl1-mesa-dri 7.0.1-2
xserver-xorg-video-ati 6.6.193-3

Gtkradiant (a 3D games map editor: http://www.qeradiant.com/cgi-bin/trac.cgi) crashes when using radeon driver. Program usually fires up, and after some work  it crashes. Other times it just crashes as soon as loading a map.

Backtrace:

This GDB was configured as "i486-linux-gnu"...
setUsing host libthread_db library "/lib/libthread_db.so.1".
(gdb) set pagination 0
(gdb) run
Starting
program: /home/jcarlos/software/other/GtkRadiant_old/install/radiant.x8
6 Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread 0xb718c6c0 (LWP 5135)]
radiant.x86: vbo/vbo_split_inplace.c:97: flush_vertex: Assertion
`max_index >= m in_index' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb718c6c0 (LWP 5135)]
0xb741b7d6 in raise () from /lib/libc.so.6
(gdb) thread apply all bt full

Thread 1 (Thread 0xb718c6c0 (LWP 5135)):
#0  0xb741b7d6 in raise () from /lib/libc.so.6
No symbol table info available.
#1  0xb741d0f1 in abort () from /lib/libc.so.6
No symbol table info available.
#2  0xb7414b50 in __assert_fail () from /lib/libc.so.6
No symbol table info available.
#3  0xb6a745b1 in flush_vertex (split=0xbf974840) at
#vbo/vbo_split_inplace.c:97
        min_index = 0
        max_index = 5135
        __PRETTY_FUNCTION__ = "flush_vertex"
#4  0xb6a74a3e in vbo_split_inplace (ctx=0x8ac8518,
#arrays=0x8b11dd8, prim=0xbf9
74ba0, nr_prims=1, ib=0x0, min_index=0, max_index=4294967295,
draw=0xb69c9970 <_ tnl_draw_prims>, limits=0xbf974ad8) at
vbo/vbo_split_inplace.c:255 split = {ctx = 0x8ac8518, array =
0x8b11dd8, prim = 0xbf974ba0, nr_prims = 1, ib = 0x0, min_index =
0, max_index = 4294967295, draw = 0xb69c9970 <_tnl_d raw_prims>,
limits = 0xbf974ad8, dstprim = {{mode = 6, indexed = 0, begin = 1,
e nd = 1, weak = 0, pad = 0, start = 0, count = 0}, {mode = 0,
indexed = 0, begin = 0, end = 0, weak = 0, pad = 0, start = 0,
count = 0} <repeats 31 times>}, dstp rim_nr = 1}
#5  0xb69c9ad9 in _tnl_draw_prims (ctx=0x8ac8518,
#arrays=0x8b11dd8, prim=0xbf974
ba0, nr_prims=1, ib=0x0, min_index=0, max_index=4294967295) at
tnl/t_draw.c:384 limits = {max_verts = 3000, max_indices =
4294967295, max_vb_size = 4294 967295}
        tnl = (TNLcontext *) 0x8b23688
#6  0xb69c2ce5 in vbo_exec_DrawArrays (mode=6, start=0, count=0)
#at vbo/vbo_exec
_array.c:259
        ctx = <value optimized out>
        prim = {{mode = 6, indexed = 0, begin = 1, end = 1, weak =
0, pad = 0, s tart = 0, count = 0}}
#7  0x081c3026 in RenderablePatchWireframe::render
#(this=0x996ccb0, state=128) a
t radiant/patch.h:221
        n = 0
#8  0x081f78a1 in Renderables_flush (renderables=@0x892cfd4,
#current=@0xbf974e14
, globalstate=65675, viewer=@0xbf974ef4) at
radiant/renderstate.cpp:2183 i = {_M_current = 0xa486cbc}
        transform = (const Matrix4 *) 0x9d1ac68
#9  0x081f7b23 in OpenGLStateBucket::render (this=0x892cf50,
#current=@0xbf974e14
, globalstate=65675, viewer=@0xbf974ef4) at
radiant/renderstate.cpp:2220 No locals.
#10 0x08204e56 in OpenGLShaderCache::render (this=0x8447138,
#globalstate=65675, 
modelview=@0x8590000, projection=@0x858ffc0, viewer=@0xbf974ef4)
at radiant/rend erstate.cpp:1427
        i = {_M_node = 0x892cff8}
        current = {m_state = 128, m_sort = 0, m_texture = 0,
m_texture1 = 0, m_t exture2 = 0, m_texture3 = 0, m_texture4 = 0,
m_texture5 = 0, m_texture6 = 0, m_t exture7 = 0, m_colour =
{m_elements = {1, 1, 1, 1}}, m_blend_src = 770, m_blend_ dst =
771, m_depthfunc = 513, m_alphafunc = 519, m_alpharef = 0,
m_linewidth = 1 , m_pointsize = 1, m_linestipple_factor = 1,
m_linestipple_pattern = 43690, m_fo g = {mode = 2048, density = 0,
start = 0, end = 0, index = 0, colour = {m_elemen ts = {1, 1, 1,
1}}}, m_program = 0x0} pattern =
"����UUUU����UUUU����UUUU����UUUU����UUUU����UUUU����UUUU����U
UUU����UUUU����UUUU����UUUU����UUUU����UUUU����UUUU����UUUU����UUUU
\000\000\000"
#11 0x08270bba in XYRenderer::render (this=0xbf974fa8,
#modelview=@0x8590000, pro
jection=@0x858ffc0) at radiant/xywindow.cpp:2128
No locals.
#12 0x08268bf3 in XYWnd::XY_Draw (this=0x858ff30) at
#radiant/xywindow.cpp:2286
        renderer = {<Renderer> = {_vptr.Renderer = 0x82aa528},
m_state_stack =
{ <std::_Vector_base<XYRenderer::state_type,std::allocator<XYRenderer::state_type>
>> = {_M_impl = {<std::allocator<XYRenderer::state_type>> =
>> {<__gnu_cxx::new_al locator<XYRenderer::state_type>> = {<No
>> data fields>}, <No data fields>}, _M_sta
rt = 0xa211228, _M_finish = 0xa211230, _M_end_of_storage =
0xa211248}}, <No data fields>}, m_globalstate = 65675,
m_state_selected = 0x8457760} nDim1 = 1
        nDim2 = 2
        globalstate = 65675
#13 0x0826b537 in xywnd_expose (widget=0x85d1a10,
#event=0xbf975600, xywnd=0x858f
f30) at radiant/xywindow.cpp:809
No locals.
#14 0xb7ad4c10 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#15 0x085d1a10 in ?? ()
No symbol table info available.
#16 0xbf975600 in ?? ()
No symbol table info available.
#17 0x0858ff30 in ?? ()
No symbol table info available.
#18 0xb76dd738 in ?? () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#19 0xb7ad4bb0 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x08590430 in ?? ()
No symbol table info available.
#21 0xbf9750c8 in ?? ()
No symbol table info available.
#22 0xb76ac619 in g_closure_invoke ()
#from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
Backtrace stopped: frame did not save the PC
(gdb)
Comment 1 Roland Scheidegger 2007-11-06 07:05:40 UTC
As discussed on dri-devel list, this should be fixed in both mesa git master and mesa_7_0_branch.
Comment 2 Roland Scheidegger 2007-12-28 11:07:39 UTC
*** Bug 13809 has been marked as a duplicate of this bug. ***