Bug 13764 - mesa xdemos 'glxpixmap' draw nothing
mesa xdemos 'glxpixmap' draw nothing
Status: VERIFIED DUPLICATE of bug 9200
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other Linux (All)
: medium normal
Assigned To: Zou Nan hai
:
: 13633 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 00:29 UTC by Colin.Joe
Modified: 2009-08-24 12:28 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (18.39 KB, text/plain)
2007-12-21 00:32 UTC, Colin.Joe
Details
xorg.conf (3.72 KB, text/plain)
2007-12-21 00:32 UTC, Colin.Joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin.Joe 2007-12-21 00:29:53 UTC
System Environment:
--------------------------

--Platform:bearlake

--Architecture(32-bit,64-bit,compatiblity):64bit 

--2D driver:
commit f69b48fe24ef94dac44b8123884ca71df675be4b

--3D driver:
commit 8aa0fd6b206930ababb1bae2acc629e2a945c0c0

--Xserver:
commit 7ef7727b800fa4715b80a82850d65b88fde5fe6c


--Kernel:
2.6.24-rc5


Bug detailed description:
-------------------------
startx ,run glxpixmap , draw nothing on the window .


Reproduce steps:
----------------
 run glxpixmap



Current result:
----------------
draw nothing on the window.


Expected result:
----------------
run normally
Comment 1 Colin.Joe 2007-12-21 00:32:28 UTC
Created attachment 13273 [details]
Xorg.0.log
Comment 2 Colin.Joe 2007-12-21 00:32:54 UTC
Created attachment 13274 [details]
xorg.conf
Comment 3 Colin.Joe 2007-12-23 19:11:42 UTC
This case also run failed at mesa 7.0.2 release ,but run normally at mesa git
mesa_7_0_branch tip.
Comment 4 Zou Nan hai 2008-01-06 20:34:53 UTC
This is a known issue.
Render indirect context with direct render program is not implemented by X server currently.
Comment 5 Gordon Jin 2008-01-06 21:40:17 UTC
Nanhai, do you mean it's dup with bug#9200? I wonder why the error sympton different. Because code changed?

And why it's said that mesa_7_0_branch ok?
Comment 6 Gordon Jin 2008-01-06 21:41:30 UTC
*** Bug 13633 has been marked as a duplicate of this bug. ***
Comment 7 Zou Nan hai 2008-01-06 21:52:57 UTC
please check if mesa_7_0_branch is using direct or indirect render
Comment 8 Colin.Joe 2008-01-07 18:45:01 UTC
we reset the mesa to 7.0branch, it print :Direct rendering: No
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  30
  Current serial number in output stream:  30
Comment 9 Gordon Jin 2008-01-07 22:00:45 UTC
So it's the same with bug#9200.
Comment 10 Gordon Jin 2008-01-07 22:01:09 UTC

*** This bug has been marked as a duplicate of bug 9200 ***
Comment 11 ajax at nwnk dot net 2009-08-24 12:28:51 UTC
Mass version move, cvs -> git