Bug 13838 - [GLSL] glean/glsl1 fail: texture sampling (opcode 74) unsupported in vertex shader
[GLSL] glean/glsl1 fail: texture sampling (opcode 74) unsupported in vertex s...
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: medium minor
Assigned To: Ian Romanick
:
: 14164 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 00:28 UTC by Gordon Jin
Modified: 2009-08-24 12:28 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon Jin 2007-12-28 00:28:48 UTC
System Environment:
--------------------------
Platform: Q965
Arch: 32-bit
Xf86_video_intel:		d9df93578b74785c08ba860b4c9aa23b0c89c91c
Drm:		b9417f41418321d5081547a3a3386dcccae7541f
Mesa:		aac2d99dc316c069faa46dd43ff034155754c6b3
Kernel:		2.6.23
Glean:		Tip of CVS

Bug detailed description:
--------------------------
glean/glsl1 have 3 fails with the latest mesa master. This bug report is targeted for the 2nd failure:
FAILURE:
  Shader test: 2D Texture lookup with explicit lod (Vertex shader)
  Expected color: 0.25, 0, 0, 0.25
  Observed color: 0, 0, 0, 0

this happens whether or not INTEL_NO_TTM set.

Reproduce steps:
----------------
run glean case glsl by:
./glean -r ResultDir -t glsl1
Comment 1 Zou Nan hai 2008-01-03 01:26:53 UTC
This program is doing tex fetch in vertex shader which is not supported in current driver architect. We may implement it later but not in current time frame
Comment 2 Roland Scheidegger 2008-01-04 05:11:57 UTC
The driver should probably set Const.MaxVertexTextureImageUnits to 0 in this case (which is a legal value).
Comment 3 Gordon Jin 2008-01-20 20:22:22 UTC
*** Bug 14164 has been marked as a duplicate of this bug. ***
Comment 4 ajax at nwnk dot net 2008-02-24 18:22:44 UTC
Mass reopen.  The "LATER" resolution is lame, I'm deleting it.  Consider LATER to have arrived.
Comment 5 Ian Romanick 2008-12-08 17:05:39 UTC
This bug was fixed in July by commit 43346fb1fb43f91cb3e90d84b442dc08d6c9550d.
Comment 6 Gordon Jin 2008-12-15 00:31:01 UTC
verified
Comment 7 ajax at nwnk dot net 2009-08-24 12:28:59 UTC
Mass version move, cvs -> git