Bug 14656 - [i965] multiple texture units works incorrect in some case
[i965] multiple texture units works incorrect in some case
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: haihao
:
: 14617 14677 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 21:46 UTC by Shuang He
Modified: 2008-03-05 17:58 UTC (History)
2 users (show)

See Also:


Attachments
test case (4.32 KB, text/plain)
2008-02-24 21:49 UTC, Shuang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2008-02-24 21:46:08 UTC
System Environment:
--------------------------

--Platform: i965

--Architecture(32-bit,64-bit,compatiblity): all

--2D driver:
commit 4a42b01f5ee5a673716d6959dfe0e693b037eb48 

--3D driver:
commit d7cf6a8a697a2fb4da171a36968f65aa0f108b27 

--Xserver:
commit 06c968acbf6771d5fed4b12ebd400fea791ea498 

--Drm
commit d6098db1409e8ee45052920d3acdd3b6f2cb80aa

--Kernel:
2.6.24-rc5


Bug detailed description:
-------------------------
this issue doesn't happen on i915
this issue doesn't happen in non-DRI mode

here some case means the following sequences:
1. enable, apply, and read back,  2 or more texture units separately, with GL_DECAL mode
2. then enable and apply 2 or more texture units together, with GL_MODULATE mode

but it turns out the result is incorrect



Reproduce steps:
----------------
1. start X
2. compile and run attached test case


Current result:
----------------
multiple texture units doesn't work as expected in some case


Expected result:
----------------
multiple texture units should work as expected
Comment 1 Shuang He 2008-02-24 21:49:28 UTC
Created attachment 14547 [details]
test case

this test case should draw a small rectangle at left-bottom corner with color [0.000000, 0.000000, 1.000000], but it turns out [0.000000, 1.000000, 1.000000]
Comment 2 haihao 2008-03-02 23:11:30 UTC
*** Bug 14677 has been marked as a duplicate of this bug. ***
Comment 3 haihao 2008-03-04 17:54:41 UTC
*** Bug 14617 has been marked as a duplicate of this bug. ***
Comment 4 haihao 2008-03-04 18:12:37 UTC
This issue can be reproduced with a single texture unit
Comment 5 haihao 2008-03-04 23:08:05 UTC
fixed in drm 638353103d009d44bd5bdbe97cc7cef1bf011cdf
Comment 6 Shuang He 2008-03-05 17:58:37 UTC
verified, thanks