Bug 15098 - Images with transparency not displayed in FF3; XaaNoOffscreenPixmaps fixes problem
Summary: Images with transparency not displayed in FF3; XaaNoOffscreenPixmaps fixes pr...
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/XAA (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 15613 (view as bug list)
Depends on:
Blocks: xorg-7.5
  Show dependency treegraph
 
Reported: 2008-03-17 14:46 UTC by Søren Sandmann Pedersen
Modified: 2008-11-22 23:50 UTC (History)
11 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Søren Sandmann Pedersen 2008-03-17 14:46:27 UTC
I believe there is a bug in the nv driver where it sometimes treats Pictures in video memory as if they were blank.

The symptoms were that with the metacity compositor some windows, apparently randomly, didn't show up. Using XAANoOffscreenPixmaps fixed it.

This was with a G80 chip. Unfortunately, I don't know the exact versions of the server and nv, but both were git master sometime after 1.4. Pixman was almost certainly 0.9.6.

I don't have the system anymore, so I can't get more details. Sorry.
Comment 1 Vladimir Vukicevic 2008-03-17 14:55:42 UTC
This seems to be the same problem as in https://bugzilla.mozilla.org/show_bug.cgi?id=411831 -- a number of people there can reproduce, if any additional information is required.
Comment 2 Nathan Straz 2008-03-18 06:02:40 UTC
I am willing to test out any fixes for this bug.
Comment 3 Chris Sherlock 2008-03-28 18:50:55 UTC
I don't believe that this is specific to the nVidia driver, as I'm using an ATI driver and I'm seeing the same issue. 
Comment 4 Luke Hutchison 2008-04-21 08:23:07 UTC
*** Bug 15613 has been marked as a duplicate of this bug. ***
Comment 5 Luke Hutchison 2008-04-21 08:26:45 UTC
Agreed, I see this on all of nv, radeon and vesa drivers.  The problem is most commonly seen in Firefox 3, and is 100% reproducible with images that have an alpha channel there ( => updating the title to be more descriptive ).  

The corresponding Mozilla bug with lots of extra info is:

    https://bugzilla.mozilla.org/show_bug.cgi?id=411831

The Mozilla bug was recently closed as INVALID because XAA is supposedly
becoming superceded by EXA, but FF3 will soon be running on many systems that
have not yet transitioned to EXA, so it still makes sense to fix this in xorg. 
Thanks!
Comment 6 Aaron Plattner 2008-04-21 10:08:05 UTC
Why the heck did this get moved to ASSIGNED?  Moving to Acceleration/XAA and reassigning to the default assignee.
Comment 7 Alan Coopersmith 2008-04-21 10:15:20 UTC
Another reason for making XAANoOffscreenPixmaps the default?
Comment 8 Chris Sherlock 2008-05-21 03:15:36 UTC
With the greatest of respect, would it be possible to know whether this is something that is seen as important enough to be fixed?

The reason I ask is that Firefox 3 is adversely affected by the issue, the workaround is to disable the option. A number of distros (Ubuntu and Fedora) have done just this. However, it does on the face of it appear to be sweeping the issue under the rug. 

If this isn't seen as a very important issue now that EXA is where development is being focused, could we at least get the status changed to WONTFIX? Then we would all be clear on where we stand with the issue. 

The bug causing all the commotion, incidently, can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=411831
Comment 9 Juliusz Chroboczek 2008-06-11 09:43:45 UTC
FWIW, I worked around this on Radeon by setting

        Option          "AccelMethod" "EXA"

Of course, in order to get decent performance, you then need to say

        Option          "MigrationHeuristic" "greedy"

Regards,

--Juliusz
Comment 10 Adam Jackson 2008-06-17 13:16:16 UTC
This is much the same problem as bug #13795, as far as I can tell.

I really can't be arsed to fix this properly right now, XAA is just dire.  For 7.4 I'm just going to turn off XAA offscreen pixmaps by default, they end up being a performance loss in most cases anyway.

Moving to 7.5 tracker so we either cherry-pick 7822a3d05f935cca3bfa47d15d961596652ecfca by then or else fix this properly.
Comment 11 Stefan Dirsch 2008-11-22 14:36:51 UTC
AFAIK XAANoOffscreenPixmaps is meanwhile the default. Closing as FIXED.
Comment 12 Chris Sherlock 2008-11-22 21:23:54 UTC
No offense to Scott of SuSE, but turning it off by default isn't actually a true fix. That just... turns off the feature. 

I have no problem with the bug being closed, but the resolution really should be WONTFIX, surely?
Comment 13 Chris Sherlock 2008-11-22 21:25:31 UTC
Oooh boy... sorry, meant to Stefan, not Scott. Sorry about that. My comments on WONTFIX still stand though. 
Comment 14 Stefan Dirsch 2008-11-22 23:50:27 UTC
As you whish. For me the meaning of WONTFIX is more like this. The problem still exists, i.e. you can still reproduce it, but nobody cares about it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.