Bug 13795 - RenderComposite with XAA renders at wrong position if vertically scaled.
RenderComposite with XAA renders at wrong position if vertically scaled.
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/XAA
unspecified
x86 (IA32) Linux (All)
: medium critical
Assigned To: Søren Sandmann Pedersen
Xorg Project Team
:
: 14210 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 05:10 UTC by Kusanagi Kouichi
Modified: 2009-09-01 08:22 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.01 KB, text/plain)
2007-12-23 05:11 UTC, Kusanagi Kouichi
no flags Details
Xorg.0.log (51.42 KB, text/plain)
2007-12-23 05:12 UTC, Kusanagi Kouichi
no flags Details
testcase (2.54 KB, text/plain)
2007-12-23 05:13 UTC, Kusanagi Kouichi
no flags Details
Not scaled. 320 pixel height. (746 bytes, image/png)
2007-12-23 05:14 UTC, Kusanagi Kouichi
no flags Details
Change height to 280 pixel. (492 bytes, image/png)
2007-12-23 05:16 UTC, Kusanagi Kouichi
no flags Details
Change height to 360 pixel. (660 bytes, image/png)
2007-12-23 05:16 UTC, Kusanagi Kouichi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kusanagi Kouichi 2007-12-23 05:10:32 UTC
Position is shifted up or down if scaled down or up respectively.
RenderComposite with EXA works correctly.
Comment 1 Kusanagi Kouichi 2007-12-23 05:11:28 UTC
Created attachment 13321 [details]
xorg.conf
Comment 2 Kusanagi Kouichi 2007-12-23 05:12:35 UTC
Created attachment 13322 [details]
Xorg.0.log
Comment 3 Kusanagi Kouichi 2007-12-23 05:13:28 UTC
Created attachment 13323 [details]
testcase

This should fill entire window with white.
Comment 4 Kusanagi Kouichi 2007-12-23 05:14:45 UTC
Created attachment 13324 [details]
Not scaled. 320 pixel height.
Comment 5 Kusanagi Kouichi 2007-12-23 05:16:00 UTC
Created attachment 13325 [details]
Change height to 280 pixel.
Comment 6 Kusanagi Kouichi 2007-12-23 05:16:34 UTC
Created attachment 13326 [details]
Change height to 360 pixel.
Comment 7 ajax at nwnk dot net 2008-03-03 20:25:55 UTC
*** Bug 14210 has been marked as a duplicate of this bug. ***
Comment 8 Kusanagi Kouichi 2008-03-21 00:13:56 UTC
If I disabled offscreen pixmap, the problem disappears.
Comment 9 Søren Sandmann Pedersen 2008-03-21 02:36:32 UTC
The issue here is almost certainly that FbComposite offsets the composite operation by the coordinates of the drawable with no regard to the transformation. 

Fixing probably involves making image_from_pict() do the conversion, and somehow fixing up miSourceValidate
Comment 10 ajax at nwnk dot net 2008-06-17 13:16:44 UTC
Moving to 7.5 tracker.  Hacked around in server-1.5-branch, see further discussion on bug #15098 for motivation and workaround doc.
Comment 11 Daniel Stone 2009-08-31 17:37:56 UTC
dropping from the release tracker: xaa is deprecated, offscreen pixmaps are not enabled by default, and this _may_ be fixed already.
Comment 12 Søren Sandmann Pedersen 2009-09-01 08:22:53 UTC
I believe this is fixed.