Bug 15739 - [915]mesa xdemo 'manywin' run abort
[915]mesa xdemo 'manywin' run abort
Status: RESOLVED DUPLICATE of bug 13890
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other Linux (All)
: medium normal
Assigned To: haihao
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-27 23:17 UTC by Colin.Joe
Modified: 2009-08-24 12:30 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (46.90 KB, text/plain)
2008-04-27 23:26 UTC, Colin.Joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin.Joe 2008-04-27 23:17:07 UTC
System Environment:
--------------------------

--Platform:945
--Architecture(32-bit,64-bit,compatiblity):all
--2D driver: 1d467a8038946a37844795e8860be113d43219ac 
--3D driver:  118de7a01369977d13f40bab2ad591320cc7f7ff
--DRM: 10b9a116a7b7fe3acf0848de9e0cf40f8e1bcd75
--Xserver: 0209e46249b61974a6e3ed54a51cc36dfaf0064f
--Kernel:2.6.23

Bug detailed description:
--------------------------
startx ,run manywin on 945 ,it soon run abort and print :DRM_I915_EXECBUFFER: -22.You can see bug 15717 which reports this case crash X on 965 .


Reproduce steps:
----------------
1. start X 
2 ./manywin - 10 


Current result:
--------------
run abort 


Expected result:
----------------
run fine
Comment 1 Colin.Joe 2008-04-27 23:26:08 UTC
Created attachment 16210 [details]
Xorg.0.log
Comment 2 Colin.Joe 2008-04-30 02:17:32 UTC
There are 2 commit   which interval is the shortest:  . 
commit 33107357a1226b9218fac410a7502a981aac5cc5
commit 711222bb7b4fd7ea8e7f801ac26532360bc5440f
The preceding one can reproduce this bug, and the latter one runs fine .
So the  commit  33107357a1226b9218fac410a7502a981aac5cc5  makes this issue . 

 

Comment 3 Eric Anholt 2008-04-30 11:07:56 UTC

*** This bug has been marked as a duplicate of bug 13890 ***
Comment 4 ajax at nwnk dot net 2009-08-24 12:30:09 UTC
Mass version move, cvs -> git