Bug 16750 - [Macbook] booting through EFI gets broken display
Summary: [Macbook] booting through EFI gets broken display
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium major
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
Depends on:
Reported: 2008-07-16 17:19 UTC by Daniel Roschka
Modified: 2008-09-16 10:42 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:

used xorg.conf (751 bytes, text/plain)
2008-07-16 17:20 UTC, Daniel Roschka
no flags Details
log with the error messages (37.82 KB, text/plain)
2008-07-16 17:21 UTC, Daniel Roschka
no flags Details

Description Daniel Roschka 2008-07-16 17:19:05 UTC
I spent the last days to get linux (32Bit) working through efi on a first-generation macbook. I use the efi version of grub2 as bootloader. So far everything is fine. While using vesafb or efifb as kernel parameter for video I see linux booting, but then the display went black or get funny stripes (without displaying any content). But so far linux boots fine and is available via ssh. So there must be a graphics related issue.
I just tried to get xorg from current Debian/unstable working, but I'll get the following error message:
(EE) intel(0): V_BIOS address 0x0 out of range
(II) Attempted to read BIOS 64KB from /sys/bus/pci/devices/0000:00:02.0/rom: got 0KB
(EE) intel(0): Bad VBT signature

Same error messages appeared with a self compiled intel-driver from current trunk.
More infos with ModeDebug enabled are available in the attached logfile. While searching the web for possible solutions I found: http://lists.freedesktop.org/archives/xorg/2008-March/033838.html
According to that mail booting trough efi should work with an intel driver 2.x, but apparently that isn't working in my case.

If you need more infos just drop me a note.
With best regards
Comment 1 Daniel Roschka 2008-07-16 17:20:32 UTC
Created attachment 17718 [details]
used xorg.conf
Comment 2 Daniel Roschka 2008-07-16 17:21:31 UTC
Created attachment 17719 [details]
log with the error messages
Comment 3 Michael Fu 2008-07-17 02:39:32 UTC
Daniel, if you remove vesafb or macfb ( in fact any other kind of kernel fb module ) and this issue is gone, then this is a known issue. solution for now is to get rid of fb module, there are conflicts. can you confirm?
Comment 4 Daniel Roschka 2008-07-17 03:15:22 UTC
(In reply to comment #3)
> Daniel, if you remove vesafb or macfb ( in fact any other kind of kernel fb
> module ) and this issue is gone, then this is a known issue. solution for now
> is to get rid of fb module, there are conflicts. can you confirm?

Unfortunately the problem remains when I remove the video kernel command line argument in grub2. The only difference is, that I even can't see the early boot process anymore (because of the missing fb-driver).
Comment 5 Gordon Jin 2008-07-17 20:26:54 UTC
I suppose Eric has experience on Macbook with EFI. Any comments?
Comment 6 Gordon Jin 2008-07-29 22:15:57 UTC
I guess Jesse might take care of this issue in LVDS output detection.
Comment 7 Michael Fu 2008-07-30 23:29:18 UTC
by comparing the xorg.log in attachment# 15225 [details] of bug# 11211, it seems that our driver can't get VBT from you machine.. It might related with the EFI, We don't have a mac. I'm copying the bug reporter of 11211, at least he can use the LVDS with no problem...maybe you can talk with him to see what's new in his Mac.

re-assign to zhenyu.
Comment 8 Daniel Roschka 2008-07-31 03:46:54 UTC
The author of #11211 doesn't mention efi in his bugreport. So I assume he's using the legacy bios emulation to boot linux. His posted guide for Gentoo in the links also just use the bios emulation.
Comment 9 Wang Zhenyu 2008-09-02 02:01:26 UTC
oh, your mac has quirk in driver to disable LVDS. Mac mini has no LVDS, but other Mac might have (like yours), so try with removing that quirk line in i830_quirk.c

 /* Apple Mac mini has no lvds, but macbook pro does */
    { PCI_CHIP_I945_GM, 0x8086, 0x7270, quirk_mac_mini },

Not sure if Apple has info on how to detect the type of Mac platform.
Comment 10 Daniel Roschka 2008-09-16 10:42:08 UTC
2.4.2 fixed this bug for me. Thank you guys.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.