Bug 16965 - gpkg-application 0.2.3 stops if gpgcheck enabled in repo but gpgkey not installed
Summary: gpkg-application 0.2.3 stops if gpgcheck enabled in repo but gpgkey not inst...
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium blocker
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
: 16976 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-02 17:24 UTC by mustafamehmed
Modified: 2008-08-06 03:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
the fix (1.00 KB, patch)
2008-08-06 03:00 UTC, Richard Hughes
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description mustafamehmed 2008-08-02 17:24:20 UTC
gpk-application 0.2.3 stops with the following error :-

Error Type: <type 'exceptions.TypeError'>
Error Value: object of type 'instancemethod' has no len()
  File : /usr/share/PackageKit/helpers/yum/install-packages.py , line 19, in <module>
    backend.install_packages(packages)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 226, in wrapper
    func(*args,**kwargs)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 949, in install_packages
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1151, in _runYumTransaction
    hex_fingerprint = "80740e5" * len(fingerprint) 158781488ple(map(ord, fingerprint))

This occurs if the PGP-KEY is not installed for the appropriate repo server and gpgcheck is enabled.

In my case I was trying to install "vlc*" from rpm.livna.org on Fedora 9 (i386 Linux hp-laptop 2.6.25.11-97.fc9.i686 #1 SMP Mon Jul 21 01:31:09 EDT 2008 i686 i686 i386 GNU/Linux). I installed livna's PGP-KEY and the error went away.
Comment 1 Richard Hughes 2008-08-06 02:24:21 UTC
*** Bug 16976 has been marked as a duplicate of this bug. ***
Comment 2 Richard Hughes 2008-08-06 03:00:45 UTC
Created attachment 18154 [details] [review]
the fix

I've applied this file to master and 0.2.x -- I'll build new RPMs today or tomorrow. Thanks for reporting.
Comment 3 Richard Hughes 2008-08-06 03:28:42 UTC
rpm's available here: http://koji.fedoraproject.org/koji/buildinfo?buildID=58789


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.