Bug 17025 - Error report when checking signatures
Summary: Error report when checking signatures
Status: RESOLVED DUPLICATE of bug 16942
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-07 04:19 UTC by Hedayat Vatankhah
Modified: 2008-09-26 08:10 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hedayat Vatankhah 2008-08-07 04:19:05 UTC
I was installing some packages using PackageKit and it crashed with this error when it was checking the signature of a package:


Error Type: <type 'exceptions.TypeError'>
Error Value: object of type 'instancemethod' has no len()
  File : /usr/share/PackageKit/helpers/yum/update-packages.py , line 19, in <module>
    backend.update_packages(packages)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1084, in update_packages
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1151, in _runYumTransaction
    hex_fingerprint = "80740e5" * len(fingerprint) 146387232ple(map(ord, fingerprint))
Comment 1 Richard Hughes 2008-08-07 05:29:08 UTC
Should be fixed in the PackageKit in updates-testing.
Comment 2 Hedayat Vatankhah 2008-08-07 07:50:03 UTC
Oh! I found that I didn't import GPG key of one of my repositories, so this error might be related to that problem. But anyway this kind of error doesn't seem to be nice.
Comment 3 Richard Hughes 2008-09-26 08:10:12 UTC

*** This bug has been marked as a duplicate of bug 16942 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.