Bug 1717 - Locks up w/ dri when changing resolution
Summary: Locks up w/ dri when changing resolution
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
Depends on:
Reported: 2004-10-26 23:32 UTC by Terumasa Hasegawa
Modified: 2007-02-22 14:27 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Terumasa Hasegawa 2004-10-26 23:32:06 UTC
I wonder if this bug must be a kind of duplications...

When I change a resolution by pressing CTRL+ALT+(+/-) or command xrandr,
My monitor changes it's resolution,but my PC offten seems to be freeze.
Any keys don't be accepted(even numlock, CTRL+ALT+BS).
But other processes seems good.For example,sshd and httpd are available.
Playing tuxracer fullscreen mode twice or xmame.SDL --fullscreen cause this
problem too.
If I delete Option "dri",this problem dosen't occur.
It helped nothing to disable any other screen section options. 
Zapping TV viewer goes fine.

MBchipset:KT133(bios is up-to-date)
xorg-cvs(2004/10/21) i386
kernel-2.6.9-1.640 i686

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Iiyama Vision Master MF-8617E"
        HorizSync    23.6 - 86.0
        VertRefresh  50.0 - 120.0
        Option       "dpms"

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 8500"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24

        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "800x600" "640x480"
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"

Section "DRI"
        Group        0
        Mode         0666

 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 321mm x 241mm )  *85   75   70   60   87
 1    800 x 600    ( 321mm x 241mm )   85   75   72   60   56
 2    640 x 480    ( 321mm x 241mm )   85   75   73   60
 3    832 x 624    ( 321mm x 241mm )   75
 4    720 x 400    ( 321mm x 241mm )   85
 5    640 x 400    ( 321mm x 241mm )   85
 6    640 x 350    ( 321mm x 241mm )   85
 7    512 x 384    ( 321mm x 241mm )   87
 8    416 x 312    ( 321mm x 241mm )   75
 9    400 x 300    ( 321mm x 241mm )   85   75   72   60
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none
Comment 1 Jonathan Isom 2004-11-13 19:45:03 UTC
My Radeon 7000 locks up with monitor bad refresh when changing resolutions.
sometimes I can reboot otherwise have to reset.
Comment 2 Terumasa Hasegawa 2004-12-11 04:30:01 UTC
According to some advices on webs,I've changed my power suply from 250W to
500W.But my machine still locks when I change monitor resolution.
I have no idea about PCI LATENCY CLK.I set it to 255. 
Comment 3 Terumasa Hasegawa 2004-12-14 07:43:25 UTC
I have changed my mother board into Asus A7V400-MX,
but the probrem still occurs.the temeparture of CPU is 67.0c/152.6F. 
Comment 4 T. Hood 2005-09-23 06:02:51 UTC
Compare bug #1991.
Comment 5 Terumasa Hasegawa 2005-09-26 04:07:05 UTC
The problem is not solved yet.My machine is as used to.



I also tried xorg-x11-6.8.2-52.src.rpm. (cannot see TV by this package.) 

I am afraid that AIW8500 has a problem itself.
Comment 6 Erik Andren 2006-04-02 23:09:46 UTC
Whats the status of this bug using a current version of xorg?
Could you please post a backtrace of the lockup?
Comment 7 Terumasa Hasegawa 2006-04-08 19:36:08 UTC
Now,I am using Fedora Core 5.
All of my packages are up-to-date.


Lockup(maybe dri problem) still occurs by the same way.
Comment 8 Terumasa Hasegawa 2006-04-08 19:49:53 UTC
The lockup problem do not always occurs,but sometimes.
changing resolution once,twice or other times.
So I guess this is complicated one.
Comment 9 Terumasa Hasegawa 2006-04-08 20:20:50 UTC
I have tried a development package xorg-x11-drv-ati- just now.
Something has changed.
Lockup still occurs,BUT
1.My monitor becomes black.
2.Sometime my keybord is available and sometime unavailable.
3.Additionally when my keyboard is available and I try to change resolution one
more ,all the process seems to lock up.
??? -sigh-(;_;)
Comment 10 Erik Andren 2006-05-31 07:19:01 UTC
I take it that you are experiencing the same behaviour with another monitor. 
Also try to build the custom non-kernel drm modules from dri.freedesktop.org
See http://dri.freedesktop.org/wiki/Building

Comment 11 Timo Jyrinki 2007-02-22 14:27:33 UTC
Marking broken (status null/blank) bugs in xorg with no activity in a long time as fixed. Please reopen if you think it's necessary, but first do a search if a similar bug report is already filed and in a NEW/ASSIGNED state. These bugs do not currently show in most search results as they do not have any status.

Sorry for this janitorial spam, you know where to send hate mails to when your inbox gets full of bugs you're subscribed to.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.