Bug 17307 - sfwdec-mozilla plugin stops playing sounds
Summary: sfwdec-mozilla plugin stops playing sounds
Status: RESOLVED FIXED
Alias: None
Product: swfdec
Classification: Unclassified
Component: library (show other bugs)
Version: 0.6.6
Hardware: Other All
: medium normal
Assignee: swfdec ml
QA Contact: swfdec ml
URL:
Whiteboard:
Keywords:
: 17366 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-26 03:03 UTC by Wouter Bolsterlee
Modified: 2008-10-02 07:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
don't give up on buffer underrun (1.33 KB, patch)
2008-08-28 05:36 UTC, Riccardo Magliocchetti
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Wouter Bolsterlee 2008-08-26 03:03:20 UTC
The swfdec-mozilla plugins stops playing sound after ~10 seconds. I'm using pulseaudio and my ~/.asoundrc looks like this:

  pcm.!default { type pulse }
  ctl.!default { type pulse }

The output my browser gives me is this:

$ epiphany -p http://gnomecoder.wordpress.com/2008/08/26/luz-at-play/ 
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
Unsupported movie property wmode with value "transparent"
unhandled event 19
Loading stream: http://www.youtube.com/swf/l.swf?video_id=yGkWnz74zUk&rel=0&eurl=http%3A//gnomecoder.wordpress.com/2008/08/26/luz-at-play/&iurl=http%3A//i2.ytimg.com/vi/yGkWnz74zUk/default.jpg&t=OEgsToPDskJd96uAoMR-rcI8cnBL20Ky&use_get_video_info=1&load_modules=1&
Loading stream: http://www.youtube.com/swf/cps.swf
Loading stream: http://i2.ytimg.com/crossdomain.xml
Loading stream: http://i2.ytimg.com/vi/yGkWnz74zUk/default.jpg
Loading stream: http://www.youtube.com/get_video_info?&video_id=yGkWnz74zUk&eurl=http%3A%2F%2Fgnomecoder%2Ewordpress%2Ecom%2F2008%2F08%2F26%2Fluz%2Dat%2Dplay%2F
Loading stream: http://nyc-v95.nyc.youtube.com/get_video?video_id=yGkWnz74zUk&signature=23DBE455F18CB00DE78F005DA928439C036DB9BA.5E378F4DB7DA496A02A35655661D80ECAB8B2F2B&ip=86.91.80.239&ipbits=8&expire=1219764796&key=yt1&sver=2
Loading stream: http://video-stats.video.google.com/s?ns=yt&docid=yGkWnz74zUk&ps=default&el=embedded&eurl=http%3A%2F%2Fgnomecoder%2Ewordpress%2Ecom%2F2008%2F08%2F26%2Fluz%2Dat%2Dplay%2F&rt=1.2&fv=WIN%209%2C0%2C100%2C0&bc=258908&st=0.04&len=59.977&et=0.04
snd_pcm_avail_update failed: Broken pipe
^C
Comment 1 Riccardo Magliocchetti 2008-08-28 05:36:02 UTC
Created attachment 18556 [details] [review]
don't give up on buffer underrun

Wouter, which version of swfdec library and pulseaudio do you have?

This is the same patch i've sent to the list.
Comment 2 Wouter Bolsterlee 2008-08-28 05:50:49 UTC
ii  gstreamer0.10-pulseaudio             0.9.7-2                          GStreamer plugin for PulseAudio
ii  libgstreamer-plugins-pulse0.10-0     0.9.7-2                          GStreamer plugin for PulseAudio (transitional package)
ii  libpulse-browse0                     0.9.10-2                         PulseAudio client libraries (zeroconf support)
ii  libpulse-dev                         0.9.10-2                         PulseAudio client development headers and libraries
ii  libpulse-mainloop-glib0              0.9.10-2                         PulseAudio client libraries (glib support)
ii  libpulse0                            0.9.10-2                         PulseAudio client libraries
ii  libpulsecore5                        0.9.10-2                         PulseAudio sound server core
ii  pulseaudio                           0.9.10-2                         PulseAudio sound server
ii  pulseaudio-esound-compat             0.9.10-2                         PulseAudio ESD compatibility layer
ii  pulseaudio-module-gconf              0.9.10-2                         GConf module for PulseAudio sound server
ii  pulseaudio-module-hal                0.9.10-2                         HAL device detection module for PulseAudio sound server
ii  pulseaudio-module-x11                0.9.10-2                         X11 module for PulseAudio sound server
ii  pulseaudio-module-zeroconf           0.9.10-2                         Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils                     0.9.10-2                         Command line tools for the PulseAudio sound server
ii  libswfdec-0.6-90                     0.6.8-1                          SWF (Macromedia Flash) decoder library
ii  swfdec-gnome                         2.22.2-2                         Tools to play SWF files (Macromedia Flash) on GNOME
ii  swfdec-mozilla                       0.6.0-4                          Mozilla plugin for SWF files (Macromedia Flash)
Comment 3 Riccardo Magliocchetti 2008-08-31 06:08:18 UTC
*** Bug 17366 has been marked as a duplicate of this bug. ***
Comment 4 Benjamin Otte 2008-09-01 02:29:59 UTC
fixed in git.
Comment 5 Wouter Bolsterlee 2008-10-02 07:37:57 UTC
Is this in a released version? If so, which?
Comment 6 Riccardo Magliocchetti 2008-10-02 07:49:30 UTC
It's fixed in latest stable which is 0.8.0.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.