Bug 17559 - Yum yielding an invalid syntax error in /usr/lib/yum-plugins/filter-data.py
Summary: Yum yielding an invalid syntax error in /usr/lib/yum-plugins/filter-data.py
Status: RESOLVED NOTOURBUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
: 17706 (view as bug list)
Depends on:
Blocks: 17891
  Show dependency treegraph
 
Reported: 2008-09-12 22:31 UTC by Abhishek Singh
Modified: 2008-10-13 06:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abhishek Singh 2008-09-12 22:31:50 UTC
The package kit stops giving an message that an error has occurred, and pointing out to file a bug at bugs.freedesktop.org. It does not give any other clue though. Then I tried using yum at the console. Any command configuration with yum (install, list, etc.) yields the following error:
File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/filter-data.py", line 111
    ('committers', 'committer')]
                               ^
SyntaxError: invalid syntax

I'm using a Fedora 9 fully updated system. The installed version of package-kit is yum-packagekit-0.2.5-1.fc9.i386, and the installed version of yum is yum-3.2.19-3.fc9.noarch.
Comment 1 tomppa 2008-09-21 14:41:38 UTC
I have install to opera-9.60.gcc4-shared-qt3.i386.rpm and packege-kit
crash. I'm using a Fedora 9 fully updated system. 

Error Type: <type 'exceptions.UnicodeDecodeError'>
Error Value: 'ascii' codec can't decode byte 0xc3 in position 71: ordinal not in range(128)
  File : /usr/share/PackageKit/helpers/yum/install-files.py , line 20, in <module>
    backend.install_files(trusted, files_to_inst)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1033, in install_files
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1138, in _runYumTransaction
    rpmDisplay=rpmDisplay)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 3067, in processTransaction
    self._doTransaction(callback,display=rpmDisplay)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 3171, in _doTransaction
    self.runTransaction( cb=cb )
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 785, in runTransaction
    errors = self.ts.run(cb.callback, '')
  File : /usr/lib/python2.5/site-packages/yum/rpmtrans.py , line 333, in callback
    self._instProgress( bytes, total, h )
  File : /usr/lib/python2.5/site-packages/yum/rpmtrans.py , line 414, in _instProgress
    self.complete_actions, self.total_actions)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1711, in event
    self._showName(self.info_actions[action])
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1704, in _showName
    self.base.package(id,status,"")
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 269, in package
    PackageKitBaseBackend.package(self,id,status,summary)
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py , line 102, in package
    print >> sys.stdout,"package\t$s\t$s\t$s" $ (status,id,summary)
Comment 2 Richard Hughes 2008-09-22 01:55:46 UTC
You need to disable the yumfilter-data plugin, as it's broken.
Comment 3 Richard Hughes 2008-09-29 23:42:16 UTC
*** Bug 17706 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.