Bug 17668 - error
Summary: error
Status: RESOLVED DUPLICATE of bug 17694
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-19 11:57 UTC by matt
Modified: 2008-10-13 06:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matt 2008-09-19 11:57:29 UTC
Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1819, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1808, in main
    backend = PackageKitYumBackend('',lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 118, in __init__
    self._setup_yum()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1552, in _setup_yum
    self.yumbase.doConfigSetup(errorlevel=0,debuglevel=0)     # Setup Yum Config
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 139, in doConfigSetup
    errorlevel=errorlevel)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 191, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 753, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 823, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
Comment 1 Richard Hughes 2008-10-13 06:32:24 UTC

*** This bug has been marked as a duplicate of bug 17694 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.