Bug 18333 - Ctrl+Shift and other layout switching combinations stop working as modifiers
Summary: Ctrl+Shift and other layout switching combinations stop working as modifiers
Status: RESOLVED DUPLICATE of bug 865
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/XKB (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Daniel Stone
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-31 17:33 UTC by Ihar Mahaniok
Modified: 2008-10-31 18:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ihar Mahaniok 2008-10-31 17:33:39 UTC
It is possible to set combination like "Ctrl+Shift" the keyboard layout
switcher privatizes it as the shortcut for switching layouts, and disallows all
other programs to use it as modifier.

Steps to reproduce:
0. Login to GNOME (the steps below are for 2.24, but should be similar for other versions).
1. Open "Keyboard preferences" in Keyboard layout indicator applet.
2. Go to Layouts.
3. Add some keyboard layouts.
4. Click "Other Options".
5. Under "Layout switching", check "Ctrl+Shift" change layout.
6. Open Firefox.
7. Open several tabs with Ctrl+T.
8. Switch forward through them with multiple "Ctrl+Tab". Notice that everything
is ok.
9. Try to switch backward through them with multiple "Ctrl+Shift+Tab"...


Actual results:
Exactly at moment when you press down Ctrl and Shift, keyboard layout changes;
after you press Tab, without letting Ctrl and Shift off, Firefox switches one
tab forward instead of one tab backward.

Expected results:
Firefox should go one tab back.
Layout should not change.

Overall, the layout should change not at the time when you press down Ctrl and
Shift, but only at the time when you let go one of them, and only if you didn't
use this combination as modifier for another key.

Does this happen every time?
Yes.

Other information:
In windows, everything is working exactly as desired - layouts are changed only
at the time when you let go the combination.

This bug was filed against GNOME, and they told it is X.Org problem: http://bugzilla.gnome.org/show_bug.cgi?id=558738
Comment 1 Sergey V. Udaltsov 2008-10-31 17:57:01 UTC
It is not xkeyboard-config, it is rather xorg/XKB. But, as I said before, it will hardly be fixed.
Comment 2 Daniel Stone 2008-10-31 18:12:06 UTC

*** This bug has been marked as a duplicate of bug 865 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.