Bug 18462 - [855GM] No outputs detected --> Xserver cannot be started at all
[855GM] No outputs detected --> Xserver cannot be started at all
Status: RESOLVED DUPLICATE of bug 20826
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86 (IA32) Linux (All)
: medium critical
Assigned To: Wang Zhenyu
Xorg Project Team
: NEEDINFO
Depends on:
Blocks: 18858
  Show dependency treegraph
 
Reported: 2008-11-10 02:28 UTC by Guek Wu Neo
Modified: 2009-04-12 23:47 UTC (History)
9 users (show)

See Also:


Attachments
Xorg.0.log (13.30 KB, text/plain)
2008-11-10 02:28 UTC, Guek Wu Neo
no flags Details
xorg.conf (4.67 KB, text/plain)
2008-11-10 02:29 UTC, Guek Wu Neo
no flags Details
hwinfo (391.24 KB, text/plain)
2008-11-10 02:30 UTC, Guek Wu Neo
no flags Details
Xorg.0.log collected after adding Option ModeDebug on (22.89 KB, text/plain)
2008-11-10 20:30 UTC, Guek Wu Neo
no flags Details
xorg.conf with Option ModeDebug on (4.70 KB, text/plain)
2008-11-10 20:30 UTC, Guek Wu Neo
no flags Details
rom.bin (64.00 KB, application/octet-stream)
2008-11-13 21:11 UTC, Guek Wu Neo
no flags Details
Xorg.0.log when vesa driver used (50.05 KB, text/plain)
2008-11-23 23:26 UTC, Guek Wu Neo
no flags Details
this is output messages upon running ./autogen.sh (4.43 KB, text/plain)
2008-12-03 20:15 UTC, Guek Wu Neo
no flags Details
Xorg.0.log and xorg.conf (30.00 KB, application/octet-stream)
2008-12-05 00:29 UTC, Guek Wu Neo
no flags Details
i830.quirks.c, dmesg, messages, Xorg.0.log and xorg.conf (660.00 KB, application/octet-stream)
2008-12-08 19:13 UTC, Guek Wu Neo
no flags Details
new lvds detect patch from upstream (4.18 KB, text/plain)
2008-12-08 22:31 UTC, qwang13
no flags Details
Xorg.0.log i830_quirks.c and i830_lvds.c (80.00 KB, application/octet-stream)
2008-12-10 00:38 UTC, Guek Wu Neo
no flags Details
Be LID_UNKNOWN when no lid acpi object found (437 bytes, patch)
2008-12-10 04:20 UTC, Wang Zhenyu
no flags Details | Splinter Review
Be LID_UNKNOWN when no lid acpi object found (437 bytes, patch)
2008-12-10 04:21 UTC, Wang Zhenyu
no flags Details | Splinter Review
Be LID_UNKNOWN when no lid acpi object found (437 bytes, patch)
2008-12-10 04:22 UTC, Wang Zhenyu
no flags Details | Splinter Review
xorg.0.log swfdump xorg.conf (100.00 KB, application/octet-stream)
2008-12-10 20:30 UTC, Guek Wu Neo
no flags Details
Xorg.0_7.4-19.5.1.log (21.49 KB, text/plain)
2009-03-25 10:04 UTC, Stefan Dirsch
no flags Details
Xorg.0.log with ModeDebug on. (23.29 KB, text/plain)
2009-03-25 23:54 UTC, Tomas Tichy
no flags Details
Output of acpidump (82.17 KB, text/plain)
2009-03-25 23:55 UTC, Tomas Tichy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guek Wu Neo 2008-11-10 02:28:27 UTC
Created attachment 20174 [details]
Xorg.0.log

Intel Corporation 82852/855GM
Integrated Graphics Device [8086:3582] (rev 02)


Problem description: Not able to startX. Problem exist is Sles11 beta1/2/3/4
Error message:Not able to start X with error message " maximum number of X
display failures reached.

We need to fix the issue and use the Intel driver.

Load the following.
libdrm-2.4.1-2.3.i586.rpm
Mesa-7.2-8.3.i586.rpm
xorg-x11-server-7.4-19.1.i586.rpm
xorg-x11-driver-video-7.4-25.2.i586.rpm
Comment 1 Guek Wu Neo 2008-11-10 02:29:08 UTC
Created attachment 20175 [details]
xorg.conf
Comment 2 Guek Wu Neo 2008-11-10 02:30:27 UTC
Created attachment 20176 [details]
hwinfo
Comment 3 Stefan Dirsch 2008-11-10 02:47:15 UTC
Guek is using the following driver related software

- xorg-server 1.5.2
- xf86-video-intel 2.5.0
- libdrm 2.4.1
- Mesa 7.2_intel-2008-q3_46921a5 (Intel-2008-Q3-RC5)
- Kernel 2.6.27.1
Comment 4 Stefan Dirsch 2008-11-10 02:59:44 UTC
Sounds like a blocker to me. The only workaround for now is using vesa/fbdev driver.
Comment 5 Stefan Dirsch 2008-11-10 03:10:21 UTC
[...]
(II) intel(0): Output VGA disconnected
(WW) intel(0): No outputs definitely connected, trying again...
(II) intel(0): Output VGA disconnected
(WW) intel(0): Unable to find initial modes
(EE) intel(0): No valid modes.
Comment 6 Michael Fu 2008-11-10 17:17:47 UTC
would you please submit a log with "ModeDebug" option turns on?
Comment 7 Gordon Jin 2008-11-10 19:29:33 UTC
Does this hardware ever worked with previous intel driver 2.x? 
Comment 8 Guek Wu Neo 2008-11-10 20:30:11 UTC
Created attachment 20202 [details]
Xorg.0.log collected after adding Option ModeDebug on
Comment 9 Guek Wu Neo 2008-11-10 20:30:44 UTC
Created attachment 20203 [details]
xorg.conf with Option ModeDebug on
Comment 10 Stefan Dirsch 2008-11-10 20:38:16 UTC
(In reply to comment #7)
> Does this hardware ever worked with previous intel driver 2.x? 

I doubt that this hardware has ever been tested with an earlier intel 2.x release. I assume that it worked with i810 driver before though.

Comment 11 Wang Zhenyu 2008-11-10 22:08:13 UTC
855GM should at least have LVDS. What's your machine type? maybe we have wrong quirks?

Classic mode works fine on my R50e.
Comment 12 Guek Wu Neo 2008-11-10 22:40:13 UTC
Yes it has LVDS. This is a point of sales with 15" IR touch screen from Elo Technology. hwinfo in previous attached. 
Comment 13 Gordon Jin 2008-11-11 04:35:48 UTC
(In reply to comment #10)
> (In reply to comment #7)
> > Does this hardware ever worked with previous intel driver 2.x? 
> 
> I doubt that this hardware has ever been tested with an earlier intel 2.x
> release. I assume that it worked with i810 driver before though.
> 

If so, I don't think it's blocker.
Comment 14 Stefan Dirsch 2008-11-11 06:40:07 UTC
Sounds like Intel is not interested into supporting hardware, which has been supported before by i810 driver. A driver which is no longer available for X.Org 7.4 (missing support for libpciaccess).
Comment 15 Jesse Barnes 2008-11-13 13:10:55 UTC
Does this machine have a VBIOS you can attach to this bug?

# cd /sys/devices/pci0000\:00/0000\:00\:02.0/
# echo 1 > rom
# cat rom > /tmp/rom.bin
# echo 0 > rom

It may also be that you could use the LVDSFixedMode option for this device; if it's a special purpose platform that may be the expected usage.
Comment 16 Guek Wu Neo 2008-11-13 21:11:21 UTC
Created attachment 20292 [details]
rom.bin
Comment 17 Wang Zhenyu 2008-11-20 00:39:02 UTC
Just notified that our driver now has a lvds quirk on this board alike...could you try to remove following line from src/i830_quirk.c and try again?

    /* Cappuccino SlimPRO SP625F, bz #11368 */
    { PCI_CHIP_I855_GM, 0x8086, 0x3582, quirk_ignore_lvds },

Comment 18 Guek Wu Neo 2008-11-20 02:31:02 UTC
i did not locate the 'i830_quirk.c' in the sles11beta4 and sled11beta5 terminal that i have..
Comment 19 Stefan Dirsch 2008-11-20 05:37:35 UTC
Guek, you would need to recompile the xf86-video-intel driver from source. I'm not sure if Intel provides a HOWTO for this. From my mind:

 git-clone git://anongit.freedesktop.org/git/driver/xf86-video-intel
 cd xf86-video-intel
 ./autogen.sh
 make
 make install

You need to install git and gcc package (+dependancies) before. Hope this are tools, which are available on SLES/SLED Beta.

Comment 20 Stefan Dirsch 2008-11-22 02:26:53 UTC
Guek, just to double check. The vesa driver does work on this machine, right?
Comment 21 Guek Wu Neo 2008-11-23 17:40:30 UTC
yes. they work with vesa 
Comment 22 Michael Fu 2008-11-23 22:34:04 UTC
would you please attach your xorg.log using vesa or directfb? thanks.
Comment 23 Guek Wu Neo 2008-11-23 23:26:35 UTC
Created attachment 20535 [details]
Xorg.0.log when vesa driver used
Comment 24 Michael Fu 2008-11-25 23:03:33 UTC
(In reply to comment #17)
> Just notified that our driver now has a lvds quirk on this board alike...could
> you try to remove following line from src/i830_quirk.c and try again?
> 
>     /* Cappuccino SlimPRO SP625F, bz #11368 */
>     { PCI_CHIP_I855_GM, 0x8086, 0x3582, quirk_ignore_lvds },
> 

Guek, please also tell us the test result if you remove this from the source code... xorg.log file with ModeDebug turns on... thanks.
Comment 25 Guek Wu Neo 2008-11-25 23:23:22 UTC
In reply to comment#24,  Pls see my reply in comment#18.

there is not 'i830_quirk.c' file in the sles11beta4 and sled11beta5 terminal
that i have..




Comment 26 Michael Fu 2008-11-26 00:24:44 UTC
(In reply to comment #25)
> In reply to comment#24,  Pls see my reply in comment#18.
> 
> there is not 'i830_quirk.c' file in the sles11beta4 and sled11beta5 terminal
> that i have..
> 

there should be source code from sles release, isn't it? maybe you need to install the -dev package?  Stefan Dirsch should know...

To move this bug on, we have to rely on  you to do the testing since we don't have this device...

thanks.
Comment 27 Guek Wu Neo 2008-11-26 01:26:17 UTC
Stefan?
Comment 28 Stefan Dirsch 2008-11-26 03:26:38 UTC
Guek, Michael, please see my comment #19.
Comment 29 Vance 2008-11-27 02:33:01 UTC
Hi Stefan, I tried compiling the driver source but encountered some errors. Perhaps you can advise on this.

Upon running the script, I get the following error.

sles11beta4135:/tmp/xf86-video-intel # ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
configure.ac:273: error: must install xorg-macros 1.1.3 or later before running autoconf/autogen
configure.ac:273: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
Comment 30 Stefan Dirsch 2008-11-27 03:32:33 UTC
Vance, please install xorg-x11-proto-devel and xorg-x11-devel, e.g. by using

  zypper install xorg-x11-proto-devel xorg-x11-devel
Comment 31 Guek Wu Neo 2008-12-03 00:25:58 UTC
Stefan,

did not locate the xorg-x11-proto-devel and xorg-x11-devel 3dvds of Sles11beta6. git is not  in either.
where can we get them from? 


Comment 32 Matthias Hopf 2008-12-03 03:41:19 UTC
(In reply to comment #31)
> did not locate the xorg-x11-proto-devel and xorg-x11-devel 3dvds of
> Sles11beta6. git is not  in either.
> where can we get them from?

Sigh. Seems we don't publish developer packages for our enterprise betas.
You can get the packages from openSUSE 11.1 from

  http://download.opensuse.org/factory/repo/oss/suse/i586/

, they are compatible.
Comment 33 Guek Wu Neo 2008-12-03 20:14:14 UTC
managed to download and install the xorg-x11-proto-devel and xorg-x11-devel and their dependencies from the link. Thanks Stefan.

run './autogen.sh', move further. 

Stefan could you advise on  this error message.

./configure: line 12603: syntax error near unexpected token `XINERAMA,'
./configure: line 12603: `XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)'

Comment 34 Guek Wu Neo 2008-12-03 20:15:40 UTC
Created attachment 20802 [details]
this is output messages upon running ./autogen.sh
Comment 35 Wang Zhenyu 2008-12-03 21:36:46 UTC
Looks sles missed xineramaproto in xorg devel package. 
Comment 36 Matthias Hopf 2008-12-04 03:02:21 UTC
(In reply to comment #35)
> Looks sles missed xineramaproto in xorg devel package. 

You have to install xorg-x11-proto-devel. However, that should been a dependency of xorg-x11-devel.
Comment 37 qwang13 2008-12-04 10:08:38 UTC
The actual package should be xorg-x11-server-sdk.
try this if you still can not solve the build issue
Comment 38 Guek Wu Neo 2008-12-05 00:29:29 UTC
Created attachment 20828 [details]
Xorg.0.log and xorg.conf 

by the way, i only managed to locate i830_quirks.c (With a 's')

thanks QianXian able to compile after installing the xorg-x11-server-sdk and its dependencies.

this is what i did:

(1) removed the following from  xf86-video-intel/src/i830_quirks.c
/* Cappuccino SlimPRO SP625F, bz #11368 */
    { PCI_CHIP_I855_GM, 0x8086, 0x3582, quirk_ignore_lvds 

(2)cd xf86-video-intel
 ./autogen.sh
 make
 make install

(3) edit the xorg.conf to use intel driver and with ModeDebug on.

(4) reboot and till do not able to see display when startX
Comment 39 Wang Zhenyu 2008-12-07 17:57:03 UTC
I think you have wrong build or install of changed driver. Log should at least say LVDS ddc i2c initialization.
Try ./autogen.sh --prefix=/usr; make ; make install.
Comment 40 Guek Wu Neo 2008-12-08 19:13:50 UTC
Created attachment 20931 [details]
i830.quirks.c, dmesg, messages, Xorg.0.log and xorg.conf

this is what i did:

(1) removed the following from  xf86-video-intel/src/i830_quirks.c
/* Cappuccino SlimPRO SP625F, bz #11368 */
    { PCI_CHIP_I855_GM, 0x8086, 0x3582, quirk_ignore_lvds 

(2) Try ./autogen.sh --prefix=/usr; make ; make install.


(3) edit /etc/X11/xorg.conf to use intel video driver

(4) it works:-)
Comment 41 Wang Zhenyu 2008-12-08 21:06:44 UTC
Guek, thanks for verify this! I have removed origin quirk and added LVDS output detect patch into git master. Could you help to test if current git master works for you? This helps me to verify the LVDS detect logic. Thanks.
Comment 42 qwang13 2008-12-08 22:29:54 UTC
The commit should be 
1-0fe61b0b7e3bbe8ced1b0ad2be72c438d200c64b
2-4d7a95959d8223aec41550eb19f60b3edd7210a1

I attached the diff file for this, Guek, please patch this into you 2d driver and try this.

Novell, if it works, please add this patch into the SLE11 release.

Thanks for Zhenyu's great support
Comment 43 qwang13 2008-12-08 22:31:39 UTC
Created attachment 20938 [details]
new lvds detect patch from upstream 

commit
4d7a95959d8223aec41550eb19f60b3edd7210a1
0fe61b0b7e3bbe8ced1b0ad2be72c438d200c64b
Comment 44 Guek Wu Neo 2008-12-08 22:50:41 UTC
ZhenYu,

hv you completed the uploading of the package?
could you give me the link pls. thank you.
Comment 45 qwang13 2008-12-09 01:13:15 UTC
The attachment is uploaded.

See the last attachment file.
Comment 46 Guek Wu Neo 2008-12-09 01:27:05 UTC
do i need to rename the file? 
which folder  should i place the file to?
do i need to recompile the package?
Comment 47 Guek Wu Neo 2008-12-09 20:19:33 UTC
i am waiting for further helping instruction from Intel on how to install the patch to try out.
Comment 48 qwang13 2008-12-09 23:18:50 UTC
(In reply to comment #46)
> do i need to rename the file? 
No
> which folder  should i place the file to?
cd xf86-video-intel/; patch -p1 <$patch_file 
> do i need to recompile the package?
> 
Yes,
./autogen.sh --prefix=/usr
make -j4 install

Reboot xserver. (ctrl-alt-backspace or telinit 3 and then telinit 5)
Comment 49 Guek Wu Neo 2008-12-10 00:38:48 UTC
Created attachment 20991 [details]
Xorg.0.log i830_quirks.c and i830_lvds.c

Not able to start X using the intel driver after applying the patch.

Error message:Not able to start X with error message " maximum number of X
display failures reached.
Comment 50 Wang Zhenyu 2008-12-10 00:50:56 UTC
Could you paste the output of 'ls /proc/acpi/button'? Is there 'lid' directory under /proc/acpi/button directory?
Comment 51 Guek Wu Neo 2008-12-10 01:06:09 UTC
there is only a 'power' directory under '/proc/acpi/button'.

Do not see 'lid' directory under '/proc/acpi/button'
Comment 52 Wang Zhenyu 2008-12-10 04:20:19 UTC
Created attachment 21002 [details] [review]
Be LID_UNKNOWN when no lid acpi object found

Thanks. Could you help to apply and test with this patch? 

And there's a debug utility under xf86-video-intel source, src/bios_reader/swf_dumper, could you paste output from running this tool?
Comment 53 Wang Zhenyu 2008-12-10 04:21:41 UTC
Created attachment 21003 [details] [review]
Be LID_UNKNOWN when no lid acpi object found

Thanks. Could you help to apply and test with this patch? 

And there's a debug utility under xf86-video-intel source, src/bios_reader/swf_dumper, could you paste output from running this tool?
Comment 54 Wang Zhenyu 2008-12-10 04:22:27 UTC
Created attachment 21004 [details] [review]
Be LID_UNKNOWN when no lid acpi object found

Thanks. Could you help to apply and test with this patch? 

And there's a debug utility under xf86-video-intel source, src/bios_reader/swf_dumper, could you paste output from running this tool?
Comment 55 Guek Wu Neo 2008-12-10 20:30:46 UTC
Created attachment 21035 [details]
xorg.0.log swfdump xorg.conf 

display works with the patch from comment#52 using intel driver in xorg.conf
Comment 56 Wang Zhenyu 2008-12-10 21:55:37 UTC
Guek, thanks for your testing! I've pushed the patch to upstream.

commit 80e2d90139dd99f50beb4f9353599608624b777d
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Thu Dec 11 13:45:17 2008 +0800

    Let lid status be unknown if no acpi lid object found

commit 4d7a95959d8223aec41550eb19f60b3edd7210a1
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Tue Dec 9 19:48:11 2008 +0800

    Try to add LVDS detect support
    
    This one trys to use lid status for LVDS detect,
    which works when internal panel is not used as primary
    display alone, or there's no internal panel at all.
    ACPI button driver's lid state interface is preferred,
    and SWF state is also checked if ACPI method failed.

commit 0fe61b0b7e3bbe8ced1b0ad2be72c438d200c64b
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Tue Dec 9 19:19:58 2008 +0800

    Remove Cappuccino SlimPRO SP625F 855GM LVDS quirk
    
    It breaks bug #18462 on IBM 855GM with same subdevice ids.

Comment 57 Stefan Dirsch 2008-12-15 00:15:40 UTC
Guek, patches are now applied to our xorg-x11-driver-video package for SLE11, so next RC should include the fix.
Comment 58 Guek Wu Neo 2008-12-15 00:21:36 UTC
Noted. Will lookout in RC2 and feedback. Thank you.
Comment 59 Stefan Dirsch 2009-03-25 03:14:05 UTC
(In reply to comment #56)
> Guek, thanks for your testing! I've pushed the patch to upstream.
> 
> commit 80e2d90139dd99f50beb4f9353599608624b777d
> Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
> Date:   Thu Dec 11 13:45:17 2008 +0800
> 
>     Let lid status be unknown if no acpi lid object found
> 
> commit 4d7a95959d8223aec41550eb19f60b3edd7210a1
> Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
> Date:   Tue Dec 9 19:48:11 2008 +0800
> 
>     Try to add LVDS detect support
> 
>     This one trys to use lid status for LVDS detect,
>     which works when internal panel is not used as primary
>     display alone, or there's no internal panel at all.
>     ACPI button driver's lid state interface is preferred,
>     and SWF state is also checked if ACPI method failed.
> 
> commit 0fe61b0b7e3bbe8ced1b0ad2be72c438d200c64b
> Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
> Date:   Tue Dec 9 19:19:58 2008 +0800
> 
>     Remove Cappuccino SlimPRO SP625F 855GM LVDS quirk
> 
>     It breaks bug #18462 on IBM 855GM with same subdevice ids.

Unfortunately applying these patches caused severe regressions for a large part of our user base. The result for them is that no output is detected any longer,
so Xserver no longer comes up at all. Thus I'm afraid I need to reopen this one
and disable this patch for now. See

  https://bugzilla.novell.com/show_bug.cgi?id=486643 

for more details.

Bug 486643 - intel: No outputs detected after xorg-x11-driver-video update (855GM/915GM)
Comment 60 Wang Zhenyu 2009-03-25 08:01:54 UTC
Could you help to get X log with ModeDebug on?
Comment 61 Stefan Dirsch 2009-03-25 08:28:24 UTC
I will and let you know, once such a logfile is available.
Comment 62 Stefan Dirsch 2009-03-25 10:04:41 UTC
Created attachment 24239 [details]
Xorg.0_7.4-19.5.1.log

Xorg.0.log with ModeDebug on.
Comment 63 Wang Zhenyu 2009-03-25 17:54:42 UTC
(II) intel(0): LID switch detect closed with ACPI button

ok, so driver trys to know lid status through acpi button lid object, and that reported closed. 

We have seen this kind of hw with broken acpi, it's fixed through custom dsdt or driver has a BROKEN_ACPI_LID quirk if this hw's acpi can't be fixed with dsdt.

Could you ask user to attach acpidump? our acpi guy would like to see it.
Comment 64 Tomas Tichy 2009-03-25 23:54:14 UTC
Created attachment 24250 [details]
Xorg.0.log with ModeDebug on.
Comment 65 Tomas Tichy 2009-03-25 23:55:39 UTC
Created attachment 24251 [details]
Output of acpidump

I am suffering with the same behavior. 
Attached requested files.
Comment 66 Wang Zhenyu 2009-03-30 22:31:12 UTC

*** This bug has been marked as a duplicate of bug 20826 ***
Comment 67 Guek Wu Neo 2009-03-31 02:04:33 UTC
with the package mentioned in Bug #20826, what is the plan to have the fixed that we have verified to be working in this bug back in place for our terminal to function.


Comment 68 Stefan Dirsch 2009-03-31 02:40:55 UTC
Why? Does this patch break anything?
Comment 69 Guek Wu Neo 2009-03-31 03:06:00 UTC
Bug #20826 mentioned "disabled LVDS detect". Where else the package in this Bug#18462 comment#56  is with "LVDS detect".

Thus will the change in Bug#20826. Will it affect IBM terminal that is verfied to be working with package from Bug#18462 comment#56?
Comment 70 Stefan Dirsch 2009-03-31 03:35:48 UTC
Wang should know. Anyway, we saw so many regressions, that we currently don't have a choice anyway. And Luc, we're talking about patches, not about packages.
Patches are changes to the source code. 

  http://en.wikipedia.org/wiki/Patch_(computing)

Packages is something different ...
Comment 71 Guek Wu Neo 2009-04-05 19:10:40 UTC
Intel

could you respond on the query in comment#69
Comment 72 Michael Fu 2009-04-12 23:47:04 UTC
for your case ( 855GM with LVDS panel attached ), the revert of the change won't impact you, i.e. it by default assume any mobile chpset will come with a LVDS panel. So, even the patch is reverted , your case should still work.

Your problem is introduced by the patch of adding quirk for Cappuccino SlimPRO SP625F 855GM, which use exactly same board as you use but did _not_ come with a LVDS panel, commit 0fe61b0b7e3bbe8ced1b0ad2be72c438d200c64b get rid of this quirk. So it breaks another guy, but not you...