Bug 20826 - 2.6.99.902: LVDS wrongly detected as disconnected
Summary: 2.6.99.902: LVDS wrongly detected as disconnected
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
URL: https://qa.mandriva.com/show_bug.cgi?...
Whiteboard:
Keywords: regression
: 18462 (view as bug list)
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-03-24 07:13 UTC by Thierry Vignaud
Modified: 2009-03-30 23:50 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log with ModeDebug set to yes (25.12 KB, text/plain)
2009-03-26 01:49 UTC, Christophe Fergeau
no flags Details
X.log diff (patch against initial failed x.log: https://qa.mandriva.com/attachment.cgi?id=12869) (14.66 KB, patch)
2009-03-27 03:14 UTC, Thierry Vignaud
no flags Details | Splinter Review
another log diff (12.75 KB, text/plain)
2009-03-27 03:18 UTC, Thierry Vignaud
no flags Details
yet another log diff (15.97 KB, text/plain)
2009-03-27 03:18 UTC, Thierry Vignaud
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Vignaud 2009-03-24 07:13:27 UTC
Latest intel driver 2.6.99.902 failed on a lot of machines, saying no output can be found whereas 2.6.3 works smoothly.
Tested on Mobile GM965/GL960 Integrated Graphics Controller, Mobile 915GM/GMS/910GML Express, ...

See Mandriva Linux bug #49081: https://qa.mandriva.com/show_bug.cgi?id=49081

xorg's log diff between old & new driver: https://qa.mandriva.com/attachment.cgi?id=12867

xorg with 2.6.3 driver log: https://qa.mandriva.com/attachment.cgi?id=12868

xorg with 2.6.99.902 driver log: https://qa.mandriva.com/attachment.cgi?id=12869

The interesting part of the log diff is:
-(II) intel(0): Output LVDS connected
+(II) intel(0): Output LVDS disconnected
+(WW) intel(0): No outputs definitely connected, trying again...
+(II) intel(0): Output VGA disconnected
+(II) intel(0): Output LVDS disconnected
+(II) intel(0): Output TMDS-1 disconnected
+(II) intel(0): Output TV disconnected
+(WW) intel(0): Unable to find initial modes
+(EE) intel(0): No valid modes.
+(II) UnloadModule: "intel"
+(II) UnloadModule: "vgahw"
+(II) Unloading /usr/lib/xorg/modules//libvgahw.so
+(EE) Screen(s) found, but none have a usable configuration.
+
+Fatal server error:
+no screens found
Comment 1 Thierry Vignaud 2009-03-24 07:16:16 UTC
Btw we are _NOT_ using KMS...
Comment 2 Wang Zhenyu 2009-03-24 18:12:30 UTC
Could you turn on ModeDebug option and attach X log here?
Comment 3 Gordon Jin 2009-03-24 18:13:46 UTC
seems similar to bug#20752
Comment 4 Michael Fu 2009-03-25 21:08:08 UTC
(In reply to comment #3)
> seems similar to bug#20752
> 

No. this isn't VBT related. Otherwise, LVDS output won't even be created at all. This bug shows LVDS disconnected.
Comment 5 Christophe Fergeau 2009-03-26 01:49:56 UTC
Created attachment 24263 [details]
Xorg.0.log with ModeDebug set to yes

I'm also seeing this bug on a mandriva box with the same driver as the original reporter, here is the log you asked for. The machine is a macbook from August 2008 with an GM965 8086:2a02 (rev 03). Let me know if you need more information.
Comment 6 Christophe Fergeau 2009-03-26 01:54:22 UTC
Downgrading the intel driver to 2.6.3 (as packaged by mandriva) is enough to get X working (same xorg.conf, no package upgrade except for the x11 driver change).
Comment 7 Wang Zhenyu 2009-03-26 02:13:35 UTC
 Christophe, your problem is same at 20752, not this one. I have patch there to disable VBT parsing for LVDS completely.
Comment 8 Wang Zhenyu 2009-03-26 19:48:34 UTC
As Christophe's log is for another LVDS probe issue, Thierry could you paste X log with ModeDebug option on?
Comment 9 Thierry Vignaud 2009-03-27 03:14:01 UTC
Created attachment 24310 [details] [review]
X.log diff (patch against initial failed x.log: https://qa.mandriva.com/attachment.cgi?id=12869)

The problem is that I cannot reproduce it anymore.
There were a few backports on our xserver but I don't think that can impact this bug. I tried all releases of our intel & xserver packages without being able to reproduce it whereas I was able to reproduce it every time the other day.

I cannot think of any other package update that could have such an impact on this bug????

See history of our packages:
http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/x11-server/current/
http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/x11-driver-video-intel/current/

The diff shows some ACPI noise because now hal starts before acpid, thus preventing acpid from opening /proc/acpi/events
Comment 10 Thierry Vignaud 2009-03-27 03:18:26 UTC
Created attachment 24311 [details]
another log diff
Comment 11 Thierry Vignaud 2009-03-27 03:18:56 UTC
Created attachment 24312 [details]
yet another log diff

I've no clue for now...
Comment 12 Wang Zhenyu 2009-03-30 22:29:15 UTC
It should be relate to your ACPI module, it looks it failed to load somehow, and driver can't get lid status through it, then fallback to SWF BIOS state, which works on your machine. I'm going to disable current LVDS detect for 2.7 release.
Comment 13 Wang Zhenyu 2009-03-30 22:31:12 UTC
*** Bug 18462 has been marked as a duplicate of this bug. ***
Comment 14 Wang Zhenyu 2009-03-30 23:50:47 UTC
I have disabled LVDS detect in master now. Close this one, we should find a reliable way to reenable this.

commit 4f046af760b92c07f59664359453933fb5358e3d
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Tue Mar 31 13:49:44 2009 +0800

    Disable LVDS detect methods
    
    Both methods ACPI lid and SWF bit have issues in LVDS detect from
    wider testing. Fallback to origin code.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.