Bug 1873 - Requesting driver support for the ATI Radeon X700 chipset
Summary: Requesting driver support for the ATI Radeon X700 chipset
Status: RESOLVED DUPLICATE of bug 2827
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.1
Hardware: x86 (IA32) Linux (All)
: high enhancement
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-19 21:40 UTC by raxet
Modified: 2005-03-25 16:43 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raxet 2004-11-19 21:40:34 UTC
Currently there is no support for the ATI Radeon X700 chipset. The X600 and 
X800 series are supported. Apparently the X700 came later.
Comment 1 Alex Deucher 2004-11-20 10:52:04 UTC
x700 should be similar to x800; it's probably just a matter of adding hte new
chipid to the list.  try forcing the chipid to one of these (x800 variations):

0x4A48
0x4A49
0x4A4A
0x4A4B
0x4A4C
0x4A4D
0x4A4E
0x4A50

eg, add:

ChipID 0x4A48

to the device section of your config.

Alex
Comment 2 raxet 2004-11-26 13:01:21 UTC
has anyone looked at this enhancement request yet?
Comment 3 raxet 2004-11-27 21:54:07 UTC
Here is what Xorg.O.log reports for the ATI X 700 Pro for chipID:

(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) ATI Technologies Inc unknown chipset (0x5e4b) rev 0, Mem @
0xc0000000/28, 0xff4f0000/16, I/O @ 0x9800/8, BIOS @ 0xff4c0000/17
(--) PCI: (1:0:1) ATI Technologies Inc unknown chipset (0x5e6b) rev 0, Mem @
0xff4e0000/16
Comment 4 raxet 2004-12-16 12:07:37 UTC
What is the status here?
Comment 5 Jose Fonseca 2005-02-27 13:28:49 UTC
I tested and my RADEON X700 PRO (RV410 5E4B) works fine with a fresh Xorg CVS
checkout, if "ChipID 0x4A49" (Radeon X800 Pro) is addded.
Comment 6 Adam Jackson 2005-03-26 11:43:27 UTC

*** This bug has been marked as a duplicate of 2827 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.