Bug 2827 - Add new Radeon pci ids
Add new Radeon pci ids
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/Radeon
git
x86 (IA32) All
: high normal
Assigned To: Xorg Project Team
:
: 1873 2644 3693 3881 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 11:12 UTC by Alex Deucher
Modified: 2005-09-22 13:29 UTC (History)
10 users (show)

See Also:


Attachments
add new chips, and fix the numeric ordering (19.32 KB, patch)
2005-03-26 11:13 UTC, Alex Deucher
no flags Details | Splinter Review
updated patch (new radeon PCI IDs) (24.45 KB, patch)
2005-03-28 22:13 UTC, Alex Deucher
krh: 6.8‑branch?
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Deucher 2005-03-26 11:12:18 UTC
Add new radeon PCI ids from ati devrel.  I don't know if the RS400 chips need
any additional tweaks for support, I've set them as chip type RS300.  All new
R4xxs (X700, X850, etc.) seem to work ok as chiptype R420.
Comment 1 Alex Deucher 2005-03-26 11:13:26 UTC
Created attachment 2217 [details] [review]
add new chips, and fix the numeric ordering
Comment 2 ajax at nwnk dot net 2005-03-26 11:43:29 UTC
*** Bug 1873 has been marked as a duplicate of this bug. ***
Comment 3 ajax at nwnk dot net 2005-03-26 11:45:03 UTC
*** Bug 2644 has been marked as a duplicate of this bug. ***
Comment 4 Alex Deucher 2005-03-28 06:22:35 UTC
I'll clean up the naming tonight and add bus info (AGP/PCIE, etc.).  Hui or
Michel, is anything else special needed for these chipsets?
Comment 5 Daniel Stone 2005-03-28 06:50:50 UTC
nothing special as such, but the radeon_probe.c changes could be handy :)
Comment 6 Alex Deucher 2005-03-28 06:56:02 UTC
d'oh! I knew I forgot something!
Comment 7 Michel Dänzer 2005-03-28 07:46:26 UTC
The only thing I can think of is that the PCI Express chipsets will need special
GART code, so the DRI should be disabled on them for now.
Comment 8 Alex Deucher 2005-03-28 08:41:10 UTC
(In reply to comment #7)
> The only thing I can think of is that the PCI Express chipsets will need special
> GART code, so the DRI should be disabled on them for now.

I guess the pci-gart cell has changed from the previous version?  I was thinking
on Athlon64s/Opterons, couldn't we use the on-chip IOMMU to handle the GART? 
that's what we do for AGP cards right now instead of using the AGP chip, at
least on 64-bit kernels.
Comment 9 Alex Deucher 2005-03-28 22:13:53 UTC
Created attachment 2231 [details] [review]
updated patch (new radeon PCI IDs)

updated patch.
Comment 10 Alex Deucher 2005-03-29 06:48:17 UTC
*** Bug 2834 has been marked as a duplicate of this bug. ***
Comment 11 Alex Deucher 2005-03-31 15:18:45 UTC
committed to cvs
Comment 12 ajax at nwnk dot net 2005-07-28 02:13:51 UTC
*** Bug 3693 has been marked as a duplicate of this bug. ***
Comment 13 ajax at nwnk dot net 2005-07-28 02:15:30 UTC
*** Bug 3881 has been marked as a duplicate of this bug. ***
Comment 14 Kristian Høgsberg 2005-09-21 07:23:51 UTC
Comment on attachment 2231 [details] [review]
updated patch (new radeon PCI IDs)

Nominating for 6.8.3
Comment 15 Alex Deucher 2005-09-21 07:29:30 UTC
(In reply to comment #14)
> (From update of attachment 2231 [details] [review] [edit])
> Nominating for 6.8.3
> 

This patch is out of date. the XPRESS chips sets are actually RV3xx based, not
RS300 based as this patch sets them.  You'll probably want to grab the latest
updates from xorg cvs.
Comment 16 T. Hood 2005-09-23 06:29:10 UTC
(In reply to comment #15)
> This patch is out of date. the XPRESS chips sets are actually RV3xx based, not
> RS300 based as this patch sets them.  You'll probably want to grab the latest
> updates from xorg cvs.

Cf. #3869