Bug 18940 - [GEM] performance degradation after vt_switch on all platforms
Summary: [GEM] performance degradation after vt_switch on all platforms
Status: VERIFIED DUPLICATE of bug 18879
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: high major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18841
  Show dependency treegraph
 
Reported: 2008-12-07 19:25 UTC by liuhaien
Modified: 2009-01-11 22:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (49.96 KB, text/plain)
2008-12-07 19:25 UTC, liuhaien
Details
xorg conf file (3.36 KB, text/plain)
2008-12-07 19:26 UTC, liuhaien
Details
dmesg (35.51 KB, text/plain)
2008-12-07 22:27 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-07 19:25:07 UTC
Created attachment 20881 [details]
xorg.0.log

System Environment:
--------------------------
Host:		x-915gm
Arch:		i386
xf86_video_intel   xf86-video-intel-2.6-branch
       commit b156b3165e1aae5df0353737d0335ac2e653f5fd

mesa   intel-2008-q4 branch
       commit 154a9e5317f890618932cea0129ef887e16baf84

kernel  for-airlied branch
        commit 66647dc60d16fae9f6963fd98b6d9baa1a8dac69

libdrm  master branch
       commit b0d93c74d884b40bd94469a5ef75fdb2fef17680

xserver 1.6 is recommended.


Bug detailed description:
-------------------------
startx, vt-switch after runing a glxgears, the performance will go down to about 1 fps from 60 fps, and gears seems like still. 
 
Reproduce steps:
----------------
1. xinit&
2. gnome-session&
3. chvt 1
4. chvt 7
Comment 1 liuhaien 2008-12-07 19:25:46 UTC
and it only happens on 915gm.
Comment 2 liuhaien 2008-12-07 19:26:11 UTC
Created attachment 20882 [details]
xorg conf file
Comment 3 liuhaien 2008-12-07 19:27:32 UTC
sorry ,reproduce steps should be :

Reproduce steps:
----------------
1. xinit&
2. gnome-session&
3. glxgears 
4. chvt 1
5. chvt 7
Comment 4 Gordon Jin 2008-12-07 21:15:12 UTC
Zhenyu, can you take a look at that machine?
Comment 5 Wang Zhenyu 2008-12-07 21:32:49 UTC
I can't see it on 915G here, could you retest current 2.6 branch and for-airlied?
Comment 6 Gordon Jin 2008-12-07 21:38:32 UTC
Haien, anything special in dmesg?
Comment 7 liuhaien 2008-12-07 22:27:15 UTC
Created attachment 20884 [details]
dmesg
Comment 8 liuhaien 2008-12-07 22:31:24 UTC
I have tested the latest 2.6 branch and for-airlied kernel and get the same issue,
I have closed compiz,but dmesg shows:
[drm] Initialized i915 1.6.0 20080730 on minor 0
compiz[2749]: segfault at 20 ip 080537ad sp bfb1fd10 error 4 in compiz[8047000+33000]
thinkpad_acpi: CMOS NVRAM (7) and EC (6) do not agree on display brightness level

Comment 9 Wang Zhenyu 2008-12-07 22:42:55 UTC
haien, don't try to mess up the bug. ;)

I did exactly in comment #3, but not saw this problem.
Comment 10 Gordon Jin 2008-12-07 22:52:56 UTC
(In reply to comment #9)
> haien, don't try to mess up the bug. ;)
> 
> I did exactly in comment #3, but not saw this problem.

Zhenyu, it's not surprising you can't reproduce this on your machine, as this 915gm is the only machine suffered by this issue out of so many QA machines. So please stick to this machine. 

Comment 11 liuhaien 2008-12-16 23:45:36 UTC
now this issue spreads to all platforms against below commit:
Libdrm:         (master)c86d431fe6174b1c2de531929213ea7dbd92326d
Mesa_stable:    (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
Xserver_stable:  (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel_stable:                (xf86-video-intel-2.6-branch)
                            83f3c376b5942e134047a220e6e5f2432ffc492c
		
Comment 12 Michael Fu 2008-12-18 22:48:42 UTC
(In reply to comment #11)
> now this issue spreads to all platforms against below commit:
> Libdrm:         (master)c86d431fe6174b1c2de531929213ea7dbd92326d
> Mesa_stable:    (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
> Xserver_stable:  (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
> Xf86_video_intel_stable:                (xf86-video-intel-2.6-branch)
>                             83f3c376b5942e134047a220e6e5f2432ffc492c
> 
> 

haien, other than glxgears, do you see obvious render performance downgrade such as surfing the net,etc?
Comment 13 liuhaien 2008-12-21 21:16:11 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > now this issue spreads to all platforms against below commit:
> > Libdrm:         (master)c86d431fe6174b1c2de531929213ea7dbd92326d
> > Mesa_stable:    (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
> > Xserver_stable:  (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
> > Xf86_video_intel_stable:                (xf86-video-intel-2.6-branch)
> >                             83f3c376b5942e134047a220e6e5f2432ffc492c
> > 
> > 
> 
> haien, other than glxgears, do you see obvious render performance downgrade
> such as surfing the net,etc?
> 

just 3D demos.
Comment 14 Gordon Jin 2009-01-06 21:52:22 UTC
Jesse's patch on bug#18879 (VT switch vblank issue) also fixes this, so I'm marking dup.

*** This bug has been marked as a duplicate of bug 18879 ***
Comment 15 liuhaien 2009-01-11 22:44:49 UTC
verified agaist:
xf86_video_intel   xf86-video-intel-2.6-branch
       commit 4447973345a2a7af20ba1d6cb18c5f1ed8949d00 (2.5.99.2)

mesa   intel-2008-q4 branch
       commit eef0dcc298f65158dc750a09f80317ded1101dc7 (before and close to
7.3)

kernel  drm-intel-2.6.28 branch
        commit e1a6fcee467556a7e955fe1f7ccc134dd2f974e7 (2.6.28 + 5 patches)

libdrm  master branch
       commit ac8b3308b9432edef5cabe30559004314d42d98c (after 2.4.3)

xserver server-1.6-branch
 commit 8cfb353078d9b5d03a9633304038141a60adc970


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.