Bug 19089 - [GLSL] glsl1/shadow2D() cases fail
[GLSL] glsl1/shadow2D() cases fail
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Ian Romanick
:
Depends on:
Blocks: intel-3d-release 29044
  Show dependency treegraph
 
Reported: 2008-12-14 22:23 UTC by liuhaien
Modified: 2010-11-08 18:39 UTC (History)
0 users

See Also:


Attachments
xorg.0.log (42.17 KB, text/plain)
2008-12-14 22:23 UTC, liuhaien
Details
xorg conf file (3.76 KB, text/plain)
2008-12-14 22:24 UTC, liuhaien
Details
glsl.log (21.21 KB, text/plain)
2008-12-14 23:34 UTC, liuhaien
Details
glsl log (601 bytes, text/plain)
2009-10-09 20:47 UTC, fangxun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-14 22:23:56 UTC
Created attachment 21148 [details]
xorg.0.log

System Environment:
--------------------------
Libdrm:         (master)9583c099b4a08b49e03f7b461c344b6d277fd262
Mesa_stable:            (intel-2008-q4)154a9e5317f890618932cea0129ef887e16baf84
Xserver_stable: (server-1.6-branch)d6129ebf8dad9cfbc13dc8db7c780b023bf9a60b
Xf86_video_intel_stable:(xf86-video-intel-2.6-branch) 
                     005127b5825993d2fe3c36e3a01a37ea6904739e
GEM kernel (for-airlied)8b1fae4e4200388b64dd88065639413cb3f1051c


Bug detailed description:
-------------------------
glean cases glsl1 run failed on all 965 platforms(G965 ,G45 and GM45).
Reproduce steps:
----------------
1.xinit&
2. run glean cases (glsl1)
Comment 1 liuhaien 2008-12-14 22:24:52 UTC
Created attachment 21149 [details]
xorg conf file
Comment 2 liuhaien 2008-12-14 22:26:19 UTC
and 915 machines works well.
Comment 3 liuhaien 2008-12-14 23:33:56 UTC
glsl.log in the attachment is the output when run glean/glsl1.
Comment 4 liuhaien 2008-12-14 23:34:19 UTC
Created attachment 21152 [details]
glsl.log
Comment 5 Ian Romanick 2009-02-20 15:43:30 UTC
Does this commit fix the failure?

Module: Mesa
Branch: master
Commit: da2b661ee45a2754bab06359477428ef7df570ca
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=da2b661ee45a2754bab06359477428ef7df570ca

Author: Brian Paul <brianp@vmware.com>
Date:   Fri Feb 20 10:47:28 2009 -0700

intel: fix datatype typo, s/GLboolean/GLuint/

Fixes mysterious failures in glean glsl1 test.
Comment 6 liuhaien 2009-02-22 23:21:06 UTC
(In reply to comment #5)
> Does this commit fix the failure?
> 
> Module: Mesa
> Branch: master
> Commit: da2b661ee45a2754bab06359477428ef7df570ca
> URL:   
> http://cgit.freedesktop.org/mesa/mesa/commit/?id=da2b661ee45a2754bab06359477428ef7df570ca
> 
> Author: Brian Paul <brianp@vmware.com>
> Date:   Fri Feb 20 10:47:28 2009 -0700
> 
> intel: fix datatype typo, s/GLboolean/GLuint/
> 
> Fixes mysterious failures in glean glsl1 test.
> 

hi,Ian
it still fails against this commit.
Comment 7 liuhaien 2009-03-22 20:41:38 UTC
still exists against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 8 Eric Anholt 2009-10-09 12:16:53 UTC
glsl1 is many different testcases which would each need to be treated separately.
Comment 9 fangxun 2009-10-09 20:47:31 UTC
Created attachment 30241 [details]
glsl log

It still fails with current commits:
Libdrm: (master)ac71f0849928f4b2fbb69c01304ac6f9df8916a1
Mesa:   (master)44c6c20b69839ea130a255496f5f692186b68793
Xserver: (master)c0a1bb511a4629bf5683d8a710dc4a1c577a5d44
Xf86_video_intel: (master)1556c62e0336ea2fef866722ee44d2d188e318f3
Kernel_unstable: (drm-intel-next)8d91104aac6e21e6ca2a56124e2e47b0db043ea8
Comment 10 Gordon Jin 2010-08-15 19:45:16 UTC
Now with glsl2 branch (443a7e4e9a360acbc3e662c098be436f180bf81d), there are 6 failures (also existing with master branch):
FAILURE:
  Shader test: temp array with swizzled variable indexing
  Link error: Variable indexing of variable arrays in the FS unsupported
FAILURE:
  Shader test: texture2D(), with bias
  Expected color: 0.5, 0, 0, 0.5
  Observed color: 1, 0, 0, 1
FAILURE:
  Shader test: shadow2D(): 1
  Expected color: 0.25, 0.25, 0.25, 1
  Observed color: 0.25098, 0.25098, 0.25098, 0.25098
FAILURE:
  Shader test: shadow2D(): 3
  Expected color: 0.25, 0.25, 0.25, 1
  Observed color: 0.25098, 0.25098, 0.25098, 0.25098
FAILURE:
  Shader test: function with early return (4)
  Link error: i965 driver doesn't yet support uninlined function calls.  Move to using a single return statement at the end of the function to work around it.
FAILURE:
  Shader test: texcoord varying
Vertex shader did not compile:
0:3(15): error: unsized array index must be constant
glsl1:  FAIL rgba8, db, z24, s8, win+pmap, id 33
	238 tests passed, 6 tests failed.

And master branch has additional 3 failures:
FAILURE:
  Shader test: function with early return (1)
  Link error: i965 driver doesn't yet support uninlined function calls.  Move to using a single return statement at the end of the function to work around it.
FAILURE:
  Shader test: function with early return (2)
  Link error: i965 driver doesn't yet support uninlined function calls.  Move to using a single return statement at the end of the function to work around it.
FAILURE:
  Shader test: function with early return (3)
  Link error: i965 driver doesn't yet support uninlined function calls.  Move to using a single return statement at the end of the function to work around it.
Comment 11 Eric Anholt 2010-08-22 18:42:23 UTC
From now on, this bug will just be about the shadow2D cases.  The function call one is represented in many other bug reports, and variable indexing of variable arrays is also in another report.  For other glsl1-framework testcases that fail, please open separate reports.
Comment 12 Eric Anholt 2010-10-02 23:50:53 UTC
commit a7fa00dfc5ab5782b2e497fbf4ca292dde69cdbd
Author: Eric Anholt <eric@anholt.net>
Date:   Sat Oct 2 23:27:31 2010 -0700

    i965: Set up swizzling of shadow compare results for GL_DEPTH_TEXTURE_MODE.
    
    The brw_wm_surface_state.c handling of GL_DEPTH_TEXTURE_MODE doesn't
    apply to shadow compares, which always return an intensity value.  The
    texture swizzles can do the job for us.
    
    Fixes:
    glsl1-shadow2D(): 1
    glsl1-shadow2D(): 3
Comment 13 Gordon Jin 2010-11-08 18:39:40 UTC
verified, and the whole glsl1 has passed on i965 since Oct 16th, though still fail on i915.