Bug 19231 - [g45] ut2004 hangs X
[g45] ut2004 hangs X
Status: VERIFIED DUPLICATE of bug 21330
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: Eric Anholt
:
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-12-22 01:08 UTC by lin, jiewen
Modified: 2009-08-10 02:18 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
log (49.29 KB, text/plain)
2008-12-22 01:08 UTC, lin, jiewen
Details
conf (3.77 KB, text/plain)
2008-12-22 01:09 UTC, lin, jiewen
Details
backtrace from ut2004 (6.73 KB, text/plain)
2009-01-07 10:01 UTC, Sven Arvidsson
Details
backtrace from xorg (6.74 KB, text/plain)
2009-01-07 10:01 UTC, Sven Arvidsson
Details
xorg log (28.02 KB, text/plain)
2009-01-07 10:02 UTC, Sven Arvidsson
Details
dmesg output (40.34 KB, text/plain)
2009-01-07 10:02 UTC, Sven Arvidsson
Details
gpu dump (242.18 KB, application/x-gzip)
2009-05-21 15:29 UTC, Sven Arvidsson
Details
backtrace from xorg (64.46 KB, text/plain)
2009-05-21 15:29 UTC, Sven Arvidsson
Details
Xorg log (2.47 KB, text/plain)
2009-05-21 15:30 UTC, Sven Arvidsson
Details
dmesg output (44.03 KB, text/plain)
2009-05-21 15:30 UTC, Sven Arvidsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-12-22 01:08:37 UTC
Created attachment 21385 [details]
log

System Environment:
--------------------------

--Platform: G45
--Architecture(32-bit,64-bit,compatiblity): 64-bit
--2D driver:
(xf86-video-intel-2.6-branch)83f3c376b5942e134047a220e6e5f2432ffc492c
--3D driver: (intel-2008-q4)f96baeaac3ef41260ac3975750627ece073fdce0
--DRM: shipped with kernel 2.6.28-rc8-for-airlied
--libdrm: (master)0243c9f801a35de3465a0321c02f18a4d07ce5b8
--Xserver:  (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
--Kernel: 2.6.28-rc8-for-airlied

Bug detailed description:
--------------------------
start X and run ut2004, play for about 20 minutes, X hung.
Reproduce steps:
----------------
1. xinit &
2. ut2004
Comment 1 lin, jiewen 2008-12-22 01:09:04 UTC
Created attachment 21386 [details]
conf
Comment 2 Gordon Jin 2008-12-22 04:38:57 UTC
This may only happen on 64-bit.
On 32-bit G45, we are seeing bug#16520.
Comment 3 lin, jiewen 2008-12-25 19:06:00 UTC
It also exists on q965.
Comment 4 lin, jiewen 2008-12-25 19:21:27 UTC
(In reply to comment #3)
> It also exists on q965.
> 
It is a mistake, sorry.
Comment 5 lin, jiewen 2008-12-25 21:29:21 UTC
965 does not have this issue.
Comment 6 zhao jian 2008-12-28 21:47:27 UTC
It also exist on gm45 32-bit in UXA mode. 
Comment 7 Sven Arvidsson 2009-01-06 12:34:07 UTC
I have the same problem with UT2004 on my G45. Using:

-- chipset: G45 / ICH10R
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- Machine or mobo model: Asus P5Q-EM
-- Display connector: DVI
-- xf86-video-intel: d8e89b26ef5ef2c15e5d34162b14d279a7f0bb1c
-- xserver: 1.5.3
-- mesa: a8ee35c1c59c23938e0a18b163515acc892ed407
-- drm: 0243c9f801a35de3465a0321c02f18a4d07ce5b8
-- kernel: drm-intel-2.6.28 72e2bfb03f46f7eef1ae8907593dd35e2c5603de

I have experienced the hang with a non-GEM kernel (2.6.27) too so I guess this isn't GEM-related, or I'm seeing a different bug.
Comment 8 Sven Arvidsson 2009-01-07 10:01:23 UTC
Created attachment 21754 [details]
backtrace from ut2004

I'm attaching backtraces and logs from the hang, but I don't know if they're of much use.
Comment 9 Sven Arvidsson 2009-01-07 10:01:53 UTC
Created attachment 21755 [details]
backtrace from xorg
Comment 10 Sven Arvidsson 2009-01-07 10:02:23 UTC
Created attachment 21756 [details]
xorg log
Comment 11 Sven Arvidsson 2009-01-07 10:02:56 UTC
Created attachment 21757 [details]
dmesg output
Comment 12 lin, jiewen 2009-01-16 00:24:13 UTC
This issue still eixsts with current build.
Comment 13 Sven Arvidsson 2009-05-21 15:29:06 UTC
Created attachment 26081 [details]
gpu dump

This is still a problem, I'm attaching a gpu dump in case that's helpful.

System environment:
-- chipset: G45 / ICH10R
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- Machine or mobo model: Asus P5Q-EM
-- Display connector: DVI
-- xf86-video-intel: 87332a7cc16af82aa47e07fbf90da3635b071dbf
-- xserver: 1.6.1.901
-- mesa: 08ec7e0d329a72433b427e8167b2c3442d1f53b4
-- drm: f57d7f4b0b14972f92a83f155ae8033478aa7729
-- kernel: 2.6.30-rc6
Comment 14 Sven Arvidsson 2009-05-21 15:29:36 UTC
Created attachment 26082 [details]
backtrace from xorg
Comment 15 Sven Arvidsson 2009-05-21 15:30:06 UTC
Created attachment 26083 [details]
Xorg log
Comment 16 Sven Arvidsson 2009-05-21 15:30:27 UTC
Created attachment 26084 [details]
dmesg output
Comment 17 Yifei Chen 2009-06-04 20:19:32 UTC
It works fine on G45 now, ut2004 runs flawlessly for more than 30 minutes, tested on:

Arch:           x86_64
OSD:            Fedora release 10 (Cambridge)
Kernel_version:         2.6.30-rc7-KMS
Libdrm:         (master)2cb4c64d7310904b354365c2cbc263211e9eb4a1
Mesa:           (master)086ecea179ed572c89aa77c5f465671a5cef87a7
Xf86_video_intel:               (master)4afbe3b75e53cca1254883f2e847cf93cf9f0d71
Comment 18 Sven Arvidsson 2009-06-05 14:28:24 UTC
Still a problem for me. I'm using most things from git master, and rc8 of the kernel:

-- xf86-video-intel: 66ceedc0cc123e5c9f85f708b2e56d943f00e4b9
-- xserver: 1.6.1.901
-- mesa: 4c034441a8f12e4bf60b8c5f58202d5ae00ff31d
-- drm: 3d4bfe8c893d016ef43d1ebf28e4607aa1f540a4
-- kernel: 2.6.30-rc8
Comment 19 Gordon Jin 2009-06-05 16:37:49 UTC
change the title as this bug is for Sven now.
Comment 20 Eric Anholt 2009-06-30 13:32:10 UTC
Closing this as a dupe of the other ut2004-hangs-on-g/gm45 bug that has a reliable way to reproduce.


*** This bug has been marked as a duplicate of bug 22130 ***
Comment 21 Sven Arvidsson 2009-06-30 13:53:04 UTC
Wrong bug? Should be 21330?
Comment 22 Eric Anholt 2009-06-30 15:31:28 UTC
Yeah, that, thanks.


*** This bug has been marked as a duplicate of bug 21330 ***