Bug 19415 - [945GM] X fail to start on kernel 2.6.28
Summary: [945GM] X fail to start on kernel 2.6.28
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords: NEEDINFO
: 21265 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-05 23:01 UTC by Li Peng
Modified: 2009-07-09 00:55 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Li Peng 2009-01-05 23:01:58 UTC
kernel 2.6.28
Xorg 1.5.99.3
xf86-video-intel 2.5.99.1
mesa intel-2008-q4 branch

X failed to start and print following kernel message 

[drm:i915_irq_emit] *ERROR* i915_irq_emit called without lock held, held  0 owner 00000000 de8de9c0
Comment 1 Li Peng 2009-01-05 23:12:27 UTC
After bisect, below commit cause the problem, revert it could fix the issue. It is strange that my kernel config has "CONFIG_HIGHMEM64G=y", and GEM works with this option.

commit ac5c4e76180a74c7f922f6fa71ace0cef45fa433
Author: Dave Airlie <airlied@redhat.com>
Date:   Fri Dec 19 15:38:34 2008 +1000

    drm/i915: GEM on PAE has problems - disable it for now.
    
    On PAE systems, GEM allocates pages using shmem, and passes these
    pages to be bound into AGP, however the AGP interfaces + the x86
    set_memory interfaces all take unsigned long not dma_addr_t.
    
    The initial fix for this was a mess, so we need to do this correctly
    for 2.6.29.

Comment 2 Andrés Becerra Sandoval 2009-02-23 06:31:01 UTC
I found the same problem that Li Peng in Gentoo with the following versions:

xorg-server-1.5.3
xf86-video-intel-2.6.1
media-libs/mesa-7.3
gentoo-sources-2.6.28-r1  (linux kernel 2.6.28.1 )


But, with the same versions of the programs and a new kernel:

gentoo-sources-2.6.28-r2  (linux kernel 2.6.28.5)

X is starting and working correctly.

Comment 3 Gordon Jin 2009-04-20 01:10:51 UTC
*** Bug 21265 has been marked as a duplicate of this bug. ***
Comment 4 Hugo Jacques 2009-04-23 08:08:00 UTC
FYI, I do get the same kind of problem with 2.6.28.9 on a 945G system
xorg server 1.6.0
xf86-video-intel 2.7.0
libdrm 2.4.7
mesa 7.3
Comment 5 Gordon Jin 2009-07-09 00:15:34 UTC
Peng, does this still exist in the latest kernel?
Comment 6 Li Peng 2009-07-09 00:24:30 UTC
(In reply to comment #5)
> Peng, does this still exist in the latest kernel?
> 

No, it is be fixed with Dave's agp patch in 2.6.31. 
Comment 7 Hugo Jacques 2009-07-09 00:29:24 UTC
(English message follows) Bonjour, Je suis en congé parental jusqu'au 13 jullet 2009. Pour toute urgence concernant le travail, veuillez contacter Louis Marchand (louis.marchand@verint.com). 

Hi, I will be out of office until July 13th 2009. For any urgent matters regarding work, please contact Louis Marchand (louis.marchand@verint.com). Hugo
Comment 8 Gordon Jin 2009-07-09 00:55:47 UTC
closing as the reporter says it's fixed.
If other people still have problem with 2.6.31, please file separate bugs.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.