Bug 19543 - UXA accelleration renders compiz transparency bleached
Summary: UXA accelleration renders compiz transparency bleached
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2009-01-13 11:22 UTC by Martin
Modified: 2009-07-16 07:35 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Picture showing the bleached transparancy rendering of UXA and normal for EXA (59.16 KB, image/jpeg)
2009-01-13 11:22 UTC, Martin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2009-01-13 11:22:44 UTC
Created attachment 21951 [details]
Picture showing the bleached transparancy rendering of UXA and normal for EXA

I'm testing Kubuntu Jaunty with xorg-edgers packages (launchpad.net) and noticed that when I'm using UXA (which implies DRI2) transparancy in compiz is rendered bleached. I've attached a screenshot to explain the bug.
Intel driver in xorg-edgers momentarily is 2.6.99, xorg server 1.5.99.3, DRI2 is 1.5.99.3
Comment 1 Martin 2009-01-13 13:23:02 UTC
Forgot to mention the hardware: GM965/GL960.
Comment 2 Alex Hofbauer 2009-01-18 03:03:59 UTC
Don't know if that helps, but I can confirm that bug with GM45 and 4500MHD using git master branch of every component involved (mesa, libdrm, xorg, video-intel, kernel+drm-intel-next).
Comment 3 Martin 2009-02-11 11:12:46 UTC
This only happens with compiz. KDE composite window manager (kwin) also has transparency but doesn't bleach.
Comment 4 Mingming 2009-03-03 01:52:25 UTC

*** This bug has been marked as a duplicate of bug 19970 ***
Comment 5 Eric Anholt 2009-03-10 11:59:52 UTC
Reopening because I the fix this was marked as a dupe of shouldn't have fixed this, and I think I reproduced it just the other day with Mesa master.
Comment 6 Martin 2009-03-11 00:47:52 UTC
Confirm that the bug is still present with Tormods intel driver in Jaunty:
2:2.6.99.1+git20090309.dc12c4b3-0ubuntu0tormod
Comment 7 Eric Anholt 2009-03-20 11:37:11 UTC
I can't reproduce this now with current Mesa master.  Could you re-test?
Comment 8 Sven Arvidsson 2009-03-21 08:55:39 UTC
Works fine for me too, using Mesa commit 699897e81c623e53be51fba0488f535b0a8d7761.
Comment 9 Martin 2009-03-28 13:21:53 UTC
Fixed for me too! Thx.
Comment 10 Vasilis Vasaitis 2009-05-18 10:49:40 UTC
(Not sure if it's best to reopen this bug or submit a new one, but since the description of this one matches the behaviour I'm experiencing exactly, I thought I'd reuse it.)

When I switch from EXA to UXA, I get the following behaviour under compiz:

- First of all, anything that has 100% opacity displays fine.

- Completely black areas become completely transparent, at any opacity other than 100%.

- Anything else that is partially transparent creates a "washed out" effect when blended with the background. The effect is more pronounced as the luminance and the opacity increases; i.e. it's worse for bright areas compared to dark areas, and it's worse for high opacity compared to high transparency.

With EXA everything displays fine.

Hardware information:

Dell Optiplex GX620
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
Intel(R) Pentium(R) D CPU 3.00GHz (running in 64-bit mode)
monitor connected to the VGA connector

System information:

Debian GNU/Linux unstable
kernel: linux-image-2.6.29-2-amd64 2.6.29-5 (based on upstream 2.6.29.3)
X server: xserver-xorg-core 2:1.6.1.901-2
intel driver: xserver-xorg-video-intel 2:2.7.1-1
mesa: libgl1-mesa-glx 7.4.1-1
libdrm: libdrm-intel1 2.4.9-2 / libdrm2 2.4.9-2

I have also tested this with xserver-xorg-video-intel 2:2.7.99.1-1 from Debian experimental; the result is exactly the same.

I can attach xorg.conf / Xorg.0.log / dmesg as needed.

Thanks,
Vasilis
Comment 11 Vasilis Vasaitis 2009-06-25 06:46:01 UTC
Just thought I'd mention that I've just tried this again with kernel 2.6.30 (again the Debian stock kernel, package linux-image-2.6.30-1-amd64 2.6.30-1), both with xserver-xorg-video-intel 2:2.7.1-1 and 2:2.7.99.901-2, and the problem remains the same.
Comment 12 Eric Anholt 2009-07-15 17:34:25 UTC
Vasilis: you're running old Mesa.
Comment 13 Vasilis Vasaitis 2009-07-16 07:28:43 UTC
OK, fair enough. I've just tried with version 7.5~rc4-1 of the libgl1-mesa-glx package from Debian experimental, and while a few of the visual artifacts I've described have disappeared, quite a few of them remain too. Might I ask which version I would need to get? Thanks.
Comment 14 Vasilis Vasaitis 2009-07-16 07:35:38 UTC
Never mind, I missed libgl1-mesa-dri when I was upgrading the packages, everything displays correctly now thanks. :^)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.