Bug 19970 - [OGLC] RGBA readback from RGB8 visual gives wrong alpha value
Summary: [OGLC] RGBA readback from RGB8 visual gives wrong alpha value
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: high normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 20321 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-05 08:53 UTC by Ian Romanick
Modified: 2009-08-24 12:33 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2009-02-05 08:53:30 UTC
Reading RGBA color via glReadPixels from an RGB visual should always give an alpha value of 1.0.  However, on RGB8 visuals that are stored in R8G8B8x8, the alpha value is coming back as random values.  This started with anholt's recent changes to intel fbconfigs.

I have listed this against i965, but I suspect that it impacts other Intel chipset drivers as well.
Comment 1 Gordon Jin 2009-02-05 22:55:58 UTC
increasing priority as this seems to be impacting many cases.
Comment 2 Eric Anholt 2009-02-18 13:24:24 UTC
mustpass.c seems happy now -- do you have a specific testcase?
Comment 3 Eric Anholt 2009-02-25 23:02:15 UTC
commit 119f34e2a52d7e074ea51d49acf6c11d83142ccc
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Feb 25 22:54:51 2009 -0800

    intel: Fix up x8r8g8b8 renderbuffer format so that alpha=1 spans code happens.
    
    I was lured into a false sense of security by the fact that the spans code was
    already there, and a bunch of tests didn't catch the problem.  oglconform's
    mask.c did, though.
    
    Bug #19970.
Comment 4 Mingming 2009-03-03 01:52:25 UTC
*** Bug 19543 has been marked as a duplicate of this bug. ***
Comment 5 Mingming 2009-03-03 01:53:08 UTC
*** Bug 20321 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2009-08-24 12:31:49 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.