Bug 19545 - please support GeForce 9400M
Summary: please support GeForce 9400M
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Aaron Plattner
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 23044 23214 23629 26356 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-13 16:00 UTC by Johannes Berg
Modified: 2010-03-05 12:38 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Berg 2009-01-13 16:00:12 UTC
Version selection confuses me, it's nv 2.1.12.

Here's what it has to say:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.17.7 x86_64 Debian
Current Operating System: Linux johannes 2.6.29-rc1-wl-11361-g269245b-dirty #15 
SMP PREEMPT Tue Jan 13 17:44:51 CET 2009 x86_64
Build Date: 12 November 2008  12:59:43PM
xorg-server 2:1.5.3-1 (buildd@xenophanes) 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 14 00:53:18 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Configured Monitor"
(==) No device specified for screen "Default Screen".
        Using the first device section listed.
(**) |   |-->Device "Configured Video Device"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Touchpad"
(**) |-->Input Device "Configured Mouse"
(**) Option "DontZap" "true"
(==) Automatically adding devices
(==) Automatically enabling devices

[fontpath stuff]

(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
        If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Generic Keyboard
(WW) Disabling Configured Mouse
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x7b1ec0
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 4.1
        X.Org XInput driver : 2.1
        X.Org Server Extension : 1.1
        X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 8
(--) PCI: (0@0:3:5) nVidia Corporation MCP79 Co-processor rev 177, Mem @ 0x93300000/524288
(--) PCI:*(0@2:0:0) nVidia Corporation GeForce 9400M rev 177, Mem @ 0x92000000/16777216, 0x80000000/268435456
, 0x90000000/33554432, I/O @ 0x00001000/128, BIOS @ 0x????????/131072
(II) System resource ranges:
        [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1  0       0x0000ffff - 0x0000ffff (0x1) IX[B]
        [5] -1  0       0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(==) AIGLX enabled
(==) Exporting typical set of GLX visuals
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 1.5.3, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "record"

(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) Scanning /usr/share/xserver-xorg/pci directory for additional PCI ID's supported by the drivers
(==) Matched nv for the autoconfigured driver
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "nv"

(II) Loading /usr/lib/xorg/modules/drivers//nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
        compiled for 1.5.0, module version = 2.1.12
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "synaptics"

(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.4.99.906, module version = 0.15.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
[...]
        GeForce 9200M GS, GeForce 9300M GS, Quadro NVS 150M, Quadro NVS 160M
(II) Primary Device is: PCI 02@00:00:0
(WW) NV: Ignoring unsupported device 0x10de0863 (GeForce 9400M) at 02@00:00:0
(EE) No devices detected.

Fatal server error:
no screens found
Comment 1 Bill Yerazunis 2009-01-25 10:43:37 UTC
Same here.  I'm blocked on running some important software on my 
MacBook Unibody (top of the line unit, too) without 9400M support.

   - Bill Yerazunis
Comment 2 Johannes Berg 2009-05-04 14:48:20 UTC
Is there anything we could do to help with this?
Comment 3 Anssi Hannula 2009-07-18 04:19:23 UTC
Desktop integrated GeForce 9400 is also unsupported.
(WW) NV: Ignoring unsupported device 0x10de086a (GeForce 9400) at 02@00:00:0
Comment 4 Aaron Plattner 2009-07-31 01:16:19 UTC
*** Bug 23044 has been marked as a duplicate of this bug. ***
Comment 5 Aaron Plattner 2009-08-10 07:49:39 UTC
*** Bug 23214 has been marked as a duplicate of this bug. ***
Comment 6 Aaron Plattner 2009-09-01 10:49:59 UTC
*** Bug 23629 has been marked as a duplicate of this bug. ***
Comment 7 David 2009-09-02 03:02:22 UTC
Is there a way to force xorg to start at the moment with this chipset?
Comment 8 Aaron Plattner 2009-09-02 08:00:17 UTC
With the Ubuntu live CD, I don't know.  You'll need to talk to the Ubuntu guys to find out why it's not falling back to the vesa driver and if there's a way to force it to do that.
Comment 9 David 2009-09-05 07:11:26 UTC
I think the error is occurring when xorg falls back on mesa, though I'm not sure. My log is here: http://launchpadlibrarian.net/31135314/XorgLog.txt
Comment 10 Aaron Plattner 2010-02-01 12:42:04 UTC
*** Bug 26356 has been marked as a duplicate of this bug. ***
Comment 11 David 2010-02-03 08:01:44 UTC
Not sure if this is reason enough to see this bug fixed, but I no longer have this problem using ubuntu 9.10
Comment 12 Aaron Plattner 2010-03-05 12:38:34 UTC
Please give this git commit a try:


commit 9378ecd34ad71083602232b56e8810d6cd39b518
Author: Aaron Plattner <aplattner@nvidia.com>
Date:   Wed Mar 3 20:29:55 2010 -0800

    Bug #19545: Add support for MCP7x-based integrated GPUs.
    
    Based in part on an idea from Ben Skeggs.
    
    Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
    Signed-off-by: Andy Ritger <aritger@nvidia.com>
    Reviewed-by: Christian Zander <chzander@nvidia.com>

:100644 100644 e37782d... 9bbe5cd... M  man/nv.man
:100644 100644 8ea45af... 324e180... M  src/g80_driver.c
:100644 100644 67dc0cd... 707e994... M  src/nv_driver.c


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.