Bug 23044 - please add support for GeForce 9400M G (0x10de0866)
Summary: please add support for GeForce 9400M G (0x10de0866)
Status: RESOLVED DUPLICATE of bug 19545
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other Linux (All)
: high critical
Assignee: Aaron Plattner
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2009-07-30 11:15 UTC by Bryce Harrington
Modified: 2009-07-31 01:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (10.34 KB, text/x-log)
2009-07-30 11:16 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-07-30 11:15:20 UTC
Forwarding this Ubuntu bug from Mario Limonciello:
https://bugs.edge.launchpad.net/ubuntu/+source/xorg-server/+bug/385658

[Problem]
Similar to bug #19545, the 9400M G (pci id 0866) needs support.  Tested with 2.1.14-2ubuntu2

  (WW) NV: Ignoring unsupported device 0x10de0866 (C79 [GeForce 9400M G]) at 03@00:00:0

[Original Report]
Testing out the daily image from June 10 2009, the live cd is not booting up to X. It is falling back to failsafe graphics mode.

This is because it's selecting the NV graphics driver rather than VESA. The Studio XPS 1340's graphics cards are NOT supported by NV and are not called out in the PCI ID files in /usr/share/xserver-xorg/pci.

ProblemType: Bug
Architecture: i386
Date: Wed Jun 10 13:27:13 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090609)
NonfreeKernelModules: wl
Package: xserver-xorg-video-nv 1:2.1.13-1ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4~5ubuntu21
 libgl1-mesa-glx 7.4.1-1ubuntu1
 libdrm2 2.4.11-0ubuntu1
 xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu2
 xserver-xorg-video-ati 1:6.12.2-2ubuntu1
SourcePackage: xserver-xorg-video-nv
Uname: Linux 2.6.30-8-generic i686
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.30-8-generic

[lspci]
00:00.0 Host bridge [0600]: nVidia Corporation MCP79 Host Bridge [10de:0a82] (rev b1)
02:00.0 VGA compatible controller [0300]: nVidia Corporation G98 [GeForce 9200M GS] [10de:06e8] (rev a1)
	Subsystem: Dell Device [1028:0271]
03:00.0 VGA compatible controller [0300]: nVidia Corporation C79 [GeForce 9400M G] [10de:0866] (rev b1)
	Subsystem: Dell Device [1028:0271]
Comment 1 Bryce Harrington 2009-07-30 11:16:14 UTC
Created attachment 28202 [details]
Xorg.0.log
Comment 2 Bryce Harrington 2009-07-30 11:24:37 UTC
For some additional background...  This particular hardware has dual cards.  Previously when we saw this issue in Jaunty we patched xserver to force xserver to select the first pci video device, which worked when we were using the pci.ids approach for detecting hardware.  However, now that we're not using pci.ids files to detect the hardware, this issue has cropped up again.

But for this particular bug report I'd like to focus on the core issue that support seems to be missing for the video card.  Gaining that support would obviously be the ideal solution to this problem.
Comment 3 Aaron Plattner 2009-07-31 01:16:19 UTC
The regression is in the X server, and is being addressed by the PCI boot device sysfs query work.  C79 indeed doesn't work yet; there's some hardware initialization step that's missing that I haven't yet managed to track down, so it's not as simple as just adding the PCI IDs.

Adding NV driver support for this GPU would not fix the server regression that prevents it from picking any GPU when there are more than one.

*** This bug has been marked as a duplicate of bug 19545 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.