Bug 19546 - [gm965] glsl demo noise locks X
[gm965] glsl demo noise locks X
Status: CLOSED DUPLICATE of bug 22622
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Eric Anholt
:
: 20851 (view as bug list)
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-01-13 17:27 UTC by lin, jiewen
Modified: 2012-10-23 07:04 UTC (History)
2 users (show)

See Also:


Attachments
log (45.34 KB, text/plain)
2009-01-13 17:27 UTC, lin, jiewen
Details
conf (3.35 KB, text/plain)
2009-01-13 17:27 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2009-01-13 17:27:18 UTC
Created attachment 21959 [details]
log

System Environment:
--------------------------
--Platform: 965
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver:
(xf86-video-intel-2.6-branch)4447973345a2a7af20ba1d6cb18c5f1ed8949d00
--3D driver: (intel-2008-q4)eef0dcc298f65158dc750a09f80317ded1101dc7
--DRM: shipped with kernel
--libdrm: (master)ac8b3308b9432edef5cabe30559004314d42d98c
--Xserver:  (server-1.6-branch)93e510d3abaee97f5b7812abc3a2693dabf94478
--Kernel: drm-intel e1a6fcee467556a7e955fe1f7ccc134dd2f974e7

Bug detailed description:
--------------------------
start X and run demo noise, no new window displayed. Kill noise and run apps, get no response. Kill X and restart it, get a black screen.
Reproduce steps:
----------------
1. startx &
2. ./mesa/progs/glsl/noise
Comment 1 lin, jiewen 2009-01-13 17:27:45 UTC
Created attachment 21960 [details]
conf
Comment 2 lin, jiewen 2009-01-13 17:29:31 UTC
Q965 and g45 is fine, this bug may be gm965 one only. 
Comment 3 lin, jiewen 2009-01-13 17:34:11 UTC
The bt info:

#0  0xb809f424 in __kernel_vsyscall ()
#1  0x437ffc89 in ioctl () from /lib/libc.so.6
#2  0xb7edb7b3 in drmIoctl (fd=13, request=25688, arg=0x0) at xf86drm.c:187
#3  0xb7edb932 in drmCommandNone (fd=13, drmCommandIndex=24) at xf86drm.c:2313
#4  0xb7e6804f in I830BlockHandler (i=0, blockData=0x0, pTimeout=0xbfe9eab8,
    pReadmask=0x81deb60) at i830_driver.c:2656
#5  0x0816a1ee in AnimCurScreenBlockHandler (screenNum=0, blockData=0x0,
    pTimeout=0xbfe9eab8, pReadmask=0x81deb60) at animcur.c:222
#6  0x08136235 in compBlockHandler (i=0, blockData=0x0, pTimeout=0xbfe9eab8,
    pReadmask=0x81deb60) at compinit.c:158
#7  0x08089eba in BlockHandler (pTimeout=0xbfe9eab8, pReadmask=0x81deb60)
    at dixutils.c:384
#8  0x081240f0 in WaitForSomething (pClientsReady=0x83091a8) at WaitFor.c:215
#9  0x0808632d in Dispatch () at dispatch.c:367
#10 0x0806c42d in main (argc=2, argv=0xbfe9ec04, envp=Cannot access memory at address 0x6460
) at main.c:383
Comment 4 lin, jiewen 2009-01-16 00:24:14 UTC
This issue still eixsts with current build.
Comment 5 Gordon Jin 2009-03-24 20:42:46 UTC
*** Bug 20851 has been marked as a duplicate of this bug. ***
Comment 6 liuhaien 2009-06-04 01:21:54 UTC
still exists with the latest code:
Libdrm:		(master)00fae87f96e1fc5198311feec81866bf9c53d0e1
Mesa:		(master)9f6ec50f8c79283583eeebdebd16bf7dcd134816
Xserver:		(master)7f027d9dc0146e229802aeac342ea2dbab63264a
Xf86_video_intel:		(master)b8e360bf2b77d28559d15a7c0f9c766848eb6ced
Kernel:       (for-linus)07f4f3e8a24138ca2f3650723d670df25687cd05
Comment 7 Gordon Jin 2009-07-05 17:57:26 UTC

*** This bug has been marked as a duplicate of bug 22622 ***