Bug 20851 - [gm965 GLSL]mesa/glsl case noise hangs X with EXA and UXA
[gm965 GLSL]mesa/glsl case noise hangs X with EXA and UXA
Status: VERIFIED DUPLICATE of bug 19546
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Gordon Jin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 20:32 UTC by liuhaien
Modified: 2009-07-02 00:11 UTC (History)
0 users

See Also:


Attachments
xorg.0.log (57.85 KB, text/plain)
2009-03-24 20:32 UTC, liuhaien
Details
xorg conf file (3.93 KB, text/plain)
2009-03-24 20:33 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-03-24 20:32:48 UTC
Created attachment 24222 [details]
xorg.0.log

System Environment:
--------------------------

Platform:       gm965
Arch:           x86_64
OSD:            Fedora release 10
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa:  (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:(server-1.6-branch) 60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:                (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680     

Bug detailed description:
--------------------------
X hangs when run mesa glsl/noise.we can close X by running "pkill -9 X",after that ,a blank screen will come out when restart X.this issue only happens on gm965 with both exa and uxa, it is ok on q965 ,g33 and g45.
following is the backtrace from gdb and ctrl+c:
#0  0x0000003a11cde037 in ioctl () from /lib64/libc.so.6
#1  0x00007fee0b1de111 in drmIoctl (fd=13, request=25688, arg=0x0)
    at xf86drm.c:187
#2  0x00007fee0b1de226 in drmCommandNone (fd=13,
    drmCommandIndex=<value optimized out>) at xf86drm.c:2313
#3  0x00007fee0ad5a3d8 in I830BlockHandler (i=0, blockData=0x0,
    pTimeout=0x7fff14c060d8, pReadmask=0x7c2b20) at i830_driver.c:2637
#4  0x0000000000520964 in AnimCurScreenBlockHandler (screenNum=0,
    blockData=0x0, pTimeout=0x7fff14c060d8, pReadmask=0x7c2b20)
    at animcur.c:222
#5  0x00000000004ef09e in compBlockHandler (i=0, blockData=0x0,
    pTimeout=0x7fff14c060d8, pReadmask=0x7c2b20) at compinit.c:158
#6  0x000000000044a2a0 in BlockHandler (pTimeout=0x7fff14c060d8,
    pReadmask=0x7c2b20) at dixutils.c:384
#7  0x00000000004de34c in WaitForSomething (pClientsReady=0x5753dc0)
    at WaitFor.c:215
#8  0x000000000044695b in Dispatch () at dispatch.c:367
#9  0x000000000042ddab in main (argc=2, argv=0x7fff14c06288,
    envp=<value optimized out>) at main.c:397


Reproduce steps:
----------------
1. xinit&
2.run mesa/glsl/noise
Comment 1 liuhaien 2009-03-24 20:33:10 UTC
Created attachment 24223 [details]
xorg conf file
Comment 2 Gordon Jin 2009-03-24 20:42:46 UTC
this seems dup with bug#19546.

*** This bug has been marked as a duplicate of bug 19546 ***