Bug 19734 - [G45] Random hangs with UXA
Summary: [G45] Random hangs with UXA
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-01-25 07:48 UTC by Sven Arvidsson
Modified: 2009-03-10 12:02 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg backtrace (2.65 KB, text/plain)
2009-01-25 07:48 UTC, Sven Arvidsson
no flags Details
Xorg conf (1012 bytes, text/plain)
2009-01-25 07:48 UTC, Sven Arvidsson
no flags Details
dmesg output (42.78 KB, text/plain)
2009-01-25 07:49 UTC, Sven Arvidsson
no flags Details
Xorg log (47.30 KB, text/plain)
2009-01-25 07:49 UTC, Sven Arvidsson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2009-01-25 07:48:33 UTC
Created attachment 22223 [details]
Xorg backtrace

I'm getting random hangs in Xorg when UXA is enabled. 

As I upgraded both drm, xserver and xf86-video-intel at the same time I have returned to using EXA to rule out that anything else is causing the hangs.

System environment:
-- chipset: G45 / ICH10R
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- Machine or mobo model: Asus P5Q-EM
-- Display connector: DVI
-- xf86-video-intel: b6f3ce32e295929f461a7bc37e61f126fb51e4aa
-- xserver: 1.5.99.901
-- mesa: 03188b09e071ace9d9e21ccc56c01e90c0fa8639
-- drm: 27fae006853647ad0087067adc4eaa8d4ed4594a
-- kernel: drm-intel-2.6.28 72e2bfb03f46f7eef1ae8907593dd35e2c5603de
Comment 1 Sven Arvidsson 2009-01-25 07:48:52 UTC
Created attachment 22224 [details]
Xorg conf
Comment 2 Sven Arvidsson 2009-01-25 07:49:09 UTC
Created attachment 22225 [details]
dmesg output
Comment 3 Sven Arvidsson 2009-01-25 07:49:24 UTC
Created attachment 22226 [details]
Xorg log
Comment 4 Sven Arvidsson 2009-01-27 06:34:41 UTC
EXA is stable, so it probably is a problem with UXA.
Comment 5 Sven Arvidsson 2009-03-03 06:35:44 UTC
After upgrading to the versions mentioned below, UXA seems stable. 

-- xf86-video-intel: 4a0d19ef4f210cea9e60c5acc355df03723ef808
-- drm: 4a0d19ef4f210cea9e60c5acc355df03723ef808
-- kernel: drm-intel-next 126fd9c96d80260a1f2d8dfc72e444e572bcafb7
Comment 6 Eric Anholt 2009-03-10 12:02:04 UTC
If you say it's fixed, I'll close it for now since there's no instructions for how we should try to reproduce the problem.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.