Bug 19738 - [945GM] Any 3D app is slow in resolution higher than 800x600 with UXA+DRI2, due to tiling
Summary: [945GM] Any 3D app is slow in resolution higher than 800x600 with UXA+DRI2, d...
Status: RESOLVED DUPLICATE of bug 16835
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 20276
  Show dependency treegraph
 
Reported: 2009-01-25 13:37 UTC by Vasily Khoruzhick
Modified: 2009-03-10 18:07 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (18.52 KB, text/plain)
2009-01-25 13:37 UTC, Vasily Khoruzhick
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasily Khoruzhick 2009-01-25 13:37:24 UTC
Created attachment 22239 [details]
Xorg.0.log

Any 3D application is _really_ slow if it runs in window with size higher than 
800x600.

Steps to reproduce:

1. Use gma950 hardware with xf86-video-intel from git and mesa from git, 
xorg-server-1.5.99.901, libdrm from git, 2.6.28 kernel + 6 patches
2. Download and install secret maryo chronicles (or any game you like that 
uses 3D)
3. Disable fullscreen mode and set resolution to 800x600 - game should run 
smoothly
4. Disable fullscreen mode and set resolution to 1024x768 (or higher) - game 
should became unplayable.
Comment 1 Eric Anholt 2009-01-27 17:45:12 UTC
Please attach dmesg with driver bugs.

The main problem I see from your log is that tiling isn't being set up.
Comment 2 Gordon Jin 2009-01-31 06:39:19 UTC
Will this be the performance issue fixed by jbarnes for DRI2?
Comment 3 Vasily Khoruzhick 2009-01-31 06:45:22 UTC
Can't check. With latest driver from git Xserver (1.5.99.902) eats all swap and then all memory in ~5 minutes. I've rolled back to 2.6.1, I can provide dmesg info with it.
Comment 4 Vasily Khoruzhick 2009-03-01 03:46:47 UTC
Just tested with latest xf86-video-intel from git and kernel-2.6.29-rc6, and here's results:

With tiling enabled 3D performance is low even in resolutions below 800x600,
with tiling disabled 3D performance is OK in resolutions below 800x600, but is low in resolutions higher than 800x600.

My system uses dual channel memory in interleaved mode, can it be reason of low performance with tiling enabled?
Comment 5 Eric Anholt 2009-03-10 18:07:45 UTC

*** This bug has been marked as a duplicate of bug 16835 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.