Bug 20052 - [i915 UXA] mesa xdemo manywin fails: only the first window has animation displayed
Summary: [i915 UXA] mesa xdemo manywin fails: only the first window has animation disp...
Status: CLOSED DUPLICATE of bug 18262
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: lowest normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 20263 (view as bug list)
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-02-11 02:08 UTC by zhao jian
Modified: 2015-05-14 02:23 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (3.76 KB, text/plain)
2009-02-11 02:08 UTC, zhao jian
Details
xorg.0.log (48.21 KB, text/plain)
2009-02-11 02:09 UTC, zhao jian
Details
xorg.0.log (48.21 KB, text/plain)
2009-02-11 02:09 UTC, zhao jian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2009-02-11 02:08:58 UTC
Created attachment 22801 [details]
xorg.conf

System Environment:
--------------------------

Platform:	945gm
Arch:		i386
OSD:		Fedora release 9 (Sulphur)
Kernel:		2.6.28
Libdrm:            (master)7bbd605a21200e5e4beb94f261aefe30c4e7853d
Mesa:		   (mesa_7_4_branch)7e8f2c56c00f93ad55842dc5e3b123a1fcf74b3c
Xserver:	   (server-1.6-branch)1f729b42d567ae9533ac0e467afc9fbc83390776
Xf86_video_intel:  (master)3aa8591abfbe8db0f13912910c850fdd748808df
kernel:         (drm-intel-2.6.28)e1a6fcee467556a7e955fe1f7ccc134dd2f974e7
 

Bug detailed description:
--------------------------
With UXA, start X,then run manywin n(n>1), just the first window has animation displayed. But if with EXA, it will be only the last window has animation displayed. 

Reproduce steps:
----------------
1. xinit &
2. ./manywin 10
Comment 1 zhao jian 2009-02-11 02:09:38 UTC
Created attachment 22802 [details]
xorg.0.log
Comment 2 zhao jian 2009-02-11 02:09:59 UTC
Created attachment 22803 [details]
xorg.0.log
Comment 3 Gordon Jin 2009-02-11 17:27:35 UTC
the EXA issue was tracked at bug#18262
Comment 4 liuhaien 2009-02-23 01:27:46 UTC
*** Bug 20263 has been marked as a duplicate of this bug. ***
Comment 5 zhao jian 2009-03-23 00:28:18 UTC
It still existed on 945gm-32 with the following configuration:
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:         (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:      (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Comment 6 Eric Anholt 2009-08-03 11:11:24 UTC

*** This bug has been marked as a duplicate of bug 18262 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.