Bug 18262 - [GEM] mesa xdemo manywin fails: only the last window has animation displayed
[GEM] mesa xdemo manywin fails: only the last window has animation displayed
Status: CLOSED DUPLICATE of bug 41736
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
x86 (IA32) Linux (All)
: low normal
Assigned To: Eric Anholt
:
: 20052 20820 (view as bug list)
Depends on: 41736
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-10-28 01:45 UTC by lin, jiewen
Modified: 2015-05-14 02:22 UTC (History)
3 users (show)

See Also:


Attachments
xorg conf file (3.67 KB, text/plain)
2008-10-28 01:45 UTC, lin, jiewen
Details
xorg.0,log (47.14 KB, text/plain)
2008-10-28 01:45 UTC, lin, jiewen
Details
screenshot of mesa/xdemos/manywin (396.40 KB, image/png)
2009-06-03 02:27 UTC, Yifei Chen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-10-28 01:45:06 UTC
Created attachment 19901 [details]
xorg conf file

System Environment:
--------------------------

--Platform: gm45 945 965
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (master)87ea531c5dc5b39809395b277c330854aaaaf019
--3D driver: intel-2008-q3 branch 46921a5ee832a3443894dcc98e065d2f535e899d
--DRM:shipped with kernel 2.6.27stolen-mem
--libdrm: (master)1d930fc75b99a89fc77d35d8f95f2877cfd5d7f0
--Xserver: (master)102c4dac7c521941f52652152b1660cd7f559d56
--Kernel: 2.6.27-rc9(drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49 

Bug detailed description:
--------------------------
start X,then run manywin n(n>1), just the last window has animation displayed.
Reproduce steps:
----------------
1. xinit &
2. ./manywin 10
Comment 1 lin, jiewen 2008-10-28 01:45:47 UTC
Created attachment 19902 [details]
xorg.0,log
Comment 2 lin, jiewen 2008-10-28 02:04:57 UTC
Correct the System Environment:


System Environment:
--------------------------

--Platform: gm45 945 965
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (master)87ea531c5dc5b39809395b277c330854aaaaf019
--3D driver: (master)2a877411dbe35abdd8c15fb4821d9232619d89cc
--DRM:shipped with kernel 2.6.27-rc9(drm-intel-next)
--libdrm: (master)1d930fc75b99a89fc77d35d8f95f2877cfd5d7f0
--Xserver: (master)102c4dac7c521941f52652152b1660cd7f559d56
--Kernel: 2.6.27-rc9(drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49 
Comment 3 lin, jiewen 2008-12-09 01:17:37 UTC
With current code, the issue still exists.
Comment 4 Gordon Jin 2009-01-16 00:06:59 UTC
Jiewen, does this still exist?
Comment 5 lin, jiewen 2009-01-16 00:24:12 UTC
This issue still eixsts with current build.
Comment 6 liuhaien 2009-03-22 23:26:14 UTC
(In reply to comment #5)
> This issue still eixsts with current build.
> 

still exists against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01

Comment 7 Yifei Chen 2009-06-03 02:27:49 UTC
Created attachment 26386 [details]
screenshot of  mesa/xdemos/manywin
Comment 8 Yifei Chen 2009-06-03 02:31:13 UTC
we found a new symptom of manywin may be related to this bug, when run many n wiith n > 2, there's a random number of windows have animation displayed, some with color while some are not, please see attachment for screenshot.
Comment 9 Eric Anholt 2009-08-03 11:11:24 UTC
*** Bug 20052 has been marked as a duplicate of this bug. ***
Comment 10 Eric Anholt 2009-08-03 11:11:50 UTC
*** Bug 20820 has been marked as a duplicate of this bug. ***
Comment 11 fangxun 2009-09-09 02:56:57 UTC
Still fail with following commits:
Libdrm:         (master)121b9648f846d900e67818869974ee82046e9b25
Mesa:           (mesa_7_6_branch)9216b4e7be942fed432ceb42a4337d7298d0bc6c
Xserver:        (server-1.6-branch)3044711412d0a08ba65a491bd2441c0c8980f5e2
Xf86_video_intel:    (master)94fc93d4e2b88565dca17f72903d8991213c9ee8
Kernel:         (master)e07cccf4046978df10f2e13fe2b99b2f9b3a65db

Comment 12 meng 2011-03-07 03:58:46 UTC
This issue still happens with following commits:
-------------------------------------------------------------------
Libdrm:    (master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:      (master)6538b5824e298eaebede2d9686c7607c44ab446
Xserver:                (master)xorg-server-1.10.0
Xf86_video_intel:       (master)2.14.901
Kernel:    (drm-intel-fixes) 91355834646328e7edc6bd25176ae44bcd7386c7
Comment 13 cc 2011-10-12 01:21:48 UTC
Still fail with following commits on the IVB and SNB platform, BUT sth different, the case finished unexpectly,end report a message:
intel_do_flush_locked failed: No such file or directory


OSD:		Fedora release 13 (Goddard)
Kernel_version:		2.6.31.12
Libdrm:		(master)2.4.26-11-gc82ef03e4c92017bf5644f294ea04e30500f8d4c
Mesa:		(master)a13eed4b826d0bb5dfcb5e63651987a232df8a06
Xserver:		(master)xorg-server-1.11.0-176-gfae7ed62ad476114bd37b566202cf6b6546c0a1f
Xf86_video_intel:		(master)2.16.0-119-gd0184b59095d5b8fab1a65ceba075d29189130d4
Cairo:		(master)3d51ec8a7928f313d73023cabe0d760cf1946458
Libva:		(master)8384a84cd03a1c0ef4c57f7d0c2e8cc6e71b7c91
Kernel_unstable:		(drm-intel-next)64a742fac3a22f57303d8f1b7e347350a1c48254
Comment 14 cc 2011-10-12 17:23:59 UTC
Following with the Latest test result,Sth different,So I report a new Bug 41736.
Comment 15 Guang Yang 2011-11-04 02:08:05 UTC
This issue still happens with following commits:
Libdrm:         (master)2.4.27-1-g961bf9b5c2866ccb4fedf2b45b29fb688519d0db
Mesa:           (7.11)b95767a57ad499a2ed7431e8b0b52966c6dc0a45
Kernel:         (master)c3b92c8787367a8bb53d57d9789b558f1295cc96
Comment 16 ye.tian 2013-02-22 03:28:45 UTC
The issue still exists with the follow commits:
---------------------------------
Kernel_version:     3.8
Libdrm:             2.4.42
Mesa:               (9.1)9.1-rc2
Xserver:            (server-1.13-branch)xorg-server-1.13.2
Xf86_video_intel:   (master)2.21.0
Cairo:              (master)1.12.12
Libva:              staging-20130205
Libva_intel_driver: staging-20130205
Comment 17 shui yangwei 2013-06-14 05:54:45 UTC
This issue also exists in below environment:
-----------------------------------
Kernel: 3.9.5
Mesa: 9.1.3 (almost the same as RC1)
Libdrm: 2.4.45 (even older than RC1)
Xf86-video-intel: 2.21.9
Libva: master (to be 1.2)
Libva-intel-driver: master (to be 1.2)
Cairo: 1.12.14
Xserver: 1.14
Comment 18 Eric Anholt 2013-09-30 23:30:38 UTC
mark as duplicate of the updated version of this bug.

*** This bug has been marked as a duplicate of bug 41736 ***