Bug 20262 - [i915 i965]readpix failed in toggling scale and bias (right window white)
[i915 i965]readpix failed in toggling scale and bias (right window white)
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: lowest normal
Assigned To: Eric Anholt
:
: 22491 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 22:40 UTC by liuhaien
Modified: 2009-08-31 22:39 UTC (History)
1 user (show)

See Also:


Attachments
xorg.0.log (18.09 KB, text/plain)
2009-02-22 22:40 UTC, liuhaien
Details
xorg conf file (4.17 KB, text/plain)
2009-02-22 22:40 UTC, liuhaien
Details
screenshot of readpix (842.10 KB, image/png)
2009-02-22 22:41 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-02-22 22:40:00 UTC
Created attachment 23192 [details]
xorg.0.log

System Environment:
--------------------------
Platform: g45
Architecture(32-bit,64-bit,compatiblity): 64-bit 
Libdrm:         (master)4a0d19ef4f210cea9e60c5acc355df03723ef808
Mesa:            (mesa_7_4_branch)e2092bb23c956ba9ab940935f803ef843db81af2
Xserver:         (server-1.6-branch)4557b3f6c4273cd83b701beaf7a150c806fed298
Xf86_video_intel:               (master)81c652e9a666a7459bcc5217c8a5ec518b6e00da
GEM_Kernel (for-airlied)99d31f896d243c13bb90b56620d33b416a5cffa7

Bug detailed description:
--------------------------
start X,then run readpix, and press s to toggle scale/bias. Only the middle one
(Read/Drawpixs) will have change the on on the right get nothing but a white window.(As shown in the attached screenshot) And it should be that both the middle and the right one change together.  it works well On q965 and 945gm. 

Reproduce steps:
----------------
1. xinit&
2. gnome-session&
3. demo/readpix
Comment 1 liuhaien 2009-02-22 22:40:33 UTC
Created attachment 23193 [details]
xorg conf file
Comment 2 liuhaien 2009-02-22 22:41:41 UTC
Created attachment 23194 [details]
screenshot of readpix
Comment 3 Eric Anholt 2009-03-03 12:58:41 UTC
scale and bias with ReadPixels is definitely not a release blocker.
Comment 4 liuhaien 2009-03-18 23:11:37 UTC
verified against:
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:(server-1.6-branch) 60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:                (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680	
Comment 5 liuhaien 2009-05-15 00:02:59 UTC
this bug happens again. we test it with:
Libdrm:		(master)8b8e20e0f9900fae23baee55a91533a739c1a3ec
Mesa:		(master)d3912e301fd707738b0952cd11e19f34b87765b8
Xserver:		(master)2075d4bf9e53b8baef0b919da6c44771220cd4a5
Xf86_video_intel:		(master)1c68bc376a9cb3c0a010c8e28f69a776755c8f64
Kernel:       (for-linus)79f11c19a396e8cea7dad322dcfb46c0a8517fe6
Comment 6 liuhaien 2009-05-17 18:35:45 UTC
(In reply to comment #5)
> this bug happens again. we test it with:
> Libdrm:         (master)8b8e20e0f9900fae23baee55a91533a739c1a3ec
> Mesa:           (master)d3912e301fd707738b0952cd11e19f34b87765b8
> Xserver:                (master)2075d4bf9e53b8baef0b919da6c44771220cd4a5
> Xf86_video_intel:              
> (master)1c68bc376a9cb3c0a010c8e28f69a776755c8f64
> Kernel:       (for-linus)79f11c19a396e8cea7dad322dcfb46c0a8517fe6
> 

and it also happens on gm45 now.
Comment 7 liuhaien 2009-05-17 19:17:13 UTC
915gm also encounters the same issue.
Comment 8 Eric Anholt 2009-07-20 19:06:48 UTC
*** Bug 22491 has been marked as a duplicate of this bug. ***
Comment 9 Eric Anholt 2009-08-29 12:04:34 UTC
commit 16a1f68c391688a631d1d8d47cd1ac78800bcffc
Author: Brian Paul <brianp@vmware.com>
Date:   Mon Aug 10 15:48:02 2009 -0600

    intel: use new _mesa_meta_copy_pixels() function
Comment 10 fangxun 2009-08-31 22:39:46 UTC
verified with belowing commits:
Libdrm:         (master)73b59c894380995a2889b98e79acadd2da0bb237
Mesa:           (master)241c3a1d8001fc5a30e2af4b4636b48e6f99690a
Xserver:        (master)3be80bd98357cf362aa9a004d1292e5167d83a17
Xf86_video_intel:  (master)7c48c21b22bf5862c5a35bda1635753cc5a7197c
Kernel_unstable:   (drm-intel-next)5ff7fc632793f741ad0e41babb7b8de74c7450aa